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Learning AliasStudio
Tutorials

Learning Objectives

This chapter shows how to use the tutorials, and presents the graphic and text
conventions used in this manual.






How to use this book

Introduction

A general introduction and welcome to the AliasStudio tutorials.

Welcome to AliasStudio and the world of three-dimensional modeling, rendering,
and animating.

AliasStudio offers a complete solution for the creation of digital content in fields
such as industrial design, automotive design, and consumer product design.

About the Learning AliasStudio Tutorials

A general overview of the tutorials.

The tutorials in this book present examples of typical concept design workflows.
The tutorials introduce the powerful tools and interactive features of AliasStudio,
and demonstrate how to use them to accomplish your concept design tasks.

The first six tutorials introduce modeling tools to build your experience level.
We recommend that you start with the first tutorial and proceed sequentially
through the modeling tutorials, because they build on each other.

The next two tutorials introduce rendering tools and skills.
The last tutorial introduces animation tools and skills.

These tutorials are densely packed with information and techniques that may
be new to you. You may want to re-read the lessons after completion, or even
repeat the more difficult lessons.



You can view movies (in Flash format) demonstrating each tutorial in the
online documentation. In order to view these movies, you may need to install
a Flash player. You can download Flash plug-ins for your browser for free from
www.macromedia.com.

Disclaimer: There may be slight discrepancies in procedures between the
movies and the written documentation. If you encounter a discrepancy, use
the written documentation version because it will be the most current.

For More Information

Information on learning more about AliasStudio and training.

These tutorials are an introduction to AliasStudio. They are not intended as
an exhaustive guide to the capabilities and options of AliasStudio, and will
not teach you everything there is to learn about the products and workflows.

For additional information and more comprehensive explanations of tools
and options, refer to the online documentation included with the product,
and read Getting help on AliasStudio on page 7.

Graphic Conventions

Explains graphic conventions used in the tutorials.

MOVE: Use m

To call attention to part of a screen shot, we highlight the important area and
darken the rest of the image. For example, in the picture shown, we have
marked the location of the close box on the Action Window.

4 | Chapter | How to use this book



Terms

To indicate a click, we use this symbol. For example, in the picture shown,
we have indicated that the Open command should be clicked. In the text of
the instruction, we will refer to this as File > Open. The first word or term is
the name of the menu or palette; it is followed by an arrow and the name of
the menu item or tool. In the case of a submenu, two arrows are used: Layouts
> All Windows > All Studio refers to the All Studio menu item available from
the All Windows sub-menu, which is found on the Layouts menu.

To indicate that an option box for a tool or menu item should be opened, a
box appears after the tool name, like Surfaces > Skin q.

When we ask you to choose a tool, we show the tool’s icon next to the
instruction.

Ly

n,

Explains terms used in the tutorials.

Click: Move the mouse pointer over an object and press and release a mouse
button once.

Double-click: Move the mouse pointer over an object and press and release a
mouse button twice fast.

Drag: Move the mouse pointer over an object and hold down a mouse button,
then move the mouse with the button held down. Then release the mouse
button.

Terms | 5



Click-Drag: Move the mouse pointer over an object, press the mouse button,
and move the mouse pointer to a final position before releasing the mouse
button.

The Scene: The 3D “world” inside the view windows.

The Model: The curves, surfaces, and points that make up the object you are
creating.

6 | Chapter | How to use this book



Getting help on
AliasStudio

Welcome

Autodesk provides you with a number of resources to aid you in becoming a proficient
AliasStudio user.

Finding help on AliasStudio features

If: Try this
You want information about installing Ali- B Follow the on-screen instructions on
asStudio the installation CD. For more detailed

instructions, see the install .pdf file on
the top level of the CD.

You are new to AliasStudio B Read Getting Started, the booklet in-
cluded in the kit.

B Browse through the information on
the main documentation page (in-
dex.html).

B Read the About... section of the online
documentation. If you prefer, you can
print off the book, full of this informa-
tion, which is called AliasStudio Funda-
mentals.



Work through these tutorials in Learn-
ing AliasStudio. These are basic lessons
that will teach you about working in
3D in AliasStudio. They are also the
prerequisite for more advanced Ali-
asStudio courses.

Use the How To... section of the online
documentation to learn how to per-
form specific operations within AliasStu-
dio, like drawing curves, making four-
sided surfaces, and using masks while
painting.

Visit http://www.autodesk.com/estore
to find out about learning tools such
as Autodesk AliasStudio 13| Beginner’s
Guide aimed at the novice user.

You are upgrading from a previous version
of StudioTools

See the What's New in AliasStudio
document, available by selecting Help
> What'’s New in AliasStudio, or on the
documentation CD as a PDF file.

Look at the What's New tab in the de-
fault shelf provided with the applica-
tion.

You are looking for detailed information
about a tool or feature

Look in the “Tools and Menus” section
of the online help.

Choose Help > What's this and then
click the tool or menu item.

Use the right mouse button on the
background of any option window to
see help for that tool or operation.

You want to learn new techniques for using
AliasStudio

8 | Chapter 2 Getting help on AliasStudio

See Learning AliasStudio 2009.

See Technical Surfacing.



Go to the Communities section of ht-
tp://www.autodesk.com, and check out
the tips and tricks.

Visit http://www.autodesk.com/estore
to find learning tools aimed at interme-
diate and advanced users.

You want a PDF version of one of the
manuals

All of the manuals are provided in PDF
format in the PDF directory on the
documentation CD.

You want to know what the keyboard
shortcuts are in AliasStudio

Choose Help > Keyboard shortcuts
from within AliasStudio, or click Key-

board Shortcuts on the main online
help page.

You want a Quick Reference card B Print the Quick Reference card file
provided in the PDF directory on the
documentation CD.

Finding AliasStudio training resources

If... Try this...

You want to obtain in-depth training B See the learning materials and training
courses available from Autodesk, see

http://www.autodesk.com/training.

You want to get tips and techniques from B For events near you, see ht-

the experts at AliasStudio MasterClasses tp://www.autodesk.com/training.

Finding AliasStudio training resources | 9



You want to create plug-ins for AliasStudio

Use the AliasStudio Application Pro-
grammers’ Interface Manual to learn
the object-oriented programming re-
quired to build plug-ins.

You want information about becoming an
Alias-certified instructor

See the information at ht-
tp://www.autodesk.com/training or
contact us at learning-
tools@autodesk.com.

Finding support for AliasStudio

Try this

You are a Platinum member and want to
access the Knowledgebase or Ask Autodesk

Go to the AliasStudio support site at
http://www.autodesk.com/support

You want to interact with other AliasStudio B Go to the online User-to-User Discus-

users sion forum on the AliasStudio support
site at http://www.autodesk.com/sup-
port

You want answers to common B See the FAQs (frequently asked ques-

troubleshooting questions tions) in the technical support section
of the AliasStudio support website at
http://www.autodesk.com/support.

You want to license your software B If you are a Platinum member and

10 | Chapter 2 Getting help on AliasStudio

need a license, check the executable

license file on the top of your installa-
tion CD. If your license isn’t there, go
to http://www.autodesk.com/spar and
follow the instructions in the install


mailto:learningtools@autodesk.com
mailto:learningtools@autodesk.com

.pdf file at the top of the AliasStudio
CD.

B If you are a new customer, go to ht-
tp://www.autodesk.com/opa to obtain
a new license.

You want customer or technical support B Go to the webpage ht-
tp://www.autodesk.com/support.

Working with AliasStudio

If you create concept designs

B Read about our new concept design workflow

B Work through the modeling and rendering tutorials in Learning Studio
If you build 3D models based on sketches

B Work through the modeling tutorials in Learning AliasStudio

If you build 3D models for manufacture

B Read About Curves and About Modeling

B Work through the modeling tutorials in Learning Studio
B Check the community site for tips and tricks

If you modify 3D models for manufacture

B Read AliasStudio Fundamentals

B Work through the Technical Surfacing tutorials

If you create rendered images

B Read About Rendering

Working with AliasStudio | 11



B Work through the rendering tutorials in Learning Studio

B Check the community site for tips and tricks and downloadable shaders
and backgrounds

If you create animations

Do the work in the “If you create rendered images” section
Read About Animating

Work through the animation tutorials in Learning Studio

Check the community site for tips and tricks

12 | Chapter 2 Getting help on AliasStudio



Interface Basics

Learning objectives

You will learn how to:
Log into the system and start AliasStudio.
Arrange windows.
Use tools and tool options.

|
|
|
B Customize shelves and marking menus.
B Tumble, track, and dolly the view.

|

Use the Obiject Lister window to understand the model.

Introduction

Before you begin working in AliasStudio, you should spend some time learning
how AliasStudio represents the scene and the model (both externally and
internally), and how you use menus and tools to create and edit model data.

Installing the tutorial courseware files

Each tutorial in this book is based on an Alias wire file, which contains the
material you need to learn the tools, skills, and concepts in the tutorial.

When you install AliasStudio, the courseware files are not automatically installed.
These files are required to complete the Learning AliasStudio and Technical
Surfacing tutorials.



If you have installed the online documentation, your courseware may already
be installed. If not, follow the following procedure to install the courseware.

To install the courseware for use with AliasStudio:

The courseware files (Alias wire files and other support files) are automatically
installed when you install the documentation from the AliasStudio
Documentation CD.

1 If you have not yet installed the documentation, place the AliasStudio
Documentation CD in your CD-ROM drive and proceed with the
installation.

NOTE You will require write permissions to the directory in which you plan
to install the online help and courseware files.

If you want to install only the courseware files, go directly to your disk
drive and find the CourseWare folder on the disk.

2 Copy the courseware folder from its location on your hard drive or
CD-ROM drive into your user_data folder.

On Windows systems, this is typically:

C:\Documents and Settings\[userid]\My Documents\AliasStu
dio\user data\CourseWare

To install the courseware for use with AliasStudio Personal Learning
Edition

1 The AliasStudio documentation should have already been installed on
your system. The courseware files you will require to perform the tutorials
can be found in the CourseWare directory, located under the Help
directory. If you have installed the application in the default directory,
you should find the CourseWare directory at C:\Program
Files\Autodesk\AliasStudio2009\Help.

2 Copy the courseware directory from the Help directory to your account’s
user data directory.
On Windows systems, this is typically:

C:\Documents and Settings\ [userid]\My Documents\AliasStu

dio\user data\CourseWare

14 | Chapter 3 Interface Basics



Starting AliasStudio

Logging In
If you have not logged in to your account on your workstation, do so now.
To log in to your account

B Type your user name and password at the prompts.
If you have an account on this workstation, the operating system user
environment will appear.

Depending on which product you are using, the AliasStudio icon may have
a different name, such as DesignStudio or AutoStudio.

To start AliasStudio on Windows

1 Double-click the AliasStudio 2009 shortcut icon on the desktop, or choose
AliasStudio 2009 from the Start menu. When you start AliasStudio for
the first time, the Application Launcher appears on your desktop.

2 Choose a product to launch and options where applicable. If you want
AliasStudio to launch the selected product and options automatically
every time you start AliasStudio, click Set Default. When you start
AliasStudio again, the default product starts and the Application Launcher
does not appear. You can change the default settings anytime by choosing
Application Launcher from the Start menu.

3 Click Launch. The chosen product should start.

4 If the main AliasStudio window appears, AliasStudio is installed.

The Start-up Process

The first time you run AliasStudio, you may be presented with a choice of
product to launch, if you work in an environment where there are several
AliasStudio products installed. The product choice will depend on the licenses
owned by your organization.

1 Choose the product you want to run, and click Go.
Next, you will be presented with a workflow selection.

Starting AliasStudio | 15



2 For the purpose of these tutorials, choose the Default workflow, which
gives you access to all 3D curve and surface creation tools.

The Paint workflow is for working solely within a 2D environment. You
can click the Do not show again check box, so this window will not
appear every time you launch AliasStudio. If you have chosen a workflow
setting and checked Do not show again, you can change the default
workflow by choosing the workflow you want from Preferences >
Workflows. AliasStudio will launch the application in the same workflow
that was active when you last exited the application.

AliasStudio shows a splash window as it loads.

During start-up, AliasStudio may warn you about unusual conditions on
your system:

B If you are already running AliasStudio (or if AliasStudio exited
abnormally the last time you ran it), the application will ask you if
you really want to start another copy.

3 If you are sure AliasStudio is not running, click Yes to continue loading.

After AliasStudio has finished loading its resources and plug-ins, the workspace
window opens.

Overview of the AliasStudio Interface

Menu Bar Control Panel

Palette Shelves

16 | Chapter 3 Interface Basics



The main parts of the AliasStudio interface are:
B the Palette, located on the left
B the Menu Bar, located at the top

B the Window Area, taking up most of the interface and located in the middle
(this area may or may not contain view windows when you first start
AliasStudio).

B Shelves, located at the bottom (the Shelves may or may not be visible)

B the Control Panel, located on the right

As you continue through this tutorial, you will become more and more familiar
with the AliasStudio interface.

Using Help

One of the most important menus is the Help menu. The Help menu is
organized so you can get quick and specific information on just about any
tool in AliasStudio.

To get help on a tool or menu item

It is easy to get help on any tool or menu item in the interface. Just follow
the steps below.

1 Click the Help menu, located at the right end of the menu bar.

Preferences Ulifities —
| Mmag |

2 In the Help menu, click What’s This?

Using Help | 17



Contents. ..
Toal Iocatqr
What's Thisgl—
Modifier kﬁ!ys. -

What's Mew, ..

Learning Movies. ..

Tutarials. ..

You are prompted to select the tool for which you want help. (This prompt
appears in the prompt line, located just below the menu bar.)

r lavowts ObjectDisplay  Displayial
&| Select function that you want help on.

3 Click a menu item or a tool icon in the Palette.

A browser window is launched and the on-line documentation about
that tool icon or menu item is displayed.

4 When you are finished reading the information, minimize or close the
browser window.

Arranging Windows

Performing Menu Commands
To use the menus to choose a window layout

1 Click the Layouts menu to open the menu.

File FEdit Delete Layv%s ObjectDisplay
[%  object <= | Optionk r%tored from fu/mch;
Defaulttayer [ || I[

NOTE Notice the arrow next to the All windows item. This means there are
more sub-options for this category:
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2 Click the All windows item to open the sub-menu, then click the All
windows item.

The All windows command arranges view windows in the following
layout: Top, Left, Back, and Perspective.

Arranging Windows | 19



These tutorials will sometimes refer to menu items by the path through
the menus to the item. So, All windows will be: Layouts > All windows
> All windows .

As an alternative to the single-click method, you can use the pull-down
menus by dragging the mouse down the menu and releasing on the item
you want.

Window Controls

Use these controls on the borders of view windows to move, close, and resize
the window:

Close box

Maximize box

Resize corners (4)
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The view windows have more controls across the top, but for now, you will
concentrate on the close box, title bar, maximize, and resize corners.

You will discover the functions of the other icons later in the tutorials.
Closing Windows

To close the Top view using the close box

B Find the close box in the upper left corner of the Top view window.

S

B Click the Top view window’s close box.

The Top view window disappears.

Resizing Windows

You can change the size of windows using the resize arrows at each corner.

To change the size of a view window using the resize arrows and
maximize box

1 Find the resize arrows in the corners of a view window.
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2 Drag a resize arrow to change the size of the window. An outline of the
view window follows the mouse.

3 Release the mouse button. The corner of the window snaps to the new
size.

4 Try dragging the resize corners in the other corners to see how they resize
the window.

B Often you will want to work in one large window to see more detail.
Use the maximize box to temporarily make the view window fill the
entire screen.

5 Find the maximize box in the upper right corner of a view window.
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6 Click the maximize box of the view window.

-

The view expands to fill the entire screen.

Notice that the maximize box changes to black to show the window is
maximized.

7 Click the maximize box again to return the view window to normal size.

Moving Windows
To move and arrange the remaining windows

1 Find a view window’s title bar.

The title bar is the area at the top of the window, between the close box
and the other icons on the right.

2 Drag the title bar. An outline of the view window follows the mouse.

Arranging Windows | 23



3 Release the mouse button. The window snaps to the new location.

4 By now you probably have some view windows overlapping other
windows, similar to this:

The windows are like a stack of papers on a desk. As you shuffle them,
they can overlap.
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When windows overlap like this, you can click in a window to move that
window to the front of the stack.

5 Click the title bar of the Perspective view window to move it in front of
the other windows.

The windows are probably a little disorganized at this point. You can
quickly reset them to a default layout using the commands in the Layout
menu again.

6 Choose Layouts > All windows > All windows.

Arranging Windows | 25



The Active Window

Notice one of the view windows has a white border. This is how AliasStudio
indicates the active view window (sometimes also called the current view
window).

The active view window is always the last view window you clicked in.

Some tools change behavior based on which view is active, but for now you
can disregard which view window is active.

Saving an arrangement of windows

If you have a particular choice of windows that you plan to use repeatedly,
you can save the set by choosing Layouts > User windows > Save Current
Layout. You will be prompted for a file name. To use this layout in the future,
choose Layouts > User windows > Retrieve Layout.

Using Tools

Describes how to use the AliasStudio interface, such as selecting tools and
creating shortcuts.

Tool Basics
To orient yourself in the Palette window

1 Find the Palette window on the left side of the screen.

If the palette is not visible, go to the Windows menu and choose Palette.
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The Palette window is divided into separate palettes of tools, each labeled
with a tab at the top.

For example, the Curves palette contains tools for creating new curves.
The Curve Edit palette contains tools for editing and reshaping existing
curves.

2 Find the Surfaces palette. It is the seventh palette from the top of the
window.

Surfaces h

o

Yo ¥
(d
s>%

NOTE If you cannot see the Surfaces palette, use the scroll bar on the left
side of the palette window to scroll up or down until it is visible in the window.

3 Hold the cursor over a tool.
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The name of the tool appears in a small box just below the icon. This
small text window is called a tooltip.

| Surfaces

By
o
S %

This feature can help you to identify tools until you become familiar with
the icons in the palette.

NOTE Once you are familiar with the icons in the palette, you may want to
disable tooltips. To do this, choose the Tooltips option in the Interface section
of the General Preferences window (Preferences > General Preferences - p).

Now you will use the geometric primitive tools to add some geometry to the
scene. The primitive tools create simple 3D geometric shapes such as cubes,
spheres, and cones.

As a technical surfacer, you may not regularly need to add these simple shapes
to a model. However, they will allow us to practice several AliasStudio interface
concepts, including choosing tools, using manipulators, sub-palettes, tool
option windows, and snapping.

To create a primitive sphere in the scene

1 Click the Surfaces > Primitives > Sphere tool.

2 Ared outline appears around the icon to show it is the current tool.

3 Click in the Top view window to place the new sphere.
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A new sphere, one grid unit wide, appears where you release the mouse
button.

Using a Snap Mode

To use grid snapping to place a primitive cube

You may have noticed that some tools have a small yellow arrow in the top
right corner.

These arrows indicate that more, similar tools are available in a hidden
sub-palette. To access the extra tools, you must click and hold the mouse to
open the sub-palette.

1 In the Surfaces palette, click and hold the Sphere tool icon.
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2 The Surfaces > Primitives sub-palette pops out.

T
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oY | »

3 Hold the middle mouse button on the different tools in the sub-palette to
see their names.

4 Click the Cube tool.

“O“a‘il%\

The sub-palette disappears. The Cube tool is selected and now occupies
the space in the main palette where the Sphere tool was.

-
LR X 4

9 o

This time you will place the new primitive using grid snapping.

SRR

5 Find the snap buttons, to the right of the promptline.

Q2D

6 Click the Grid I I button to turn on grid snapping.

7 Click and drag in the Top view window.
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The cube snaps to the grid intersections as you drag.

8 DPlace the cube at a grid point by releasing the mouse button.

9 Click the Grid I I snap button again to turn grid snapping off.

NOTE In addition to using the Grid I I button, you can grid snap by
pressing and holding the Alt button while you place a primitive.

To use the palette menu to choose the Cone tool

This time we will show you an alternative method for choosing tools from
palettes.

1 Click the tab at the top of the Surfaces palette.
|

W . Sufaces |
) =] a ] —-
‘ ‘ * ] Surface Edit

e fEce
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The palette collapses down to just the tab, and the other palettes move
up to fill the space.

This feature is very useful for saving space in the palette window and in
shelves. You can still choose tools from the palette using the palette’s
menu.

2 Click the right mouse button on the Surfaces palette’s title tab to open the
palette’s menu.

3 Click the Primitives item to open the sub-menu.

Surfaces !
Prirmitives| | — [= ‘

Surface Edit |
Set planar

a. b 0O, =
ﬁ ‘- ‘ Revalve ]

Just like the menus at the top of the screen, arrows indicate that an item
in the palette menu has sub-items.

4 Click the Cone tool item.

Surfaces
Prirnikives

| Sphere [

=
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BE e 0| o
g o8 7 s | e[|
Swept supfares = cube |
Plane m

You have now seen two different ways to choose a tool from a palette.
From now on, we will ask you to choose tools by name, such as:

“In the Surfaces palette, choose Primitives > Cone.”

Whenever you are asked to choose a tool, you can either click the tool
icon, or choose the tool from the palette menu.

5 Click in the Top view to place a cone in the scene.
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6 Click the Surfaces palette’s tab again to expand the Surfaces palette back
to normal.

To use tool options to add a half-cylinder

1 With the right mouse button, click the title tab of the Surfaces palette to
open the palette menu, then open the Primitives sub-menu.

Notice that some items have shadowed boxes next to the name of the

item.
| Prirnitives [ Sphere O3
Surface Edit — =
et planar
; W o pl Torus m)
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 Skin a
- R 7 core 0
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2 Click the shadowed box next to the Cylinder item.
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3 The Cylinder options window appears.

:Eylinder Options |

. Cylinder

Object Degree

o
SWeED I 360.00 deg

Sections I i ”
Caps z |

4 Double click in the text box labeled Sweep, then type 180 and press Enter
to set the sweep to 180 degrees.

SWEEP 180, deg
Sections g |
Zaps z |

5 Use the slider next to the Sections text box to set the sections to 4.
SWEER I 1580.00 | deg
Sections I 4 —l]k
Caps 2I |

6 Click the Go button at the bottom of the window.

|
Reset ‘ Save ‘ Exit | -Gw
[

This button applies the settings in the window and activates the tool.

7 Click in the Top view window to place the new half-cylinder in the scene.
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As you specified in the option window, the cylinder has a 180-degree
perimeter and is created from four sections (spans).

8 Look at the Cylinder tool icon. It has a small option box symbol in the
top left corner.

F92
Ye¥

(Ot O’ o,

Like the symbol in the menu, this indicates the tool has options.

9 Double-click the Cylinder tool icon.
The Cylinder Options window appears.

10 Click Exit to close the options window.

Picking and Unpicking Objects

Picking refers to selecting objects in the scene for use with other tools. For
example, to move a CV, you must pick the CV, then use the Move tool on
the picked CV.

Picking objects in the scene is a fundamental part of modeling with AliasStudio.
Because it is so important, AliasStudio provides several different tools for
picking.
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To pick all and pick nothing

1 In the Pick palette, choose Object types > All objects/lights.
2 All the objects in the scene highlight to show they are picked.

Unlike most selection tools, Pick > Object types > All objects/lights does
not stay selected, since you never need to use it twice in a row.

When these momentary types of tools finish, the current tool reverts to
the last continuous tool you selected.

3 In the Pick palette, choose the Nothing tool.

4 The Pick > Nothing tool unpicks every object, leaving nothing picked.
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Like the Pick > Object types > All objects/lights tool, the Pick > Nothing
tool does not stay selected. The current tool reverts to the last tool you
used.

To pick and unpick individual objects

1 Choose the Pick > Object tool.

2 Click the cone primitive in the view windows with the left mouse button.

The cone highlights to show it is picked.

3 Click the other objects with the left mouse button. They also become picked.

4 With all the objects picked, click one of the picked objects with the left
mouse button.
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The object you clicked becomes unpicked.

The left mouse button toggles objects between picked and unpicked.

5 Now click one of the primitives with the middle mouse button.
The object you clicked is picked and the other objects are unpicked.

The middle mouse button picks only the object you click.

6 Click the picked primitive with the right mouse button.
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The object is unpicked.

The right mouse button unpicks objects. This is most useful with pick boxes,
as you will see in the next procedure.

To use pick boxes to pick and unpick several objects at once

1 With the Pick > Object tool still selected, click one of the primitive objects
with the left mouse button.

2

3 Press the left mouse button and drag a box around all the primitive objects.
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All the objects inside the pick box toggle between picked and unpicked.

4 Now drag a pick box with the middle mouse button around some objects.
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Now only the objects inside the box are picked.

5 Now drag a pick box with the right mouse button around some of the
picked objects.

Any obijects inside the pick box are unpicked.

To pick by name

1 Use the middle mouse button to pick only the sphere.

2 From the Windows menu, choose Information > Information window.
The Information window appears.
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The information window allows you to adjust parameters for objects in
the scene.

3 Find the Name field. The name of the object should be sphere or
something similar.

4 Close the Information window.

5 Click in empty space with the middle mouse button.
All objects in the scene are unpicked.
B Remember, the middle mouse button picks only what you click. If

you pick “nothing” (empty space), then the tool acts as if you had
chosen Pick > Nothing.

6 Type sphere, then press Enter. The text appears as you type in the
promptline at the top of the workspace window.

When you press Enter, the sphere is picked.

Shortcuts to Tools

The variety of tools available is the source of AliasStudio’s power, but finding
tools in the palette can become potentially time consuming. You can make
commonly used tools available more quickly, and hide rarely used tools until
you need them.

AliasStudio provides three solutions: shelves, marking menus, and hotkeys.

Shelves are like the palettes, except you control the tools’ options and their
position on the shelves. You will use shelves to organize all your commonly
used tools.
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Marking menus pop-up at the current mouse location. They provide a very
fast method to choose the tools you use most often (such as Pick > Object).

Hotkeys are special key combinations that perform common menu or tool
commands.
Creating Custom Shelves

To show and hide the shelf window

1 In the Windows menu, choose Shelves.
The Shelves window appears.

B The Shelves window provides a floating window in which to keep
commonly used tools.
AliasStudio, however, provides another, even more convenient location
for shelves. In these tutorials, you will use the shelf area in the control
panel.

B Since you will not be using the Shelves window, you can close it.

2 Choose Windows > Shelves again to hide the Shelves window, or click
the Shelves window’s close button.

To help demonstrate how to make new shelves, you will clear the default
shelves and make new shelves specific to these tutorials.

Before you clear the default shelves, you will save them, so you can retrieve
them later.

To save the initial shelf set

1 Choose Windows > Control Panel. The control panel will appear.

2 Hold the left mouse button on the Shelf Options menu button at the top
of the control panel’s shelf area to open the pop-up menu.
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3 Drag down to the Save item and release the mouse button.
A file requester appears.

4 Click in the Object name text field and type pefault, then click Save.

In the next procedure, you will start a new shelf of tools commonly used in
curve fitting in preparation for the lesson on fitting curves to scan data.

To clear the existing shelf set and create a new one
1 Hold the left mouse button on the menu button at the top of the shelf area

to open the pop-up menu. Notice how the menu button is now called
Default, after the name of the current shelf.

2 Choose New from the pop-up menu.
A requester appears asking for the name of the new shelf.

3 Clickin the text box, hit the Esc key to clear the text, and type curveFit.
Click OK to name the new shelf.
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The old Shelf set is deleted and a new, empty shelf appears in the shelf
area.

Now you can begin adding tools to the new shelf.

4 In the Palette window, find the Curve Edit palette.

VAR~

dupl add pts brk infl
TR
rebuild oroj tarcey plnr

%D @

v sckn fit cry sk sckns

5 With the middle mouse button, drag the Fit Curve tool onto the CurveFit
shelf in the control panel.

WL CurveFit
o, -
) &,

. ¥

dupl add pts brkinfl

R

rebuild aroj kancry ginr

fit crv

Fey C

The tool appears in the shelf.

Defaul: 3
CurveFit .

CurveFit

Using Tools | 45



You could move the entire Curve Edit palette onto the shelf by dragging
its title tab, but you only want a selection of tools from the full palette.

Next, you will add curve drawing tools to the palette.

Since you will often need to create curves of different degree in technical
surfacing, it would be useful to have customized versions of tools with different
settings.

The shelf allows you to do this. When you drag a tool onto a shelf, the new
copy of the tool keeps the settings it had when it was dropped on the shelf,
independent of the original tool in the palette.

Using this technique, you will create several versions of the two original curve
creation tools, New curve (edit pts ) and New curve (cvs).

Each version will have different settings for the Degree option.

To add versions of the New curve tools to the shelf with different
options

1 In the Curves palette, double-click New curves > New Curve by Edit Points
and open the tool’s option window.

2 (Remember that you can also choose New Curve by Edit Points from the
palette menu).

The New Curve by Edit Points option window appears.

New Curve (Edit Points) Options

N Mew curve (edit poink)

knot Spacing
Chord
; :

Curve Degree

Create Guidelines

Reset Save Exit Go

The options let you set the knot spacing (parameterization) and degree
of the new curve.
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Make sure Knot Spacing is set to Uniform and Create Guidelines is off.

Set the Degree option to 2.

Find the tool icon at the top of the option window.

N Tew curve (edit point)

Enok Spacing
Chord

This icon represents the tool as configured with these settings.

Press the middle mouse button on the tool icon at the top of the option
box and drag it to the CurveFit shelf.

CurveFit
N New curve (edi poink) %
= Ry ¥
- chord
Curve Degree
o a2l s
5 T

Creste Guidelines |

pom | s | x| e |

Now when you choose this icon in the shelf, the New Curve (edit pts)
tool will create degree 2 curves.

Back in the option window, set the Degree to 3.

Use the middle mouse button to drag the tool icon at the top of the option
window to the shelf.
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Another copy of the tool is added to the shelf. When you choose this
copy of the tool, the New Curve (edit pts) tool will create degree 3 curves.

9 Click Exit at the bottom of the option window to close the window.

To rename the tools

1 Move the mouse over the CurveFit shelf’s title tab and press the right
mouse button to show the shelf’s menu.

Note that the two versions of the tool have the exact same name and
icon.

To be able to distinguish between the tools, you will rename them.

2 Find the first version of New Curve by Edit Points you dragged to the
shelf.

If you cannot remember which is which, double-click the two icons to
see their option windows. You want the version with the Degree option
set to 2.

3 Hold down the Ctrl key and double-click the tool icon.
A name requester appears.
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Enter Tool Label

ed pt cry

4 Double-click in the text box and type Edit pt Deg 2, then click OK to
rename the tool.

5 Hold down the Ctrlkey and double-click the second copy of the
New Curve by Edit Points tool.

6 Double-click in the text box and type Edit pt Deg 3, then click OK to
rename the tool.

7 Hold down the right mouse button on the title tab of the shelf to open the
shelf menu.

. Cuverit

The two copies of the tool are now distinguishable in the menu, but still
have identical icons.

We recommend you keep the shelves collapsed and use the shelf menus
to choose tools. This saves space in the shelf.

To remove a tool from the shelf

1 Add another tool to the CurveFit shelf.

Let’s now assume that this was a mistake and you wish to remove the
tool.

2 Hold the middle mouse button over the tool’s icon in the shelf.
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CurveFit

The name of the tool appears.

3 With the middle mouse button held down, drag the label to the upper-right
corner of the window and position the cursor over the trash can icon.

4 Release the mouse button. The tool disappears from the shelf.

You can also delete groups of tools by dragging a tab with the middle
mouse button to the trash can.

You may have noticed that icons are a bit crowded on the shelf. The large
icons are good when you are learning which icon is which, but now you will
switch to the small icon size to save space in the shelf.

To change to the small icon size

1 In the Preferences menu, choose General Preferences - p. The Interface
options appear.

50 | Chapter 3 Interface Basics



™ General Preferences
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Set the Tool Icons to Small.

Tool Icons
wo Text
. Medium . Large

If you wish, you can also turn on the icon labels option to display name
labels for all the icons.

Click the Go button at the bottom of the window to apply the changes.

Rieset ‘ Save ‘ Exit: | [€1a] |

AliasStudio loads smaller versions of all the tool icons.

You have seen how to create shelves with customized tools. In later lessons,
you will load pre-made shelves containing all the tools you need to complete
the tutorials.

Using and Customizing Marking Menus

An even faster method for selecting tools is the marking menus. Marking
menus generally hold fewer tools than a shelf, but are much faster since you
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can use quick gestures to choose tools. With practice, selecting tools with
marking menus becomes almost instantaneous.

To choose common tools with marking menus

1
2

Hold down the Shiftand Ctrlkeys.
With the keys held down, hold the left mouse button.

Hothing
emplate O o
@ject.

The left mouse button marking menu appears at the location of the mouse
pointer.

Keep the left mouse button held down and drag down until the Pick >
Obiject box is highlighted.

A thick black line shows the direction of the mouse pointer.

Release the mouse button to choose the highlighted tool.
The Pick > Object tool is now the current tool.

Hold Shift and Ctrl with the middle, then with the right mouse buttons
to see the other marking menus.

Each mouse button has a separate marking menu.
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Once you have learned which direction corresponds to which tool in a
marking menu, you can use a quick gesture to choose the tool.

6 Hold the Shift and Ctrl keys, then drag up and release the mouse button
quickly.
The black line shows the direction, but the menu is not drawn.

When you release the mouse button, the marking menu flashes the name
of the selected tool on the screen.

You have just selected Pick > Nothing.

Use this method to choose tools even faster once you have mastered the
positions of the tools on the menu.

Learn which tools are on the marking menus, and use the marking menus
whenever you need to choose one of those tools. The more you use them, the
faster you will become, until you can choose tools with quick gestures.
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To customize a marking menu with common tools

1 In the Preferences menu, open the Interface sub-menu and choose
Marking Menus.

The MarkingMenus shelf window appears.

MarkingMenus
Eﬂ Selection I@ Translation IEﬁ Display ]

NECER W

Trash nothing editp  cv  curves object  surfac blend [ourve-o

This is a special shelf window. The tools and menu items on the different
tabs appear in corresponding marking menus.

MarkingMenus
Eﬂ Selection I@ Translation [&3 Display l

Middle . o
PR Pewil g
Trash move move| scale  centerrotate nonpriguery elete o

MarkingMenus
. &5 Selection ]@ Translation I&ﬂ Display |_
Y YL e
Trash informashade{ghadelfontrols :ontrols kogale oggle n

The procedure to modify the content of marking menus is similar to the
one for modifying shelves that we learned earlier.

Here you will make a small modification to the Selection marking menu
shelf.

2 Double click the Pick > Locator tool in the Palette or Control Panel to
open the Pick Locator Options box.
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Pick Locator Options

j Locakar

Measurement |7

Deviation |7

Others |7

Reset | Save ‘ E:xit |

Go |

3

4 Hold down the middle mouse button and drag the tool icon from the top
of the option box and drop it between the third and fourth last icons on

the shelf.

-

MarkingMenus

E:H Selection [@ Translation

I ['_':! Display

B NS EREN

Trash nothing editp cv  curves object blenc
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Pick Locator Options

i cakar

Measurement |7

Deviation |7

Others |7

Reset | Save | Exxit ‘

Go ‘

You now have a tool on the marking menu to pick locators.

MarkingMenus
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5 Hold down Shift and Alt keys and press the left mouse button to show the
marking menu again.

Hothing |
Templae | EaP
Srtace| O v

pick-»Pick focaor| | Gate 1]
cos.

The tool you just added is called Pick > Pick locator in the marking menu.
You will change the name to something more concise.

6 In the MarkingMenu shelf window, hold down theCtr/ key and
double-click the Pick locator tool in the shelf (second from the right).

7 A dialog box appears.

8 Type Pick locator in the text field and click OK to rename the tool in the
marking menu.

9 Show the left mouse button marking menu again.

You now know how to customize the marking menus. In later lessons, you
will load pre-made marking menus with common surfacing tools.
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Using hotkeys

Hotkeys are special key combinations that choose tools or perform menu
commands. You can get a complete listing of all the hotkeys in the hotkey

editor.

To use hotkeys

1 Inthe Preferences menu, open the Interface sub-menu and choose Hotkeys

/ Menus.

The hotkey editor appears.

Hotkeys / Menus...

M=%

Function Titles

Default Workflow
Short Menu Display

Haotkey
Defines

+ Menu
+ shelf
+ Palette
+ BookMarks
+ Duplicate Place Toolbox
+ Conform Rig Toolbox
+ Eend Rig Toolbox
+ Twist Rig Toolbax
%‘ + Lattics Rig Toolbox
Apply

B AliasStudio’s option windows use a hierarchy similar to that of the
File Lister: options are organized into hierarchical sections that can
be collapsed and expanded.

2 In the Menu section, click the Layouts sub-section title to expand it.
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Click to open a Section Heading.

You can see the hotkey for the User windows item, as well as text fields

for defining other hotkeys.

You can define your own hotkeys, if you wish. For the most part, we will

not use hotkeys in these lessons.

If you are new to Autodesk AliasStudio products, we recommend that
you spend some time working with the product before you define hotkeys,
so you can learn which commands you use frequently enough to need a

hotkey.

3 Click the close box to close the hotkey editor.

Changing Your View of the Model

Learn how AliasStudio represents the 3D model on your 2D monitor, and how
to use the view controls to get the best possible angle on the model for the

task at hand.

Tracking, Dollying, and Tumbling the Camera’s View

There are many different ways to change the camera’s view in AliasStudio.

In general, you will only need to learn three camera moves to model effectively:

tumble, dolly, and track.
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Tumble Dolly

mt
rotate

Track

up
right

Because these camera movements are so common, AliasStudio uses special
hotkey/mouse combinations to access these movements quickly.

To use the camera move mode to move the camera in a perspective
window

1 Hold down the Shift and Alt keys.
Keep the keys held down during the following steps.

2 Make sure the mouse pointer is over the perspective view window.
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3 Drag the left mouse button to tumble the camera:
B Drag left and right to rotate the camera.

B Drag up and down to tilt the camera.

Tumbling the camera changes the azimuth and elevation angles of the
camera.

4 Release the left mouse button, but keep the Shift and Alt keys held down.

5 Drag the right mouse button to dolly the camera in and out.
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Dollying moves the camera forward and backward.

6 Again, release the right mouse button, but keep the Shift and Alt keys held
down.

7 Drag the middle mouse button to track the camera.

Tracking moves the camera, but does not change the direction in which
the camera is pointing.

8 When you are done moving the camera, release the mouse button and
the Shift and Alt keys to exit camera move mode.
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Now, try moving the camera in the orthographic windows.

To use the camera move keys to move the camera in an orthographic
window

1 Hold the Shift and Alt keys to enter camera move mode.

2 Make sure the pointer is over an orthographic window such as Top, Side,
or Back.

3 Drag the right mouse button to dolly in and out.

4 Drag the middle mouse button to track up, down, left and right.
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5 Now try dragging the left mouse button to tumble the orthographic view.

Nothing happens. You cannot change the view direction of orthographic
windows. They always look in the same direction.

Moving the camera is a very important skill in AliasStudio. Throughout this

book, you will need to move the camera to work with geometry.

Using the camera move mode soon becomes second nature. With practice,
you will be able to move the camera where you need it without thinking about
the keys or the mouse.

Practice tumbling, tracking, and dollying the camera around the model some
more before you move on.

To use Look At to center on an object

1 Use the marking menus to choose the Pick > Nothing tool.

2 Remember that the left mouse button marking menu has the pick tools.
3 Now use the marking menus to choose the Pick > Object tool.
4

Pick one of the geometric objects you created earlier.

Changing Your View of the Model | 63



5 Find the View palette. It is near the bottom of the Palette window.

6 Choose the Look at tool.

e
|

£ 4

The active view window (the window with the white outline) changes
to center on the picked object.

8 Pick nothing.
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9 Use the Look at tool again.

10 The active view changes to center on all the existing geometry.

When you use Look at with nothing or everything picked, the view will
center on all the geometry in the scene.

Look at is most useful to quickly find geometry that is outside the view of a
window or too far to be seen clearly. AliasStudio provides two additional tools
to make it easier to move the camera around a model quickly: the “point of
interest” and Viewing Panel.

Changing the Point of Interest

Normally, camera move mode (Shift+Alt) is calibrated to best view objects at
the origin (the center of world space, coordinate 0,0,0). This can become
awkward when you want to move the camera around objects away from the
origin.

The point of interest manipulator lets you center the camera movements on
a point on the model.

To use the point of interest manipulator

First, make sure the point of interest manipulator is turned on.

1 Choose Preferences > General Preferences r.
The General Preferences window appears.
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General Preferences

&
Interface General Preferences
Input

Madel Windows Default keyboard entry mode
Madeing Relative
Paint Altjshift Action
Visualization AzimuthfTwist
Animation View Step Angle a5
System Allow foxs Constrained Tumble |+
Miscellaneaus Constraint Senskivity 3
Use pick chooser | v Dolly ko Mouse
Use point of interest |+ Dolly ToPoint | v

Arrow key step size 1

Mouse mapping for perspective move

©On ground plane Left=¥ Mid=Y Right=2

On construction plane Left=Free Middle=5 Right=Y

Reset Save Exit GO

Click Input on the left-hand side to open the Input section.
Turn on the Use point of interest option.

Click Go to close the window and use the new settings.

wn A W N

Hold down the Shift and Alt keys to enter camera move mode. Keep the
keys held down for the rest of this procedure.

W Viewing Panel

g + e
Y= (R
& i s
Lookat @,
Plane view |

Perspective

BookMarks

Coew ][ edit_]

The Viewing Panel appears in the upper left corner of the Perspective
window.

The images at the center of the panel (small icons of the top and bottom
of a car) represent the model.
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6

10

Position the mouse pointer on the wireframe of one of the primitive
objects and double-click with the left mouse button.

When you release the mouse button, the point of interest manipulator
appears on the model where you clicked.

Drag with the left mouse button to tumble. The view tumbles around the
point of interest.
Click and release on another point on one of the primitive objects.

The point of interest manipulator jumps to the new point.

Drag the circle at the center of the point of interest manipulator.

The manipulator moves across the surface of the object.

Notice the light blue or yellow arrow extending from the center of the
manipulator. This arrow indicates the normal at this point on the surface.
The arrow is light blue when it is pointing toward you and yellow when
pointing away.

Click the light blue or yellow arrow.

The view changes to look at the point down the normal.
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11 Now look for the red and green arrows extending from the center of the
manipulator (tumble the view to show the arrows more clearly, if
necessary).

These arrows represent the tangents along the U and V directions of the
object.

12 Click the red arrow.
The view changes to look down the tangent in the U direction.
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Use the following overview illustration as a reminder of the different controls
on the point of interest manipulator.

Clickthe red or green arrow to
look at the tangent along the
U ort direction

Click the light
bluedtyellow arrow to
Drag the circle to look down the
rmove the paint of harmal atthis paoint
interest along or

across the abject
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Using the Viewing Panel

1| " Viewing Panel

gl 1+ K
Y CoT e
& i 5
lockat @,
Plane view [_]

|| Perspective
|« =R

BookMarks

Cosw ][ ediz_]

You have probably already seen the Viewing Panel appear when you enter
camera move mode in the Perspective window. This window lets you quickly
switch the Perspective window to a default or user-defined view of the model.

As you work on the model, you will probably find yourself changing the
camera view back and forth between two or more areas of interest. The Viewing
Panel lets you “bookmark” views of the model and return to those views by
clicking the name of the bookmark.

To use the Viewing Panel to move between different views

1 Click the maximize box in the upper right corner of the Perspective view
window.

The Perspective view window enlarges to full screen.
2 Open the General Preferences window and click Go.

3 Hold down the Shift and Alt keys to enter camera move mode. Keep the
keys held down for the rest of this procedure.
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w Viewing Panel
5| LL g
2 2]l &
L2 it ke
Lockat @
Plane view ||
Perspective

BookMarks
Coep [ edit ]

The Viewing Panel appears in the upper left corner of the Perspective
window.

The images at the center of the panel (small icons of the top and bottom
of a car) represent the model.
4 Click an arrow to view the model from one of eight different directions.

The horizontal and vertical arrows represent front, side, and back views.
The diagonal arrows represent three-quarter views.

5 Click the left car icon to see a top view, or the right car icon to see a
bottom view.
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6 Click the white arrow near the bottom of the Viewing Panel to return to
the view previous to your last camera move.

w Viewing Panel

4 8 v
=T
a ¢ &

=

Lockat @
Plane view [_]
Perspective

BookMarks
Coen 1 edit_]

7 Click the Viewing Panel section heading at the top of the panel to collapse
the entire panel into a small heading.
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s Viewing Panel |:

(2

5 L s

Use this technique to get the Viewing Panel out of the way when you
want as much viewing area as possible.

Using the Point of Interest manipulator

1 Hold down the Shift and Alt keys, then press the left mouse button to open
the Viewing Panel. Keep the keys held down for the rest of this procedure.

NOTE If the Viewing Panel does not appear, ensure that you are not clicking
the left mouse button before holding down Shift and Alt .

w Viewing Panel

g I 73
= &0 @
2 i 5
Lockat @
Plane view [

Perspective

BookMarks
Coew [ edit |

2 Double-click an object. This shows the manipulator and adds Pnt of
Interest to the Viewing Panel.

3 Click the arrow next to Pnt of Interest to see the options.
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W Viewing Panel
¥ Pnt of Interest
Visible
locked [ ]
o I 4
Sy (=T e
2 i 5
Lockat @
Plane view [_]
Perspective
e CE& i

4 Turn off the manipulator by clicking the Visible check box to hide the
point of interest manipulator.

Turn the Visible check box on to show the manipulator again.
5 Turn on the Locked check box to keep the point of interest manipulator
locked at its current position.

The manipulator will not move when you click at another point or drag
its center handle. Use this option if you find you are moving the
manipulator unintentionally.

Turn the Locked check box off to free the manipulator.

6 Turn off the Perspective check box.

The perspective view changes to an isographic projection.
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Many people find an isographic view easier for technical modeling, since
parallel lines in the model remain parallel in the view window.

For the remainder of the tutorials, the screen shots will show isographic
views. However, feel free to turn the Perspective checkbox back on if you
prefer a perspective view.

To set and show bookmarks

1 Move the mouse pointer over the Perspective view and hold down the
Shift and Alt keys, keeping them held down, to enter camera move mode.

2 With Shift and Alt still held down, find the Bookmarks section at the
bottom of the Viewing Panel.

If it is not visible, click the tag in the bottom right corner of the Viewing
Panel. It will turn white and the bookmarks section will appear.

3 Click the new button in the bookmarks section.
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A new bookmark appears at the bottom of the section.
Move the camera to a new view on the model.

Click the new button again.
A second bookmark appears in the bookmark list.

Click the label for the first bookmark, then the second.
The view switches back and forth between the two bookmarked views.

NOTE To be able to distinguish between bookmarks later, you should rename
them now.

Click the edit button in the BookMarks section.
The BookMarks Lister window appears.

S sooknarks [P
4L LA,
| | | | | |

Delete Prey Cycle

T

EBookmark
icons

I e M ext Fublish

Release the Shift and Alt keys.

Hold down the Ctrl key and double-click the first bookmark icon in the
Bookmark Lister.

A dialog box appears.
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confirm

Enter Tool Label

EM

Coneel

10 Type a new name for the bookmark, then click OK.

For production work, you should use meaningful names, such as “back
panel” or “door handle”.

NOTE By default, bookmarks are named BM, BM#2, BM#3, and so on. Move
the cursor over a bookmark icon to see its current name.

11 Ctrl double-click and rename the other bookmark.

12 Note the buttons in the BookMark Lister window:

The delete button removes the current bookmark (green outline) from
the list.

The new button adds a bookmark of the current view. This is the same
as clicking new in the Viewing Panel.

The prev and next buttons change the view to the bookmark that
precedes or follows the highlighted bookmark (green outline).

The cycle button displays the bookmarked views in a slideshow
fashion.

The publish button saves the current or all bookmark(s) as image files
on your disk.

Clicking on a bookmark icon changes the view to that bookmark.
This is the same as clicking a bookmark in the Viewing Panel.

13 Close the BookMark Lister.
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14 Hold the Shift and Alt keys in the Perspective window to show the Viewing

Panel.

Notice your new names in the BookMarks section.

Use the following overview illustration as a reminder of the different controls
on the Viewing Panel.

DpeniClose Panel

Open/Close P.O|. =
section

wWiew model from =
top or bottom

wiew madel fram /

preset direction

Return to previous
wiew —

[ Wigwing Panel

% Prit of Interest
visble [+
Locked

o & 74
TEJCT e
Pz

Loak, at C !
Plane wvigw

Perspective

=
| ey %=

Aspect ratio

BookMar

e ]

Create new /
bookmark

Edit bookmarks

Turist

Hide/Show the
P.Q.1. manipulator

Lock P.C position

Center active object
in wiemy

Use const. plane as
ground plane
Perspective or
isographic wiew
Open/Close

bookmark section

Azimuth/Elewation

NOTE The Twist and Azimuth/Elevation tools rotate the view around the point of

interest.

Understanding the Object Lister

AliasStudio keeps track of every aspect of the scene in a hierarchical data
structure. You can view representations of this structure through the SBD
(scene block diagram) or through the Obiject Lister.

Curves, surfaces, groupings, transformations, components, lights, and
everything else in the scene is represented by nodes in the hierarchy.

You may want to use the Object Lister in the following circumstances:

B In complex models, it can be easier to pick objects in the Object Lister
than in a view window.
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B The Object Lister shows important information that has no visual
equivalent in the view windows, such as how the components and objects
are grouped, and how they relate to modeling layers.

B The Object Lister lets you confirm the effects of tools and menu items on
the internal structure of the scene to help diagnose problems.

Types of Nodes

Information of different types is associated with nodes in the hierarchical data
structure. These nodes can represent surfaces of different types, curves, lights,
or groups of objects.

Different types of geometry are indicated by different icons.

For a full list of icons, see Windows > Obiject Lister.

- HL_-‘ 0 Default

&l overlay Owerlay plane

E]_Q node#z
|“- plane#z20

I“ plang# 222 =— AR
- !
i krim_surface# 159 ———Trimmed surface

E tube_group#26
[;I}itubejiece#lﬂg
| Le tube_piece#109 COS #1—CUrve 0N suUrface
% tube_piece#110
E'_Q cylinder #12 —0Group
% cyl_bodv#zs
I—‘- caph#lz
l_‘- capB#5

— W fillet_srf#55

Node States

B Grouped: you can group several objects. In the Object Lister, this is
represented by putting the objects under an orange block.

[;EI—Q nodegtz ——NMEw Qroup node created
| ’_‘-skin#z when grouping two surfaces
| l_‘- skin#3
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B Instanced: you can duplicate an object as an “instance”. Instead of a new
object, an instance is just a pointer to existing geometry. It is represented
in the Object Lister as a white cube. As well, the object that has been
instanced gains a node underneath.

ﬁ]‘@ skin#4

‘ skin#3

B Compressed: as the Object Lister becomes busier, you may want to collapse
a part of the graph into a single node. The node with other nodes below
it has a plus sign (+) in front of it. Nodes that have been expanded and
can be collapsed have a minus sign (-) in front. Shift-click a - or + sign to
expand or compress the entire hierarchy.

8| 2 back buttons

B Invisible: you can make objects in the scene invisible. Nodes for invisible
objects have gray text.

[]I:HE 12 screen

| l_" plane

B Templated: you can “template” objects in the scene so they are still visible,
but cannot be transformed or picked. Nodes for templated objects do not
change their appearance; however, when the object is picked, in the view
windows, it will be pink. When inactive, gray.

The Object Lister window
To view and pick using the Object Lister window

1 From the Windows menu, choose Object Lister.

The Object Lister window appears.
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Show  Categoties st

0 Default

< cvlinder
W cube

oo

ol

COne

‘- sphere

L
&

The graph in the window is the diagram representing the current scene.

2 Use the scroll bar on the left to move through the graph.

The nodes are labelled with their names and icons showing their types.

3 Click a geometry node in the Object Lister window.
The corresponding object in the scene becomes picked.

Pick > Object and Pick > Component
Unlike in the modeling windows, you can use either Pick > Object or Pick >
Component to select whole objects or parts of objects in the Object Lister. In

this section, you will compare picking in the modeling window with picking
in the Object Lister.

To pick using Pick > Object and Pick > Component

1 Choose Pick > Nothing.

2 In the Obiject Lister window, click the plus (+) sign beside the cube to
open its representation.
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_ioix]

Show  Categories S
el =T =TI

cylinder
El]_@ cube

— B facen
— W facen
_‘- FaceC
— W faceD
— W faceE
o — W facer

Eﬂ_@ cone

You can see that the cube is constructed of six planes that are grouped.
Choose Pick > Object and pick the cube in a view window.

In the Object Lister window, you can see that the grouping node is picked.
Choose Pick > Component.

Find the component filter buttons to the left of the promptline. These
buttons appear when the Pick > Component tool is active.

—LFHE Edit Delete  Lavouts
Meshes Ef“ 7 QWHS

Construction  Curves Surfaces  Sections
Ohjects

Make sure the Surfaces button is pushed in.
Click the cube.
Since you must click an edge, which is shared by two sides, a small box

appears under the mouse pointer with the name of both sides. Click the
name you want.

The Pick > Component tool only picks one side of the cube.
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In the Object Lister window, you can see that instead of picking the entire
group, the Pick > Component tool picked one of the sub-nodes

Slobyect uster ——SSI=IPY
Show  Categories 57
T rooerame
cylinder
[1]_. cube
— W Facen
— W Facen
_‘ facell
_‘FaceD
— W FaceE
o — W facer

E'F]_. cone

1 Instead of choosing Pick > Component and having difficulties selecting
a surface that can be attached to or overlaid by another surface, you can
click the sub-object directly in the Object Lister.

Conclusion

You now know how to:

B Log into the system and start AliasStudio.
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Get help.

Arrange windows.

Use tools and tool options.

Customize shelves and marking menus.

Tumble, track, and dolly the view.

Use the Object Lister window to understand the internal representation
of the model.
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Introduction to 3D

Learning Objectives

In this introductory modeling tutorial, you will start working with 3D space.

You will learn how to:
create primitive objects

duplicate objects

|

|

B move, scale, and rotate objects
B group and organize components
|

save files

This tutorial introduces you to working in 3D space, using the Autodesk AliasStudio modeling
environment. You will build a desk lamp from cylinders and spheres using the AliasStudio
Surfaces menu. As you build up the design, you will get used to moving, scaling and rotating
objects in 3D space.

You will learn how to group and organize the desk lamp, so that you can rotate the component
parts to simulate the operation of a real lamp.

Opening the tutorial file in a Windows Environment on page 86

Saving your work on page 99

Create a 3D geometric primitive

Move items

Scale objects proportionally

Scale objects non-proportionally

Rotate objects

Group and ungroup objects
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Beginning a Model

Desk lamp modeling strategy

The modeling strategy for building the desk lamp model is shown below.

L1a%1

First, you will create a base from cylinders. Then, you will build a moveable
arm at an angle, also using cylinders. Finally, you will build a lampshade using
spheres, which will then be assembled onto the arm.

As you gain experience in using AliasStudio, choosing a modeling strategy
will become a natural part of your workflow.

To help you build the desk lamp model, an exercise file has been provided
which contains outline sketches of the design.

Opening the tutorial file in aWindows Environment

g
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how to open files and set projects.

1 Choose File > Open to open the File Browser.

File |
e
Open. .. m}
Cpen Recent Files [

Open skage set...

The file browser window appears.
Ga I vI j Project  |EIARVIERY

Lock. in: |@ wire j - E

| desklarp, wire
desklamp. wire, TZ0MN

| jovestick, wire

If the desklamp file is shown, jump to step 2. If not, follow the next steps
to set up the courseware directory.

Click the arrow next to the Go field and select Projects. You will move
into the user data directory.

Go 'l j Project I
Diefault Path | -
Loal Current Projech I! b 'l
Mone I
Mane x
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The projects in the user data directory are displayed. If the courseware
project is not shown, refer to To install the courseware for use with
AliasStudio Personal Learning Edition on page 14.

Go I :'I j Project I
Laak in: Ia user_data j
Coursetiare
demao
durnpsker

Click the Courseware directory and choose Project > Set Current to make
it the current project and open its wire sub-directory.

[ 21|
j j Prejact 'I

sk, sl
isc_daca [ 1shader
rtinn [

2 D slaLesel
ok [l keschre

2 Choose the file desklamp and click Open. Alternatively, double-click the
file to open it.

When prompted to delete all objects, choose YES.
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confirm

DELETE all abjects,
shaders, views and actions
before COpening this File?

NOTE If your values for construction settings differ from those in the
desklamp.wire file, you will be presented with a dialog box. Click Accept
New Settings to use the construction settings in desklamp.wire.

The Construction Options of the retrieved file diffier from the current session
Do you want ko keep the current Construction Options?

Option Type Current Hew
| Curve Ft Distance Tolerance [ 0,0010000 men | 0.1000000 mm
| Continuty Maximum Gap Distance |0.0010000 men | 0.1000000 mm

cettings Accept New Settings

The file browser closes and the desk lamp exercise file appears in the
AliasStudio window.
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You will see a sketch of the desk lamp design in the Left view. This sketch
is a reference image, known as a canvas plane, you will use it as a guide
to model the desk lamp.

If the two sketches do not appear, it is because the canvas plane display
has been turned off. To turn on canvas display, choose WindowDisplay
> Toggles > Canvas Planes.

TIP If you do not see any views, or the views do not take up the full view
window space, choose Layouts > All windows > All windows .

Part |: Creating 3D objects

In this section you will create a primitive object, a cylinder, for the base of
the desk lamp.

Part 1 of the tutorial.
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Creating a Primitive Object

What are Primitives?

Primitives are ready-made objects in familiar shapes. The primitives are made
from a single surface, or a group of surfaces that form an enclosed volume.

In AliasStudio, the following primitives can be created:
Sphere

Torus

Cylinder

Cone

Cube

Plane

Placing Primitives in views

In this section, you will use the 2D views (Top, Left, and Back) to place the
primitives. Which window you choose will affect which way up the primitive
is created.

For example, placing a cylinder in the Top view will create a pillar.
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Placing the cylinder in the Left or Back views will create a ‘fallen pillar’, or a
‘log’.

To create the lamp stand

Now you will create a cylinder for the base of the lamp stand.

1 The first cylinder will be created using the Top window.
Maximize the Top view.
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2 Choose Surfaces > Primitives > Cylinder from the palette. If the palette
is not open, choose Windows > Palette from the menu bar.

3 To choose the Cylinder tool, press and hold the mouse button, so the
cursor is over the Sphere icon until the entire Primitives drawer appears.

Surfaces i
o

Soosiuae

Then, click the Cylinder icon to choose the Cylinder tool.

The Cylinder tool is displayed in the Surfaces palette, and is outlined in
red to indicate it is the active tool.

4 You can control the exact placing of a primitive using various snapping
modes. In this section, you will use grid snapping to align all the cylinders
centrally on the grid origin. The grid origin is where the two dark grid
lines cross.
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Hold down the Alt key to turn on grid snap mode.

Press and hold the Alt key near the origin. Keep your finger held down
on the Alt key and move the mouse until the new cylinder snaps to the
correct grid point.

Release the Alt key and the mouse button.

5 Choose Layouts > All windows > All windows or click the F9 key to
display all 4 views, and check that the cylinder has been placed correctly,
as shown.
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The cylinder remains picked, or active. Picked objects are drawn with
white lines, and objects that are not picked are drawn with dark blue
lines. Most tools and commands work on picked objects. Since the
Cylinder is picked, any tools or commands you choose will be applied to
it.

NOTE The cylinder has a manipulator attached to it, as do all primitives when
they are first added to the scene. The manipulator can be useful for
transforming a primitive, but is not relevant to this tutorial.

TIP To delete the cylinder, press the Delete key.

Scaling the lamp base

Next you will scale the cylinder to the correct size.

1 Maximize the Left view, as this is the view you will continue working in.
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2 Choose Transform > Scale

N

mave rokate

B

scale np sc

The Scale icon is outlined in red to indicate it is the active tool. At the
same time, the cylinder’s manipulators disappear.
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3 Click and drag the left mouse button to scale the cylinder equally in all
axes.
Scale the cylinder to roughly fit the width of the bottom cylinder shown
on the sketch. This will be the base of the lamp.
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The Transform > Non-p scale tool (non-proportional scale) modifies the

X,y or z scale of an object separately. This allows an object to be stretched
or squashed.

Transform

a a

‘c
by

mave rokate

i

n
e
8
T

‘u
IS
Q

%‘4}“

The mouse buttons are used to control the non-proportional scaling. For
this section, you will use the 2D views (Top, Side, and Back) to control
the transforms. In these views, the mouse buttons work as follows:

Left mouse button ‘-- "l free transform
L

Middle mouse button I" ﬂ "l horizontal transform
o

Right mouse button I" T vertical transform
o

Next you will use the right mouse button to adjust the vertical height of the
base.

1 Choose Transform > Non-p scale.

2 Click and drag with the right mouse button to adjust the height of the
cylinder. Make the height approximately the same as shown in the sketch.
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NOTE The cylinder is centred on the origin.

Later, you will line up the cylinder to the grid line, to make the lamp
base sit on the ground.

Saving your work

Now you will save the lamp as a new file.
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It is always important to save your work at each stage. However, to safeguard
the files in the CourseWare project, it is write-protected. You cannot save any
new work in the CourseWare project.

To save your work you must create a project directory. Project directories are
special directories created by AliasStudio that allow you to efficiently store all
the files related to a specific project together.

Saving your work in a Windows environment

1 Choose File > Save as.
The File Browser opens.

2 Click the arrow next to the Projects field and choose New Project from
the menu.

L x|

A new project is created which is immediately displayed in the File

Browser.
Go I i l j Project I
Save in; I@ riew_project j &

aniir [rnask sl

canvas i | misc_data [Cdshader

cloud [:I opkion G sla

depth e [ stageset
environment [:I plot G texture
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3 Click the Up 1 level button to move up one directory. This is the
user data directory that contains all the projects, including the
new project.

Go | =3 ot | =

|
Look in: IE new_project j = ¢ BT
anim Clmask Csd I
eanvas Cmisc_data shader
cloud | option Csla
depth (pix (“stageset
environment | plet Clreture

4 Click the right mouse button on the new project directory and choose
Rename from the menu.

Save Wire R £
Go | i ~|
Savein: | 3 user_data I R = I e
CourseWare
demo
1 dumpster
Select
Opan
Explore
Erowse with ACDSee
Object nanme: Search... | Open |
Sharing. .,
Fle T2 @ umap | G===T
Scan for Viruses..,
Lﬂe&ltur |
Cut
Copy e e |
Creabe Sheckout
Create leon
bete s =
Z
T e —

5 Type Lessons and press Enter.
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savewire
Gao I 'lj Project l_

Savein: I 3 user_data |

Courseare
demo

dumpster

6 Click the arrow next to the Projects field and choose Set Current to make
Lessons the current project.

Go | 'I_>| Project | Set Current hd

Set Current
=

Savein; I 5 user_data

CourseiWare
dema

; dumpster
Lessons

The wire directory of the Lessons project is now displayed in the File
Browser.

[Save wire R
Go | 2 5

Savein: | Y wie x| ¢ & ek BE-

Object name: | Save

File Types: AN Files 7] | Cancel |
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7 In the Object name field, type mydesklamp and press Enter.

i
Go | 'Iﬂ Project | Set Cunent "i
Savain: | 2 wie x|« @ ek E-

Object name:  |desklamp I Save I

FiaTypes:  [A0Fdes (") =l Cancel

AliasStudio saves the file mydesklamp.wire in the Lessons project.

TIP It is good modeling practice to save often as insurance against having
to start from the very beginning if you make a mistake.

Part 2: Building the lampstand

In this section, you will continue to build the lamp stand from cylinders.

g

Part 2 of the tutorial.

Aligning the base to the grid
Next, you will align the cylinder to the grid in the Back view, to make the

cylinder look like it is sitting on the ground. To do this accurately, you will
need to set the pivot point of the cylinder.
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Pivot points

When scaling or rotating an object, the transformation is applied about the
object’s pivot point. When moving and snapping an object, it is the pivot
point that is snapped to the specified position.

The pivot point is indicated by a small green icon. This is displayed only when
the object is picked. By default, the pivot is at the center of the primitive.

The position of the pivot is modified using the Transform > Local > Set pivot
tool.

1 Choose Transform > Local > Set pivot.

Transfarm

»

move ratate

!

—

7

&

scale np s
a =

&

5

p move | set pivok

N

3
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2 The pivot needs to be at the base of the cylinder. To move the pivot point
to the base you will use curve snapping and select the bottom line of the
cylinder.

Hold the Ctrl and Alt buttons down together to turn on curve snapping.

3 Click the bottom edge of the cylinder with the right mouse button. Using
the right mouse button keeps the pivot point centered as it moves
downwards.

The pivot point snaps precisely onto the bottom edge of the cylinder.
Release the Ctr/ and Alt keys and the mouse button.
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TIP If you make a mistake, choose Edit > Undo to step back.

Next, move the cylinder onto the grid.
4 Choose Transform > Move.

5 Hold down the Alt key to turn on grid snap mode, and press and drag
with the left mouse button in any direction. The cylinder moves so that
its pivot point always snaps to a grid intersection.

Drag the cylinder to the origin.
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Release the Alt key to turn off grid snap mode.

NOTE You can adjust the height of the base again using Transform > Non-p
scale and the right mouse button. The location of the pivot point makes the
scaling easier to control.

Duplicating the cylinder

The cylinder now has a convenient pivot point location. To save time, you
will copy this cylinder and then move and scale it to create the other

components.
1 With the cylinder still picked, choose Edit > Copy.
2 Choose Edit > Paste.
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Your screen will appear not to have changed. However, a second cylinder
has been placed in the same location as the first, and is selected, ready
to be moved or scaled.

3 Choose Transform > Move.

4 As the cylinder is already selected, you don’t need to click the cylinder
to move it.

NOTE When there are many objects on the screen, it is preferable to click
away from the object when using any of the transform tools.

5 Click and drag using the right mouse button (away from the objects) to
move the new cylinder vertically away from the original.
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Next, you will snap this cylinder to the top of the first cylinder.
Check that the Transform > Move tool still has the red box outline, so it
is active. If it isn’t active, choose it again.

Hold down the Ctrl and Alt keys together to turn on curve snapping. Click
the top edge of the original cylinder with the right mouse button.

The second cylinder moves to the top of the first cylinder.
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Release the Ctrl and Alt key to turn off curve snap mode.

7 Choose Transform > Scale and use the left mouse button to scale the
cylinder to match the width shown in the sketch.

8 Choose Transform > Non-p scale and use the right mouse button to adjust
the height of the cylinder to match the sketch.

NOTE When clicking and dragging the mouse, click in the background, away
from all objects. This will make sure that no objects get accidentally picked
or scaled.

Creating the lamp pillar

The same technique can be used to create the main pillar of the lamp stand.

1 With the second cylinder still selected, use Edit > Copy
followed by Edit > Paste

to create a third cylinder.
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A third cylinder is created in the same position as the second, and is
active, ready to be moved.

Choose Transform > Move. Hold down the Ctrl and Alt keys to turn on
curve snapping mode.

Click the top edge of the second cylinder to move the new cylinder into
place.
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4 Choose Transform > Scale and use the left mouse button to scale the
cylinder. Resize the cylinder to match the width of the pillar. Remember
to click and drag in the background, away from the objects.

5 Choose Transform > Non-p scale and use the right mouse button to adjust
the height of the cylinder to match the sketch.

Building the lamp arm

Next, you will build the angled arm of the lamp.

1 With the third cylinder still selected, choose Edit > Copy
followed by Edit > Paste.

2 Choose Transform > Move. Use the right mouse button to move the cylinder
into place.
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3 Choose Transform > Rotate.

Transform

nw
mave rokate

B

scale np sc

The Transform > Rotate tool is used to rotate an object around its pivot
point. The axis of rotation is determined by which mouse button you
use:

B The left mouse button rotates around the x-axis
B The middle mouse button rotates around the y-axis

B The right mouse button rotates around the z-axis

4 Using the middle mouse button, rotate the cylinder about the y-axis until
it is approximately in position.
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5 Choose Transform > Non-p scale and use the right mouse button to adjust
the length of the second pillar.

Create the hinge cylinder

One more cylinder will be added to complete the design of the arm.

1 Choose Surfaces > Primitives > Cylinder. Hold down the Alt key to turn
on grid snapping. Click near the grid intersection closest to the hinge.
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2 Choose Transform > Move. Click and drag the right mouse button to move
the cylinder to the hinge position.
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3 With the cylinder still selected, choose Transform > Scale. Click and drag
the left mouse button to resize the cylinder to match the hinge in the
sketch.

You have now completed the modeling for the base and the arm.

Saving your work

Choose File > Save as to save the current scene, and call your file mydesklamp2.

Part 3: Organizing the model

In this section, you will organize your model by grouping. One group will be
the base of the lamp, the other group will be the angled arm and hinge. The
groups will be named and managed using the Object Lister. The Object Lister
is a schematic view of the objects in your scene. It is very useful for managing
the components of a design.
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Part 3 of the tutorial.

Using the Object Lister to control visibility

Next, you will use the Object Lister to turn off the sketch, making the geometry
easier to select.

1 Choose Windows > Object Lister from the AliasStudio menu.

2 Choose Show > By Object on the Object Lister menu.
='object -|o] x|
Show  Categories S

v Bylayver Bfault
By Object

The objects in your scene are listed.

-ioix]

Shiow S

g Skekch_Assembly
'@S Sketch_Lampshade

cylinder

cylinder#5
cylinder#3
cylinder#z
cylinderatd

Persp

The sketch is shown at the top of the list, followed by the cylinders you
have created.

NOTE The ‘Persp’ object is the camera used to show the perspective view.
This will not be used in this tutorial and can be ignored.
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3 Click the right mouse button on the Sketch_Assembly name in the Object
Lister. A submenu appears. Keep the mouse button held down and move

to visible.
= object Lister O] =]
Show S

‘ Sketch_As senl'lbly
o visihie
Propertiles

cylinder#s

cylinder#3

Release the mouse button and the sketch disappears from the screen.

NOTE The sketch can be made visible again by selecting the same submenu
and choosing Visible.
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Grouping the base objects

Individual objects can be grouped so they can be selected with a single click.
A group has a single pivot point.

1 Use Pick > Object from the AliasStudio palette.

2 Click and drag in the area shown to select all the base components.

The selected objects are highlighted in white and are also highlighted in
the Object Lister.

Note that each cylinder is showing a different pivot point.
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cylinder #3
cylinder #4
cylinder ¥z
Persp

3 Choose Edit > Group.

Edit i

Undo Chrl+2

Redo

Reinvoke last

Cuk Chrl+

Copy Chrl+C

Paste Chrl+y m
Cukimage Shift+Chrl+
Copy image Shift+Chrl+C
Paste image Shift+Crel+y
Duplicate [
Ungroup m)
Group m ]
Expand instances

The grouped objects are now shown with a single pivot point at the
origin. The separate cylinders in the Object Lister have now been replaced
by a single item named node.
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= object Lister =108] x|

-

4 Double-click the word node in the Object Lister.

=lobject Lister I (=] 3

Shiows P

‘ Sketch_fssembly
‘ Sketch_Larmpshade
oylinder
cvlinder#5

Persp

The word node is highlighted. Type Base to name the group, then press
Enter.
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=/object Lister =]

Shiow S

‘ Sketch_Assembly
‘ Sketch_Lampshade

cylinder
cylinder#5
Base

Persp

Grouping the arm

Next, you will group and name the upper arm of the lamp.
1 Choose Pick > Nothing.

2 Choose Pick > Object and pick the top two cylinders.

cylinder#5
Base
Persp

3 Choose Edit > Group.
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4 Rename the new node to Arm.

=] object Lister

Show Vo

‘ Sketch_Assembly
‘ Sketch_Lampshade

Arml
Base
Persp

5 Choose Pick > Nothing to deselect all the objects.

6 Choose Layouts > All windows > All windows to display all 4 views, and

check that all the objects are in the right locations.
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NOTE If there are any problems, ungroup the models and use Transform >
Move and Transform > Scale to adjust the model. Then, group the
components again, as before.

Saving your work

Choose File > Save as to save the current scene, and call your file mydesklamp3.

Part 4: Building the lampshade

In this section, you will build the lampshade and a simplified bulb from
primitive spheres.

Creating geometry at the origin

Many designed objects are symmetrical and aligned. It is good practice to
build models centered on the origin, so grid snapping and mirror tools can
be used.

You will model the lamp shade separately at the origin, then move it into
position on to the upper arm.
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Part 4 of the tutorial.

Making the base and arm invisible

The components you have already built can be made invisible to provide a
clear space to build the lamp.

1 Choose Windows > Object Lister to open the Object Lister window.

Sobyect sterWI=IE

Shiow 5PN

@ Sketch_Assembly
g Sketch_Lampshade
& Am
& Base
% Persp

TIP If you cannot see your objects listed, check that Show > By Object has
been selected in the Object Lister submenu.

2 Click the right mouse button on the Arm text to select the submenu. Choose
Visible to make the upper arm invisible.
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~ipix

Shiow PN

‘E: Sketch_Assembly
‘5 Sketch_Lampshade
& &rm

& v visible

* Froperties

3 Make the Base invisible using the same process.

4 Use the right mouse button over the Sketch_Lampshade text to select the
submenu. Choose Visible to make the sketch visible.

-i0ix

Shiw Vo

> Sketch_mssembly
9 Sketch_Lampshade

¢ visible
i Properties

v Persp

A new sketch for the lamp head will appear in the Back window, and all
geometry should be invisible.
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5 Close the Object Lister.

Creating the light bulb

You will build a simplified light bulb from a primitive sphere.

1 Maximize the Back window to start creating the bulb and lampshade.

Part 4: Building the lampshade | 127



2 Choose the Surfaces > Primitives > Sphere tool.

3 Hold the Alt key down to turn on grid snapping. Click and hold the /eft
mouse button, and move the cursor around. The new sphere will jump to
grid points as you near them.

Position the new sphere on the origin.

4 Choose Transform > Move.
The manipulator disappears.
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Use the right mouse button to move the bulb approximately on the center
of the sketched bulb.

Choose Transform > Scale and click and drag the left mouse button to
match the size of the sphere to the sketched bulb.
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Creating the lampshade

Next, you will create the lamp shade. The main shape of the lamp shade is
created from two half-spheres, one large one and then a smaller one above.
A cylinder is then added to join the shade to the arm.

1 Choose the Surfaces > Primitives > Sphere tool. Double-click the sphere
icon to open up the option box. Type in 180 for the Sweep.

E‘ Sphere Options il

‘ Sphere

Sphere Type

~_ Shell Tennis ball

“_ Shell Mo-Pale
Cbject Degres

1
Sweep I 150,00 deg

Seckions I g H

Resek ‘ Save ‘ Exit | Go ‘

2 Click the Go button. Hold the Alt key down to turn on grid snapping.
Click near the origin to place the half sphere.

3 Choose Transform > Rotate ﬁ . Type 90,0,0 on the prompt line to
rotate the sphere 90 degrees around the X axis.
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4 Choose Transform > Scale. Click and drag the left mouse button to scale
the half-sphere.

Scale the half-sphere to match the width of the large outer curves on the
sketch.

5 Choose Transform > Non-p scale. Use the middle mouse button to adjust
the height of the half sphere to match the sketch.

NOTE The reason we use the middle instead of the right mouse button is
because the scaling occurs with respect to the local axes of the half sphere,
not the world axes. To see the local axes of a selected object, choose
Transform > Local > Set local axes.
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6 Choose Edit > Copy and Edit > Paste to create a second half sphere. This
will be scaled and moved to create the top section of the lamp.

7 Choose Transform > Scale and use the left mouse button to scale it to
approximately half its original size. Remember to click and drag in an
area of the screen that will not accidentally select any of the objects.

8 Choose Transform > Move and use the right mouse button to move the
half sphere into position based on the sketch.

132 | Chapter 4 Introduction to 3D



9 Choose Transform > Non-p scale and use the middle mouse button to adjust
the height of the half-sphere.

10 Choose Layouts > All windows > All windows to display all 4 views.
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11 Maximize the Top view.
You will now create a cylinder to connect the lampshade to the arm.
12 Choose Surfaces > Primitives > Cylinder. Hold down the Alt key to turn

on grid snapping and place the new cylinder at the origin in the Top
view.

13 Choose Layouts > All windows > All windows to display all 4 views.
Choosing to place the cylinder using the Top view has placed it in the
correct orientation.
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14 Maximize the Back window to reposition and scale the cylinder.

15 Choose Transform > Scale to reduce the cylinder to a size suitable for the
end of the lampshade.
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16 Choose Transform > Move and use the right mouse button to position the
cylinder to match the sketch.

A

Grouping the lampshade

1 Choose Windows > Object Lister to open the Object Lister.

Use the right mouse button on the Sketch_Lampshade item to bring up the
submenu.

Choose Visible to turn off the sketch.
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[='Object Lister I ]

Shaw Ve

‘ Sketch_Aszembly
l:‘ Sketch_Lampshade
v Yisible
% Properties
_‘ sphere#s
_‘ sphere#z
Arm

Base

Persp

3 Choose Edit > Group. The objects are still selected, but notice they now
have a single pivot point at the origin. The default location for a new
pivot point is the origin.
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The lampshade is designed to rotate where it connects to the lamp arm.
So next, you will adjust the pivot point to be in the center of the cylinder.

4 Choose Transform > Local > Set pivot. Use the right mouse button to move
the pivot upwards, to approximately the center of the cylinder.

In the Obiject Lister, the new group is shown as node.
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-ioix

Shiows Vi

ﬁ Sketch_Assembly
ﬁ Sketch_Lampshade

5 Double click node to rename it to Lampshade.

T=I

Shiawe -]

© Sketch_aAssembly
ﬁ Sketch_Lampshade

Lampshadel
¥ Arm
& Base

& Persp

6 Make the Base and Arm components visible using the right mouse button
and the submenu.
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='0bject Lister |

Shiow A

© Sketch_Assembly
‘ Sketch_Lampshade
Lampshade

Arm

Wisible:

Properties

7 Choose Pick > Nothing. All the objects are deselected.

8 Choose Layouts > All windows > All windows to display all 4 views.

You have now built all the components of the lamp, and it is ready to
be assembled.

9 Choose File > Save to save the current scene, and call your file
mydesklamp4.

140 | Chapter 4 Introduction to 3D



Part 5: Assembling the desk lamp

In this section, you will assemble the finished desk lamp by moving the
lampshade into the correct position and grouping it with the upper arm.

Part 5 of the tutorial.
Positioning the lampshade

1 Maximize the Left window.

2 Choose Pick > Object and select the lampshade group.

3 Choose Transform > Move. Click and drag (away from the objects) to
move the lampshade to the end of the upper arm.
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4 Choose Transform > Rotate. Use the middle mouse button to rotate the
lampshade about the y-axis.
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Grouping the lampshade and arm

Next, you will group the lampshade to the arm, so the lamp can be moved
and arranged.

1 Use Pick > Object and select the lampshade and the upper arm.

The two groups are highlighted in the Object Lister.
=l object Lister =] S

Shiows P

‘ Sketch_fssembly
‘ Sketch_Larmpshade

Larpshade
Arm
Base

Persp

2 Choose Edit > Group. A new node is created and displayed in the Object
Lister.
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Show Vi

© Sketch_assembly
© Sketch_Lampshade
¥ node
¥ Base

% Persp

3 Rename the node Upper Assembly.
IR

Show P

ﬁ Sketch_Assembly
ﬁ Sketch_Lampshade

Upper_AssemvaI

Base
% Persp

The group is created with the pivot point in the default location, at the
origin. To ensure the upper assembly rotates correctly, you will now move
the pivot point to the center of the hinge.
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4 With Upper Assembly selected, choose Transform > Local > Set pivot.
Hold the Ctrland Alt keys down and use the right mouse button to click the
center-line of the hinge cylinder.

The pivot point moves to the center of the hinge.
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Saving your work

Choose File > Save asto save the current scene, and call your file mydesklamp5.

Part 6: Posing the Lamp Model

Part 6 of the tutorial.
The groups you created previously are still in the model.

1 In the Obiject Lister click the ‘+’ sign to the left of Upper Assembly. The
Lampshade and Arm subgroups will be shown.
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= object Lister O] x|

Shiow T

A > Sketch_mssembly
‘ Sketch_Lampshade

These groups and subgroups allow you to move and rotate different
components of the lamp.

2 Maximize the perspective view.

3 Click the Upper Assembly in the Object Lister to select the group.

4 Choose Transform > Rotate. Use the middle mouse button to rotate the
upper assembly about the y-axis.
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5 In the Obiject Lister, click the Lampshade.

[ object Lister =10] x|

Show Ll

‘ Sketch_sssembly
A > Sketch_Lampshade:

Upper_Assembly

Arm

&

6 With the Transform > Rotate tool still active, use the middle mouse button
to rotate just the lampshade about the y-axis.
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You can position the lamp in many different poses, by picking and
rotating individual groups around the x, y and z axes.

Using Diagnostic Shading

The wire model can be shaded to give a more realistic view of the geometry.
Diagnostic shading can be accessed in the Control Panel to the right of the
AliasStudio interface.

NOTE If the panel isn’t shown, choose Windows > Control Panel to make it visible.
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4 Diagnostic Shading

Tolerance
| 0,000 | |

Tessellator Fask

AR R R
ARV R

4 Cross Section Conkrol

1 Choose Pick > Nothing.

2 Choose the blue shade icon ’ to color all objects in the scene.
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To return to the wireframe view, choose the wireframe icon 3 .

Conclusion

Congratulations! You have just completed the desk lamp model.

Most of your design work will involve more complex shapes than you have
used here, but you have gained useful experience in controlling the AliasStudio
interface, which you will apply as you learn the more complex modeling
techniques later in this book.

Important concepts that you should take through to future modeling tasks:
B Using snapping to accurately position geometry.

B Using the left, middle and right mouse button s to control transforms such
as Move, Scale and Rotate.

B Building geometry around the origin to align and center the model.
B Organizing your model using the Object Lister.

B Regularly saving your work.

Now that you have completed this modeling tutorial, do this quick quiz to
help you remember what you have learned.

1 How do you place an object exactly at the origin?
B (a) Hold the Ctrl key down before you click

B (b) Hold the Alt key down and click close to the origin

B (c) Zoom in really close to the origin and move your mouse as close
as possible to the grid intersection, then click

B (d) Click with the middle mouse button

B (e) Open the object option box and select the ‘origin’ option
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2 How can you tell when an object in the scene is selected (active)?

B (a) It is shown in blue
(b) It is shown in white
(c) It blinks

(d) It is outlined in red

(e) All the other objects go gray

3 When using Transform > Scale, if the object is already selected where is
the best place to click and drag to specify the scaling?

B (a) Away from all geometry, in the gray background
(b) Touching the object
(c) On the transform palette

(d) On another, unselected, object

(e) In the control panel

4 What action does holding the Shift and Alt keys together, and using the
right mouse button do?

B (a) Move an object vertically
(b) Delete an object
(c) Zoom in an out of the view

(d) Scroll the Palette up and down

(e) Save the file

5 Which button or key is used to specify movement or scaling in the
horizontal direction in the Top, Left and Side views?

B (a) Left mouse button

(b) Middle mouse button
(c) Right mouse button
(d) The Alt key

(e) The Ctrl key
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6 Which location is the best one to save your data into?
B (a) In the user data directory.

B (b) In My Documents

B (c) In the wire directory of the demo project, in the user data
directory

B (d) In the wire directory of a project created and renamed for your
task, in the user_ data directory

B (e) In the pix directory of the named project

On your own

Now that you have created a complex object from simple primitive objects,
see what else you can build. Here are some ideas to get you started.

The alarm clock shown below is made from a half-sphere, with a torus for the
rim and cubes for the hands. The clock is assembled first, and then grouped
and rotated so that the face is angled upwards. Finally, two scaled spheres are
used for feet. Have a look at the help documentation on the Edit > Duplicate
> Obiject tool, as this is useful to help build the 12 hour markers on the clock
face.
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This USB memory stick was made from a cylinder with a half-sphere. They
were created and aligned at the default size, and then grouped and
non-proportionally scaled to create the flattened oval shape.

A fun exercise that will give you the opportunity to use all the primitive tools
is to build a snowman. The model shown is just one variation; use your
imagination to create your own character. To save time, use the Edit >
Duplicate > Mirror tool to create a left arm as a copy of the right arm. You
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will need to open the option box to make sure that you mirror the objects in
the right direction. Using Edit > Group on the head, or the arm objects for
example lets you rotate them into realistic positions.
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Quiz Answers

Answers to the Desk lamp Tutorial quiz

1

(b) Hold the Alt key down and click close to the origin. The Alt key turns
on grid snap mode, so the object will always be placed on the grid
intersection nearest to where you click.

(b) It is shown in white. The selected object(s) will be affected by whatever
tool you choose, for example Transform > Move. To make sure that
nothing is affected, choose the Pick > Nothing tool.

(a) Away from the geometry. Because the object is already selected, the
only input required is a click and a drag to specify the transform. If you
accidentally pick on a second object, the transform will be applied to
that object instead. Try to find an area in the view that has no geometry
in it, and then click and drag.

(c) Zoom in and out of the view.

(b) Middle mouse button.
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6 (d) In the wire directory of a project created and renamed for your task,
inthe user data directory. It takes a few steps to set up a new AliasStudio
project, but doing so will make your data much easier to manage and to
find.
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Modeling a Joystick

Learning Objectives

This tutorial introduces you to modeling. You will learn how to:

B Create curves using CVs and edit points

B Use curves to create different types of surfaces (skinned, revolved, extruded, and planar)
B View a model in hardware shaded mode
|

Edit CVs

Introduction

In this tutorial, you will model a computer joystick like the one below. You will
be introduced to tools that enable you to build surfaces from curves. As well,
you will start to use layers to organize your work. Finally, you will learn a way
to view and evaluate your work.
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New tools used in this tutorial

Curves > Primitives > Circle

Pick > Point types > CV

Pick > Point types > Hull

Curves > New curves > New Curve by Edit Points
Curves > New curves > New Curve by CVs
Surfaces > Skin

Surfaces > Planar surfaces > Set planar

Surfaces > Swept surfaces > Extrude
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New menu items used in this tutorial

W Layers > New
B Layers > Visibility > Invisible/Visible

B WindowDisplay > Hardware Shade

New Control Panel tools you will use in this tutorial

m Display CV/Hull

Part |: Creating the Joystick Handle

In this section, you will create the joystick handle by revolving a profile curve.

g

Part 1 of the tutorial.
Opening the tutorial file

1 Choose File > Open to open the File Browser.

2 In the File Browser, locate the CourseWare directory and set it as the
Current Project.

3 Open the file called joystick.wire, located in the wire directory in the
Coursellare project.

For information on how to open a file, see Opening the tutorial file in a
Windows Environment on page 86.

A dialog box appears, asking if you want to delete all objects, shaders
views, and actions. Click YES.
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confirm

DELETE all objects,
shaders, views and actions
before Opening this File?

‘fies ‘ Mo Cancel

If your values for construction tolerances differ from those in the
joystick.wire file, you will be presented with a dialog:

The Construction Options of the retrisved file differ from the current session
Do o want o keep the current Construction Options?

Option Type curent  New
[ Linear Units -MainUnits | mm [ em

Accept New Sattings

Click Accept New Settings to use the construction tolerances in
joystick.wire.

The file is opened.
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NOTE The scene contains two reference images on canvas planes. You will
use these as a guide to model the joystick.

If you do not see any images, choose WindowDisplay > Toggles > Canvas
Planes to turn on the display of canvas planes.

To turn off the borders for canvas planes, choose WindowDisplay >
Toggles > Construction Objects.

If the modeling views do not occupy the full size of the AliasStudio
window, choose Layouts > All windows > All windows .

Creating the Joystick Handle

You will start by creating a curve that follows the profile of the joystick handle,
which will later be used to revolve a surface for the handle.

1 Maximize the Left view by clicking on the square icon on the top right
of the Left view window.
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2 Choose Curves > New curves > New Curve by CVs.

3 This tool allows you to create a curve by placing control vertices (CVs,
for short). CVs control the shape of a curve.

4 Hold down the Alt key to turn on grid snap mode, and click the left mouse
button on the grid intersection at the top of the handle.

A control vertex appears.
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This is the first CV of the curve and is displayed as a small box.

5 Release the Alt key to turn off grid snap mode.

6 Press and hold the middle mouse button to the right of the first CV to create
the second CV. Move the mouse button to position the CV, then release
the middle mouse button.

The second CV is displayed as a small U.

By using the middle mouse button, the second CV is horizontally aligned
with the first CV. Having these two CVs aligned horizontally helps to
avoid a bump or dimple in the top when you revolve the surface.

NOTE The straight red line joining the first and second CVs is not the curve.
It is the hull. Hulls connect all the CVs on a curve.

7 Press and hold the left mouse button along the edge of the joystick handle
outline to create the third CV. Move the mouse to position the CV and
then release the left mouse button.
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The third CV appears. This and all further CVs on the curve are displayed
as small crosses. The hull now consists of two red straight line segments
between the first, second and third CV.

8 Press and hold the left mouse button again to position the fourth CV along
the edge of the handle outline.

The fourth CV appears.

A white curve now connects the first CV and the fourth CV. The hull
now consists of three red straight line segments that connect all the CVs
together.

166 | Chapter 5 Modeling a Joystick



At this point, don’t worry about the shape of the curve. Later, you will
adjust the position of each CV to change the shape of the curve.

9 Continue to place four more CVs in the following positions to complete
the curve.

10 Choose Pick > Nothing to complete the curve and unpick it.

Editing the handle profile curve

Now, you will move CVs to edit the shape of the profile curve to match the
reference image.

1 Choose Pick > Point types > CV.

2 Use the left mouse button to click the third CV or drag a pick box around
it.
Remember, CVs do not lie on the curve; they are located on the hull.

Part |: Creating the Joystick Handle | 167



3 Choose Transform > Move and drag the mouse to move the CV so that
the curve lies directly on the edge of the handle sketch.

4 Click the fourth CV to pick it.
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5 With the Move tool still active, drag the mouse to move the CV so the
curve lies on the edge of the handle sketch.

6 Continue picking and moving CVs until the curve matches the sketch.
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Revolving the handle profile curve

Next, you will revolve the profile curve to create a surface for the joystick
handle.

1 Choose Surfaces > Revolve.

Surfaces
a = 0 =3 I |
sphere planar |revolve
o o = u‘ =
skin  brail_i  sguare

In the prompt window, which is just below the menu bar, you are
prompted to select a curve to revolve.

Layouts  ojeciispiay DisplayTDgl

[El [select a curve to revalve. I
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2 Click on the profile curve to select it.

The curve is revolved and a surface is created.

When you initially create a surface of revolution, it has two green
manipulators. These manipulators enable you to easily change the sweep
of the profile curve and the angle of the revolution axis. The surface you
have created is correct, and so you won't adjust the manipulators.

3 Choose Pick > Nothing to unpick the surface.
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The manipulators disappear.

Modifying the handle curve and surface

Most surfaces you create in AliasStudio have what’s known as construction
history. Construction history allows you to easily change a surface after you
have created it.

For example, if you move a CV on the original profile curve, the revolved
surface will automatically update.

Next, you will move a CV to see the effect of construction history.

1 Choose Pick > Point types > CV and click the third CV to pick it.
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2 Choose Transform > Move and drag the mouse to move the CV slightly.

When you release the mouse button the revolved surface automatically
updates.
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3 Choose the Edit > Undo tool, or the hotkey Ctr/ Z to undo the move.

The surface is now complete, so next, you will turn off the CV display
for the curve.

TIP Itis good practice to turn off the CVs for curves and surfaces, if you don't
need to use them. This helps to reduce clutter on your screen and makes
your model easier to view. It is easy to turn the CVs back on if you need to
work with them.

On the Control Panel on the right of your screen is a Display section.
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TIP If the Control Panel is not displayed, choose Windows > Control Panel
to make it visible.

In the Display section, the CV/Hull check box indicates that the CVs and
hulls are currently visible.

Lieyiee| =

spans|_s [

* Display
CrHull[ v
Blend Points J
Izoparm L vlv

% Diagnostic Shading

Toleranre

4 With the CV still selected, click the CV/Hull check box to remove CVs
from the curve display.

Part |: Creating the Joystick Handle | 175



Uiy ge | —

spans| 5 [

& Display
CwHull |
Blend Points J
[soparm L) W E

# Diagnostic Shading

Tolerance

The CVs and hulls are no longer displayed in the view.

5 Choose Layouts > All windows > All windows to return to the four views.
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TIP The hotkey for Layouts > All Windows > All windows is the F9 function
key. Use this to set the screen to show all four views at any time.

Saving your work

Now, you will save the scene as a new file.
1 Choose File > Save as to open the File Browser.

2 In the File Browser, locate the Lessons directory. Set the Lessons directory
as the Current Project.

3 Save your work in the wire directory of the Lessons project.

4 Name your file myjoystick.wire.

For information on creating the Lessons project, or saving your work, see
Saving your work on page 99.

Part 2: Creating the Joystick Base

In this section, you will create the joystick base with skin and planar surfaces.

Opening the tutorial file (optional)

If you successfully completed Part 1, you can proceed directly to the next step,
Creating the Base Outline Curve.
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If you were not successful in part 1, open the file called joystick part2.wire,
located in the wire directory of the courseware project. This file contains the
completed model from Part 1.

Part 2 of the tutorial.

Creating the Base Outline Curve

First, you will create a rounded triangle shape from a primitive circle.

1 Choose Layouts > Top to maximize the Top view.

TIP The hotkey for Layouts > Top is F5.

178 | Chapter 5 Modeling a Joystick



2 Choose Curves > Primitives > Circle.

3 Double-click the icon to open the option box for the circle.

= Cirdle Options

=

g Circle

Chject Degres

1
Sweep | 360.00 deg
2

Sections | H

Reset ‘ Save ‘ Exit | Go ‘

In the Sections box, the default number of sections is set at 8. As you will
be creating a triangular shaped base, 9 sections will provide a better
arrangement of CVs.

Type in 9 in the Sections box. Click the Go button in the circle option
box.
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=] cirde Options

g Circle

Object Degree
w1
Sweep I 360.00 deq

Sections | g []

Reset ‘ Save ‘ Exit | Go ‘

4 Press and hold the Alt key to turn on grid snapping. Click near the origin
(where the two dark grid lines intersect) to place the circle at the center
of the base.

A small circle is placed at the origin. The manipulators are shown, but
you won't use them for this part of the tutorial.

Next, you will scale and reshape the circle to form the base outline.
5 Choose Transform > Scale.

6 The manipulators disappear.
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Click and drag with the left mouse button towards the top right corner of
the screen, to make the circle larger. Match the size of the circle to the
inside of the base outline, as shown below.

TIP Use the screen diagonal direction for an increase or decrease in scale.
Drag towards the bottom left corner to decrease the scale. Drag towards the
top right corner to increase the scale.

7 Choose Pick > Nothing to deselect the circle.
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TIP Check that the CV shown as a U is at the right side of the circle. If the U
CVis at the left, it means that you have inverted the circle while scaling. Scale
the circle again, being sure to click and drag towards the top right of the
screen.

You will now select the three CVs which will form the apexes of the
triangular base.

8 Choose Pick > Point types > CV and click the CV nearest the right side
of the sketch. This CV is drawn as a small U.

9 TIP As the CVs are small, it is sometimes easier to select them by dragging
a pick box around each one.
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The CV is selected and highlighted in yellow.

10 With the Pick > Point Types > CV tool still active, choose the CV at the
top left hand corner of the sketch by clicking and dragging a pick box
around it.

The second CV is selected and highlighted.

11 With the Pick > Point Types > CV tool still active, click and drag a pick
box around the CV at the bottom left hand corner of the sketch.
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Check that the three CVs are selected and shown in yellow, and that
there are two unselected (red) CVs between each corner CV.

12 Choose Transform > Scale.

13 Click and drag the left mouse button until the outline shape is matched.
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Next, you will make the CVs and hulls invisible for the curve.

14 On the Control Panel, go to the Display section.

Degree IT I:I
Spans IT I:l
& Digplay
CyfHull[ v
Blend PointsJ
Izoparm U vlv

% Diagnostic Shading

Tolerance

Click on the CV/Hull check to remove it.
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4 Diagnostic Shading

The CVs and Hulls for the curve are no longer visible.

15 Choose Pick > Nothing to unpick the curve.
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Creating the Upper Curve for the Base

Next, you will create the upper edge of the side wall, by copying and moving
the first curve.

1 Choose Pick > Object and select the base outline curve that you just
created.
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2 Choose Edit > Copy followed by Edit > Paste.

The screen appears unchanged, but a second curve is created and placed
at the same location as the first. This curve is selected (shown in white)
and ready to move.

3 Choose Layouts > Left or press the F6 hotkey to maximize the Left view.

4 Choose Transform > Move.
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5 Click and drag the right mouse button upwards to move the curve upwards.
Click and drag away from the selected curve to avoid picking the original
curve.

Move the curve so it is aligned with the top of the wavy edge of the
joystick base sketch.

6 With the curve still selected, click the CV/Hull check box in the Control
Panel Display section to turn the CVs and Hulls on.

Degree IT I:I
Spans IT I:l
& Digplay
CyfHull[ v
Blend PointsJ
Izoparm U vlv

% Diagnostic Shading

Tolerance

The CVs and hulls appear.
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Next, you will shape the curve in 3D. To be able to see the shape develop,
you will work with all four views on the screen.

7 Use Layouts > All windows > All windows or the F9 hotkey to return to
the four views.

8 Choose Pick > Nothing to deselect the curve.

9 Looking in the Top view, choose Pick > Point types > CV and select the
three corner CVs.

10 Click on each CV or drag a pick box over each of them.
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Next, you will move these CV points downwards in the Left view.
11 Choose Transform > Move.

12 In the Left view, use the right mouse button to move the selected CVs
downwards, until the curve matches the shape of the top edge drawn in
the sketch.

13 Choose Pick > Nothing to deselect the CVs.
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14 1In the Control Panel, click on the CV/Hull check box to turn the CVs
off.

Creating the Top Curve for the Base

You will continue working in the four views to create the small circle at the
top of the base, where the joystick handle is connected.

1 Choose Curves > Primitives > Circle.

2 Hold down the Alt key to turn on grid snapping. In the Top view, click
near the origin to place the circle exactly on the center grid point.
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A small circle is placed at the origin, with the manipulator shown.
3 Choose Transform > Scale.

4 Be careful not to click on any of the curves, and click and drag with the
left mouse button. Drag towards the top right of the screen to scale the
circle to match the smaller inner circle on the sketch.

Now, you will move the circle upwards in the Left view.

5 With the circle still selected, choose Transform > Move.
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6 In the Left view, click and drag the right mouse button to move the circle
upwards to match the top of the base in the sketch.

The circle is now in position at the top of the base.

7 On the Control Panel Display section, click on the CV/Hull check to turn
the CVs and hulls off for the circle.

8 Choose Pick > Nothing to deselect the circle.
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Creating the base surfaces

Next, you will create the surfaces for the base using the skin and planar surface
tools. First, you will create the side wall of the base using a skin surface.

1 Choose Layouts > Perspective or F8 to maximize the perspective view.

o

2 Choose Surfaces > Revolve.
3 You are prompted to select the first curve.

4 Select the first triangular curve you created at the bottom of the base.
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5 Select the second triangular curve as the top edge of the side wall.
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A skin surface is created between the two curves.

Next, you will create the surface across the top of the base component.

With the skin tool still active, select the second triangular curve again.
The pick chooser offers a choice between the curve and the surface you
just created.
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Keep the mouse button held down and move the mouse over the circle
curve in the pick chooser.

Release the mouse button to select the circle.

7 Now, you are prompted to select the next curve. Click the smaller circle
at the top of the base.

198 | Chapter 5 Modeling a Joystick



The top skin surface is created between the two curves.

Next, you will create the surface underneath the base.
8 Choose the Surfaces > Planar surfaces > Set planar tool.

9 Select the first triangular curve at the bottom of the base. The pick chooser
appears.
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Select the circle curve.
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Click on the Go button that appears in the bottom right of the screen.
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A planar surface is created across the bottom of the base.

10 Choose Pick > Nothing to unpick the planar surface.
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Save your work

1 Choose File > Save as to save the current scene.
2 Save your work in the wire directory of the Lessons project.

3 Name your file myjoystick2.wire.

Part 3: Creating the Flexible Sleeve

In this section, you will create the flexible component that connects the base
to the joystick handle.

Opening the tutorial file (optional)

If you successfully completed Part 2, you can proceed directly to the next step,
Creating the zig-zag curve.
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If you were not successful in part 2, open the file called joystick_part3.wire,
located in the wire directory of the CourseWare project. This file contains the
completed model from Part 2.

Part 3 of the tutorial.

Creating the zig-zag curve

To create the profile for the sleeve, you will first create a simple curve across
the gap between the handle and the base. Then, you will increase the number
of CVs in the curve so a detailed zig-zag shape can be created.

1 Choose Layouts > Left or F6 to maximize the Left view.
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2 Zoom in to the sleeve area. Hold the Shift and Alt keys down together and
click-drag with the right mouse button.
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You will start with a single span curve stretched across the gap between
the bottom of the handle and the top of the base. You will use curve
snapping to accurately place the sleeve curve between the end of the
handle and the base curves.

3 Choose Curves > New curves > New Curve by Edit Points.

4 Hold down the Alt and Ctr/ keys to turn on curve snapping. Click on the
base of the handle to place the first edit point. Without releasing the
mouse button, drag the edit point until it snaps to the corner.

Keep the Alt and Ctrl keys held down and click near the top of the base
to place the second edit point. Without releasing the mouse button, drag
the edit point until it snaps to the corner.
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A single span curve is created that has two Edit Points (one at either end)
and 4 CVs.

NOTE The part of a curve between two edit points is called a span. If a more
complex curve is created with many edit points, there will be many spans,

one between each pair of edit points. When a curve has more spans, it also
has more CVs. These extra CVs can be used to create a more complex shape.

You will now increase the number of CVs in this curve so you can create
the zig-zag profile of the sleeve.

In the Control Panel, the number of spans that make up the curve is
displayed.
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The curve currently has only 1 span.

6 In the Spans section of the control panel, type in 8 and Enter.
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The curve is rebuilt with 8 spans, and now has 11 CVs. A preview of the
rebuilt curve is shown in the view.
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Check Deviation

Choose Accept to confirm the rebuild.

Choose Pick > Nothing to deselect the curve.
Next, you will select some of the CVs to be moved to shape the curve.

Looking at the top of the curve, the first CV is shown as a small square,
and the second CV is shown as a U. You will leave these two CVs
unselected, so the sleeve profile stays connected to the handle, and the
direction of the end tangent is not modified.

Choose Pick > Point types > CV.

Continue counting from the top and select the third, fifth, seventh and
ninth CVs.
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Leave the last two CVs unselected so the sleeve curve remains connected
to the base profile, and the direction of the end tangent is not modified.

10 Choose Transform > Move.
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11 Click and drag the middle mouse button to the right until a gentle zig-zag
shape is created, as shown.

12 With the CVs still selected, click on the CV/Hull check box to turn off
the CVs and hulls for the curve.

13 Choose Pick > Nothing to deselect the CVs.
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Next, you will create the sleeve surface.

14 Choose Surfaces > Revolve.
You are prompted to select a curve to revolve.

15 Click on the zig-zag curve to select it.
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The surface is created and the green handles displayed.

16 Choose Pick > Nothing to deselect the surface.
The green handles disappear.
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17 Zoom out to view the whole joystick design.

18 Choose the F9 key to return to the four windows.
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Save your work

1 Choose File > Save as to save the current scene.
2 Save your work in the wire directory of the Lessons project.

3 Name your file myjoystick3.wire.

Part 4: Creating the connecting cable

In this section, you will create part of the cable that connects the joystick to
the computer.

Opening the tutorial file (optional)

If you successfully completed Part 3, you can proceed directly to the next step,
Create the cable path curve.
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If you were not successful in part 3, open the file called joystick_part4.wire,
located in the wire directory of the CourseWare project. This file contains the
completed model from Part 3.

Part 4 of the tutorial.
Create the cable path curve

1 Choose Layouts > Left or F5 to maximize the Top view.
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You will create the cable on the left of the joystick, so you will modify
the view to give you more space.

Hold the Shift and Alt keys down and use the right mouse button to zoom
out of the view. With the Shift and Alt keys still held down, use the middle
mouse button to pan the view, so there is some free space to the left of the
joystick.
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3 Choose Curves > New curves > New Curve by Edit Points.

4 Hold the Alt key down to turn grid snapping on, and click on the grid
intersection at the left side of the base.

The first CV of the curve is created.

5 Click and drag the middle mouse button to position the second CV to the
left of the first.

Release the mouse button. The second CV is placed horizontally away
from the first.

6 Continue to place CVs, creating a wavy path for the cable.
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Create the cable profile curve

Next, you will create a small circle for the cross-section profile of the cable.

1 Choose Layouts > Left or F7 to maximize the Back view.

2 Choose Curves > Primitives > Circle.

3 Double click the icon to open the option box.
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The current options have 9 sections which was set previously for the
triangular shape. The default number of sections is 8 which creates a good
general purpose circular shape.

Click the Reset button at the bottom of the Circle Options box to reset
the options to the default values. Press Go to create the circle.
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4 Hold down the Alt key to turn grid snapping on. Click near the origin in
the Back window to place the circle at the center of the base.
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A small circle is placed at the origin. The CVs are highlighted in yellow
and the manipulator is showing, but it won’t be used.

5 Choose Layouts > Left or F6 to switch to the Left view.

The circle is at the origin. Next, you will move the circle to the left edge
of the joystick base, where the path curve begins.

6 With the circle still selected, choose Transform > Move.

7 Hold down the Alt key to turn on grid snapping. Click near the grid point
where the path curve starts, being careful not to select any other geometry.
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The circle moves to the start of the path.

8 Choose Pick > Nothing to deselect the circle.

9 The circle and the start of the path curve need to move upwards, so the
cable emerges from the middle of the base side wall.

10 Choose Pick > Point types > CV and drag a box around the circle CVs
and the first two CVs on the path curve.
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11 Choose Transform > Move.

12 Click and drag the right mouse button to move the selected CVs upwards,
so the circle sits in the middle of the sidewall of the base.

13 Choose Pick > Nothing to deselect the CVs.

14 Choose Layouts > Perspective or the F8 hotkey to switch to the perspective
view.
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The small circle is at the start of the path curve, centered on the side wall
of the base.

Create the cable surface

Next, you will create the extruded surface for the cable.

1 Tumble the perspective view and zoom in to the area at the start of the
cable. Hold down the Shift and Alt keys and use the left mouse button to
tumble the view, and the right mouse button to zoom in.
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To create the cable surface, you will extrude the small circle along the
path curve.

2 Choose the Surfaces > Swept surfaces > Extrude tool.

3 You are prompted to select the curves to extrude. Click the circle to select
it to be extruded.

Select the Go button to choose the circle as the generation curve.

4 You are prompted to select the extrude path. Click on the long wavy
curve to select it as the path curve.
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The extruded surface is created.
5 Choose Pick > Nothing to deselect the surface.

6 Tumble and zoom out to view the cable surface.

Save your work

1 Choose File > Save as to save the current scene.

2 Save your work in the wire directory of the Lessons project.
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3 Name your file myjoystickd.wire.

Part 5: Assigning objects to layers

In this section, you will assign the curves and surfaces you have created to
new layers.

Opening the tutorial file (optional)

If you successfully completed Part 4, you can proceed directly to the next step,
Assigning curves to a layer.

If you were not successful in part 4, open the file called joystick part5.wire,
located in the wire directory of the courseware project. This file contains the
completed model from Part 4.

Part 5 of the tutorial.

Assigning curves to a layer

Layers are a way of grouping related objects and organizing a scene. By default,
all objects you create are assigned to the Default Layer.
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First, create a layer.

1 Choose Layers > New to create a layer.

Defaultayer [0 L1 O l

A new layer button called L1 appears in the Layer Bar. (The Layer Bar is
located just below the prompt line and just above the view window area.)

2 To rename the layer, in the Layer Bar, double-click the L1 layer.

ostautiayer [

Type the word Curves, and press Enter.

cotuitayer [ S

Next, you will select all the curves to be assigned to the layer. You will
use the Pick > Component tool which allows you to specify the type of
object you want to select. In this case, you will set it to select curves only,
so that all the curves can be easily selected using a drag box.

3 Choose Pick > Component.

4 Double-click the icon to open the option box.

£ pick Component Options x|

g Pick component

Al
o

Curves |V Construction Objects [v

Surfaces |7 Shells ’7
Meshes |7 Lights |7
Sections |7 Others ’7

Reset ‘ Save ‘ Exit | Go ‘
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Deselect all the options except Curves. Select the Go button at the bottom
of the option box.

=] pick Component Options

ﬂ Pick component

&l
v on

Curves |v  Construction Objects |
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Meshes J Lights J
Sections J Cthers J

Reset ‘ Save ‘ Exit | Go ‘

5 Drag a pick box around all of the objects to choose all the curves.

Only the curves are selected.
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6 In the Layer Bar, press and hold the left mouse button on the Curves layer
to display the pull-down menu. Then, choose Assign from the menu to
assign all the picked curves to the Curves layer.

7 Press and hold the left mouse button on the Curves layer, and choose
Visible to turn off the visibility of the layer.

The curves are no longer displayed in the scene.
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Assigning the surfaces to layers

1 Choose Layers > New to create another layer.

| Defaulti ayer | i

A new layer button called L2 appears in the Layer Bar.

2 To rename the layer, in the Layer Bar, double-click the L2 layer.

| Defaulti ayer | i

Type the word Joystick, and press Enter.

| Defauli ayer |

3 Choose Pick > Object.

4 Select the joystick base, sleeve, and handle.
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5 Inthe Layer Bar, press and hold the left mouse button on the Joystick layer
to display the pull-down menu. Then, choose Assign from the menu to
assign all the picked surfaces to the Joystick layer.

These surfaces are left visible, so you can continue working on them in
the next section.

6 Create another layer using Layers > New. Rename the layer Cable.

o ouves [ doystik [

7 Choose Pick > Nothing to deselect the joystick objects.

8 Choose Pick > Object and select the cable surface.
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10 Press and hold the left mouse button on the Cable layer, choose Set State,
then Inactive to make the cable surface inactive.

The cable surface is still visible, but is shown in pale blue and cannot be
selected.
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Finally, as you have finished using the sketches as guides, you will turn
them off.

11 Choose WindowDisplay > Toggles > Construction Objects to turn off the
sketches.
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Save your work

1 Choose File > Save as to save the current scene.

2 Save your work in the wire directory of the Lessons project. Name your
file myjoystick5.wire.

Part 6: Directly modifying surfaces

In this section, you will refine the design by directly moving the CVs of the
handle and base surfaces. The sketches shown below show the design changes:

The top of the base has changed from being a straight surface, to a gently
rounded surface.
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The top of the handle has a triangular, angled shape.

A button has been added to the base.
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Opening the tutorial file (optional)

If you successfully completed Part 5, you can proceed directly to the next step,
Deleting Construction History.

If you were not successful in part 5, open the file called joystick parté6.wire,
located in the wire directory of the courseware project. This file contains the
completed model from Part 5.
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Part 6 of the tutorial.

Deleting Construction History

All the surfaces are currently shown in dark green. This indicates that they
have construction history, which means that when the curves are modified
the surfaces will update.

In this section of the tutorial, instead of using the curves to modify the surfaces,
you will be modifying the surfaces directly.

To do this, you will first delete the construction history for the surfaces.

1 On the Layer Bar, use the left mouse button to click the Joystick layer, and
select Pick Objects from the pull-down menu.

Joystick s

Set state  w b

Visible v
Symmetry

All the joystick surfaces are selected.
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2 Choose Delete > Delete construction history. A dialog box appears asking
if you want to delete the construction history for the objects.

confirm

Delete construction history
for active objects ?

Yes Mo

Click Yes to delete the history.
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3 Choose Pick > Nothing to unpick all the surfaces.

NOTE The surfaces are now shown with dark blue lines, which indicate they
have no construction history.

Sculpting the Base

You have already used CVs to create and shape curves. Surfaces also have CVs
which can be used in the same way to directly modify the surface shape.
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By default, the CVs for a surface aren’t displayed, so next, you will turn on
the CVs for the top of the base.

1 Choose Pick > Object and select the top surface on the base.

2 In the Control Panel, click the CV/Hull check box to turn on the CVs
and Hulls for the surface.

The CVs and Hulls are displayed.

3 Choose Pick > Nothing to deselect the surface.

Part 6: Directly modifying surfaces | 241



4 Choose Layouts > Top or F5 to switch to the Top view.

The CVs on the surface are arranged in rows, connected by hull lines.
The arrangement of hulls on this surface is shown below.
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&

The hulls go in two directions. One set of hulls radiates out from the
middle of the surface.

S\
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The other set of hulls goes around the surface.

You will select the two center hulls from this set to sculpt a gentle curve
into the top surface of the joystick base.

5 Choose Pick > Point types > CV.

Pick |

oL

nothing object  comp
o

M=
e

crv srf  locator Jick wisible

Click the red hull line connecting the second row of CVs in from the
outer edge.
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The row of CVs is selected and highlighted in yellow.
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6 Click the red hull line connecting the third row of CVs in from the outer
edge.

Both rows of CVs are now selected.
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You will now move these hulls, and the associated CVs, upwards in the
Left view, to sculpt the surface.

7 Choose Layouts > Left or F6 to switch to the Left view.

8 Choose Transform > Move.

9 Click and drag the right mouse button to move the hulls upwards. Move
them enough to create a gentle curve on the top edge of the surface.
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The surface bends to give a rounded shape to the top of the joystick base.

10 On the Control Panel, click the CV/Hull check box to turn off the CVs
and Hulls for the surface.

11 Choose Pick > Nothing to unpick the surface.

Sculpting the Top of the Handle

Next, you will refine the shape of the top of the joystick handle.

1 Choose Pick > Object and select the handle surface.
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2 On the Control Panel, choose the CV/Hull check to turn on the CVs and
Hulls for the handle surface.

3 Choose Pick > Nothing to unpick the surface.
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Next, you will select the CVs that shape the top of the handle.

NOTE The pick palette has the Pick > Hull tool showing. Click and hold the
left mouse button on the Pick > Hull icon to open the tool drawer. Move the
mouse to the CV icon and release to select the Pick Point Types > CV tool.

Pick

€

nothing  object  comp

% N AR

template edit bl hull blend

A

cry srf  locator Jick visible

4 Choose Pick > Point types > CV. Drag a pick box around the top right set

of CVs shown below.
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The CVs are selected and highlighted in yellow.

The first modification will be to the plan shape of the handle, so the
transforms will be made in the Top view.

5 Choose Layouts > Top or the FS hotkey to switch to the Top view.

Part 6: Directly modifying surfaces | 251



6 Zoom in to see the handle CVs clearly. Hold down the Shift and the Alt
key together and click and drag the right mouse button to zoom.

7 Choose Transform > Non-p scale.

8 Click and drag the right mouse button to reshape the handle.
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TIP Click and drag away from any of the geometry to avoid selecting different
geometry.

The selected area of the handle surface is stretched.

9 Choose Pick > Nothing to unpick the CVs.
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Next, you will select the CVs to the left of the handle, so you can create
a soft pointed shape.

10 Choose Pick > Point types > CV and drag a pick box over the central CVs
on the left of the handle.

The center-line CVs are selected and highlighted in yellow.
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11 Choose Transform > Non-p scale and click and drag the middle mouse
button the stretch the handle surface outwards to the side.

12 Choose Pick > Nothing to unpick the CVs.

The top of the handle now has a smooth triangular shape.
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Sculpting the Handle Angle

Next, you will adjust the angle of the top of the handle, to make it more
ergonomic.

1 Choose Layouts > Left or F6 to switch to the Left view.

2 Choose Pick > Point types > CV and click and drag a box around all the
CVs at the top of the handle.
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The CVs for the handle grip are selected.

Rotation always works around the object’s pivot point. The pivot point
for the CVs defaults to the origin. To rotate the CVs correctly, you will
position the pivot point at the center of the selected CVs, using the Center
pivot tool.
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3 Choose Transform > Local > Center pivot.
The pivot point for the CVs is placed in the center of the CVs.

4 Choose Transform > Rotate and click and drag with the middle mouse
button to rotate the CVs about the y-axis.

5 Choose Transform > Move and click and drag with the middle mouse button
to move the CVs slightly to the right to create a smooth transition from
shaft of the handle.
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6 On the Control Panel, click the CVs/Hulls check to turn the CVs and
hulls off.

7 Choose Pick > Nothing to deselect the object.

8 Choose Layouts > Perspective or F8 to evaluate the design
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Save your work

1 Choose File > Save as to save the current scene.
2 Save your work in the wire directory of the Lessons project.

3 Name your file myjoystické.wire.

Part 7: Creating the button

In this section, you will create a button from a modified sphere.

Opening the tutorial file (optional)

If you successfully completed Part 6, you can proceed directly to the next step,
Creating a primitive sphere.
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If you were not successful in part 6, open the file called joystick part7.wire,
located in the wire directory of the courseware project. This file contains the
completed model from Part 6.

Part 7 of the tutorial.
Creating a primitive sphere

You will now create the button for the joystick, by placing and transforming
a primitive sphere.

1 Choose Layouts > Top or F5 to switch to the top view.
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2 In the Layer Bar, click the Joystick layer to select it.

The layer is shown in yellow. This means that it is the active layer, and
any new curves or surfaces are placed on it.

3 Choose Surfaces > Primitives > Sphere.

4 Double click the icon to open the option box. You need to create a whole
sphere, so check that the sweep is set to 360 degrees.
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= sphere Options x|

. Sphere

Sphere Type

~.~ Shell Tennis ball

.~ Shell Mo-Pole
Chject Degres

w1
Sweep | 360.00 deg

Sections | =3 U

Reseat ‘ Save ‘ Exit | Go ‘

Click the Go button at the bottom of the sphere option box.

5 Hold down the Alt key to turn on grid snapping. Click near the grid
intersection just inside the right-hand edge of the base.

A small sphere is placed on the grid intersection.

6 Choose Transform > Move.
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7 Click and drag the middle mouse button to move the sphere to half way
between the handle and the edge of the base.

8 Choose Transform > Non-p scale.

9 Click and drag the middle mouse button to stretch the sphere sideways.

10 With the Transform > Non-p scale still selected, click and drag the right
mouse button to stretch the sphere upwards, making an oval shape for the
button.
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11 Choose Layouts > Left (F6) to switch to the Left view.

12 Choose Transform > Move.

13 Click and drag the right mouse button to move the sphere vertically until
the center of the sphere is approximately aligned to the top edge of the
base.
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14 Choose Transform > Rotate.

15 Click and drag the middle mouse button to rotate the sphere to
approximately match the angle of the base.

16 Choose Pick > Nothing to unpick the sphere.

17 Choose Layouts > Perspective to switch to the Perspective view.
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Save your work

1 Choose File > Save as to save the current scene.
2 Save your work in the wire directory of the Lessons project.

3 Name your file myjoystick7.wire.

Part 8:Visualizing the Model

In this section, you will view the model using Hardware Shading.

Opening the tutorial file (optional)

If you successfully completed Part 7, you can proceed directly to the next step,
Shading the view.
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If you were not successful in part 7, open the file called joystick part8.wire,
located in the wire directory of the courseware project. This file contains the
completed model from Part 7.

Part 8 of the tutorial.

Shading the view

In the previous desk lamp tutorial, Diagnostic Shading was used to visualize
the model. In this tutorial, you will use Hardware Shade. Hardware shading
allows for more visual effects and introduces you to the techniques you will
use for rendering in later tutorials.

You will start by making the cable surface pickable, so it can be shaded.

1 On the Layer Bar, press and hold the left mouse button on the Cable layer,
choose Set State, then Pickable to make cable surface active.

2 Tumble the view until you get a good view of the joystick and cable. Hold
down the Shift and Alt keys and use the left mouse button to tumble the
view.
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3 Choose WindowDisplay > Hardware Shade.

The model is shaded in the default colour.

4 Choose WindowDisplay > Hardware Shade r to open the option box.
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2> Hardware shade settings
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B
.
.
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-

2

4 Enable Environment EFfects

Ground Plane | v

I < <

Edit: Environment |

=

5 In the Enable Environment Effects section:

B Click the Ground plane check box to turn on the ground plane effects.

B Click the Edit Environment button to open the Environment window.
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-ioix

Software ” Hardware (per vertex) |

+ Background

% Ground Plane

Prewview J

Height | -0.500 J
Shadaws |7
Shadow Blur | 0.200 J
Shadow Position DIRECTLY ABCWE |
Shadow Transparency | 0,250 J

Reflection J

¥ ShaderGlow

[lale |

6 In the Environment window, set the following options:

Open the Ground Plane section by clicking the small arrow next to
it.

Set the plane Height. Type in -0.5 and Enter to drop the shadow
slightly below the base.

Ensure the Shadows box has a check mark so that shadows are turned
on.

Change the Shadow Blur. Type in 0.2 and Enter to soften the shadows.

Change the Shadow Position. Click and hold the left mouse button on
the Shadow position menu, which is set to 45 DEGREES RIGHT by
default. Choose DIRECTLY ABOVE and release the mouse button.
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A shadow appears underneath the joystick and cable.

TIP If your screen shows the wireframe view, choose the Shade On button
at the bottom of the Hardware Shade Settings box.

it
4 Control options
Auto update| v

Shade off Shade on

To view the design more clearly, you will now turn off the wireframe and
grid.

7 In the title bar of the modeling window, click the Show button to open
up the menu and select Model (to remove the check mark). The wireframe
lines are turned off.
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+  Model 1

8 In the title bar of the modeling window, click the Show button to open
up the menu and select Grid (to remove the check mark). The grid lines
are turned off.

The joystick design is displayed in shaded mode, with no model lines or
grid lines showing.

9 Select Show > Model and Show > Grid once more from the window’s title
bar to bring back the check marks.

The scene returns to a wireframe view with grid.
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10 Close the Hardware shade settings option box by clicking the cross in
the top right corner.

.........................................................................................................

! Hardware shade settings
Winclones
Geromety

Show onh shading

Now that the Hardware Shade is set up, you don’t need to go into the
option box the next time you want to shade the model. Just choose
WindowDisplay > Hardware Shade to toggle the shading on or off.

Save your work

1 Choose File > Save as to save the current scene.
2 Save your work in the wire directory of the Lessons project.

3 Name your file myjoystick8.wire.
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Conclusion

Congratulations! You have completed the joystick model and have gained
experience in using curves and then surface tools to build freeform shapes.

Important concepts to take forward to future modeling projects are:

B On a curve, a minimum of 4 CVs are needed to create the curve. Adding
more CVs means that the curve can have a more complex shape.

B Construction history means that you can modify the shape of a surface
by changing the curves it was built from.

B Alternatively, you can turn on the CV display for the surface and modify
the surface CVs directly to change the surface shape.

B The Control Panel can be used to display or hide the CVs of a curve or
surface.

B [tis good practice to turn off the CVs on objects that aren’t being modified,
to reduce the complexity of the view on the screen.

W Regularly save your work!

Now that you have completed this joystick modeling tutorial, do this quick
quiz to help you remember the tools and techniques you have learned.

1 When you created a curve, how many CVs did you need to place before
the curve was created? If you aren’t sure, try it out now in AliasStudio!

B (a) One CV
m (b) Two CVs
B (c) Three CVs
B (d) Four CVs
m (e) Five CVs
2 To build a skin surface, how many curves do you need?
B (a) Only one

m (b) Only two
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(c) Two or more
(d) A minimum of three

(e) A minimum of four

3 To select a whole row of CVs on a surface with a single mouse click, which
tool would you use?

(a) Pick > Object

(b) Pick > Component
(c) Pick > Hull

(d) Pick > CV

(e) Pick > Edit Point

4 The Hardware Shade tool can be used to display which of the following?

(a) different colors on objects
(b) shadows falling on a ground plane
(c) reflections in shiny materials

(d) only shaded geometry with no wireframe, CVs, or edit points
showing

(e) all of the above

5 To position the pivot point at the center of a group of selected CVs, which
tool would you use?

(a) Transform > Local > Set pivot and the Ctr/ key to snap to a CV
point

(b) Transform > Move and move the mouse to the center of the CVs
(c) Pick > Hull and Transform > Local > Set pivot
(d) Transform > Local > Center pivot

(e) The F9 hotkey

6 Match the Hotkeys F5 to F9 to the window views.

(a) Back
(b) Top
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B (o) All four views
B (d) Left

B (e) Perspective

On Your Own

The tools and techniques that you have learned are the basis of all complex
modeling with AliasStudio. Use curves and surfaces, controlling their shape
with CVs, to create the following designs.

The main body and lid of the coffee pot shown below are created using a
revolved surface. The handle is an extrusion and the spout is a skin surface.
You will notice that the components are intersecting and have not been fully
detailed. This is acceptable for a concept model and you will learn the detailing
techniques in the following tutorials.
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Continuing the kitchen theme, the lemon squeezer handle is built from
revolved surfaces. The squeezer was sculpted from a simple revolved shape.

The number of spans was increased, to allow for the number of grooves, and
alternate rows of CVs were scaled inwards.
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The flashlight below is based on a circle which has been shaped to a smooth
square shape. Skin surfaces have been used for the main shape, with extrude
surfaces used for the grip detail and the lanyard.
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Quiz Answers

Answers to the Joystick Tutorial quiz

1 (d) Four CVs. You created a default degree 3 curve, which requires a
minimum of 4 CVs before it is created. To learn more about CVs and
curve degree, see Mathematical representations of curves.

2 ¢) Two or more curves can be used to build a skin surface. If only two
curves are used, a ruled, straight, surface is created between them. If more
curves are used, use the shift key to select the third and subsequent curves.
The surface is blended smoothly through all the curves.

3 ¢) The Pick > Hull tool. A whole row of CVs can also be selected using
Pick > CV and carefully dragging a pick box around the required CVs.
The Pick > Hull tool is often easier to use, and it is often good practice to
modify a whole row of CVs together, to have more control over the final
shape of a surface.

4 e) All of the options listed can be displayed using the Hardware Shade
tool. This tool has been significantly enhanced in AliasStudio and can
be used very effectively to present and visualize your designs.
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5 d) The Transform > Local > Center pivot tool. This tool can be used with
all objects, curves, surfaces, and groups of CVs.

6 Match the Hotkeys to the window views.

Window Hotkey
Back F7
Top F5
All four views F9
Left F6
Perspective F8
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Modeling aVacuum
Cleaner

Learning Objectives

In this lesson, you will build a hand-held car vacuum cleaner. This lesson introduces you to
more surface building techniques. You will learn how to:

B Create swept surfaces

B Trim off the excess areas of surfaces
B Create rounded edges
|

Use Layers to organize complex models
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Modeling Workflow

In this tutorial, you will use a modeling technique called overbuilding and
trimming. With this technique, you will create simple swept surfaces to define
the main shape of the design. You will then combine these surfaces using
intersecting and trimming.

As the vacuum cleaner design is symmetrical, you will save time by only
building and detailing one half of the model. When the design is complete,
you will copy and mirror the surfaces to create the full model.

The workflow you will use to create the vacuum cleaner model is shown below.

First, you will create the main surfaces, and then intersect and trim them to
create the body shape. Throughout the tutorial, you will build one half of the
vacuum cleaner, and at the end, you will mirror the surfaces to create the
completed model.

7

Then, you will fillet the surfaces and add design details, further trimming the
main shape.

New tools used in this tutorial

B Pick > Object types > Curve on surface
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Pick > Template

Object Edit > Patch precision

Surfaces > Swept surfaces > Rail surface
Surfaces > Surface fillet

Surface Edit > Create CurvesOnSurface > Intersect

Surface Edit > Trim > Trim surface

New menu items used in this tutorial

B Object Display > Template

Part |: Creating Primary Surfaces

In this section, you will use the mono-rail tool to create the two surfaces that
define the vacuum cleaner body.

In the tutorial, file the main curves have already been created and are supplied
on a layer called curves. As you don’t have to create the curves for this model,
you will be able to focus on the techniques of intersecting and trimming
surfaces introduced in this tutorial.

The curves have been created using the same techniques you learned in Tutorial
2. If you want to see how the curves are constructed, use the Control Panel
CV/Hull display to display the CVs.

If you prefer to create your own curves, you can make the curves layer inactive,
and create your own curves using these as a guide.

Opening the tutorial file

1 Choose File > Open to open the File Browser.

2 In the File Browser, locate the courseware directory and set it as the
Current Project.

3 Open the file called vacuum.wire, located in the wire directory in the
Courselare project.

For information on how to open a file, see Opening the tutorial file in a
Windows Environment on page 86.

Part |: Creating Primary Surfaces | 283



confirm

DELETE all objects,
shaders, views and actions
before Opening this File?

‘fies ‘ Mo Cancel

A dialog box appears, asking if you want to delete all objects, shaders
views, and actions. Click YES.

If your values for construction tolerances differ from those in the
vacuum.wire file, you will be presented with a dialog:

The Construction Cxtions of tha retrieved file differ from the ornant session
Do 4ol wearit o ke the current Construction Cptions?

Option Typs Current  hew
[Linzar units - Manuni= | mm [ cm
ezt New Setinge

Click Accept New Settings to use the construction tolerances in
vacuum.wire.

The file is opened.
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If the modeling views do not occupy the full size of the AliasStudio
window, choose Layouts > All windows > All windows .

Part 1 of the tutorial.

Creating the lower surface

You will start by creating the lower body shape using a mono-rail surface.

1 Maximize the Perspective view.
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2 Choose Surfaces > Swept surfaces > Rail surface.
Surfaces
o = 0 = 0 I
sphere  planar revolve
o El = n‘ =
skin | brail_i | square
A Y

rface filleform ble tub ofst

The Rail surface defaults to a birail, which has two path curves. You will
now change this to a mono-rail, with only one path curve.

3 Double-click the Rail surface icon to open the option window.
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4 In the Rail Surface option window, click 1 in the Rail curves section.
Check that the Generation curves section is also set to 1.

E Birail I Gen. Control — |E| |i|

Sirnple I Advanced ]
Generation Curves
ARV
Rail Curves
2
Continuity | Rebld |
gen. 1 POSITION I
rail 1 POSITION
rail 2 POSITION

Recalc. Ment ‘

5 Close the Rail Surface option window by clicking the X in the top right
corner.
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You are now prompted to select the generation curve.

6 Use the left mouse button and click the curve shown to select it as the
generation curve.

The curve is highlighted.

You are prompted to select the primary rail curve.

7 Click the lower profile of the vacuum to select it as the path curve.

288 | Chapter 6 Modeling aVacuum Cleaner



A mono-rail surface is created.

8 Choose Pick > Nothing to deselect the surface.
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To see the shape of the surface more clearly, you will use Diagnostic
Shading on the Control Panel to shade the surface.

% Diaghostic Shading

Tolerance
| o.o100 | |

Tessellator

. BCCUrate

98 |
E

TIP If the Control Panel is not displayed on your screen, choose Windows >
Control Panel to make it visible.

9 Select the blue shade icon to turn on the shading .
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The surface is shaded in a default blue color.

10 Select the Diagnostic Shading wireframe icon on the Control Panel to
turn off the shading.

R

Use the diagnostic shading throughout this tutorial to visualize the
geometry.

Creating the Upper Surface

Next, you will create the upper surface of the vacuum cleaner using a Mono-rail
surface with two generation curves. When two generation curves are used,
the surface blends between the two shapes, as it sweeps along the path curve.
This will create a smooth surface blended between the wide nozzle and the
narrower handle section.

1 Choose Surfaces > Swept surfaces > Rail surface. Double-click the icon to
open the option window.

The Rail tool is set for 1 generation curve and 1 rail curve.
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2 In the Rail surface option window, click 2 in the Generation curves
section.
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3 Close the option window.
You are prompted to select the generation curve.

4 Click the curve located at the front of the vacuum nozzle to select it as
the first-generation curve.
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The curve is highlighted.

You are then prompted to select the next generation curve.

5 Click the curve located at the rear of the vacuum cleaner body to select
it as the second-generation curve.

The curve is highlighted.

Next, you are prompted to select the primary rail curve.

6 Click the upper profile curve of the vacuum cleaner body.
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A mono-rail surface is created that blends smoothly between the two
generation curves.

7 Choose Pick > Nothing to deselect the surface.
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8 Use Diagnostic Shading on the Control Panel to view the relationship
between the two overlapping surfaces.

You have now created the two main shapes that will be used to create
the vacuum cleaner body.
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Saving your work

Now, you will save the scene as a new file.
1 Choose File > Save as to open the File Browser.

2 In the File Browser, locate the Lessons directory. Set the Lessons directory
as the Current Project.

3 Save your work in the wire directory of the Lessons project.

4 Name your file myvacuum.wire.

For information on creating the Lessons project, or saving your work, see
Saving your work on page 99.

Part 2: Intersecting and Trimming

A common way to combine NURBS surfaces is to intersect the surfaces, then
trim them where the two surfaces cross each other. This is the approach you
will take with the upper and lower surfaces of the vacuum cleaner.

First, you will intersect the surfaces. When you intersect surfaces, you create
curves-on-surface, which are lines that are created on the surfaces where the
surfaces intersect. You will then trim the intersecting surfaces along the
curves-on-surface, so the unnecessary surface areas are discarded, and only
the necessary surface areas remain.

Opening the tutorial file (optional)

If you successfully completed Part 1, you can proceed directly to the next step,
Intersecting the upper and lower surfaces.
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If you were not successful in part 1, open the file called vacuum part2.wire,
located in the wire directory of the courseware project. This file contains the
completed model from Part 1.

Part 2 of the tutorial.

Intersecting the upper and lower surfaces

Now, you will intersect the upper and lower surfaces to create the body shape.

1 Click the wireframe icon in the Diagnostic Shading area of the Control
Panel to remove the shading.
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2 Choose Surface Edit > Create CurvesOnSurface > Intersect. This tool
creates the curves-on-surface that are used to trim the surfaces.

Surfaré Eaf h
o I‘=:>
project
DG

subtract  hull pl

project pro nrmllintersecigec map

rebuild

3 You are prompted to select the surface(s) to intersect.
Use the left mouse button to click the upper surface to select it.
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The surface is highlighted and a Go box appears in the lower right corner
of the view.

Click the Go box to select the first surface to be intersected.
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The surface is highlighted in pink.

4 You are prompted to select the intersecting surface.
Click the lower surface to intersect it with the upper surface.

The surfaces are intersected. Two curves-on-surface are created, one on
each surface.
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By default, the Intersect tool creates a curve-on-surface on each surface
so each surface can be trimmed.

Both surfaces are now drawn with a dotted outline to indicate that each
has a curve-on-surface.

Choose Pick > Object types > Curve on surface.

Drag a pick box around the intersected surfaces to pick the
curves-on-surface.
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The highlighted curves that appear are the two curves-on-surface. It looks
as though there is only one curve-on-surface, but in fact there are two in
the same location, one on the upper surface, and one on the lower surface.

7 Choose Pick > Nothing to unpick the curves-on-surface.

Trimming the surfaces

Now, you will trim off the excess from the upper and lower surfaces.

NOTE A trimmed surface is not actually cut; it exists in a hidden form that does
not render or affect modeling. While performing a trim, you can easily discard
part of a timmed surface by selecting the unwanted portion of the geometry and

L LK Discard
clicking the Divide = ‘

corner of the screen.

Divide

button that appears at the bottom right

1 Choose Surface Edit > Trim > Trim surface.

2 You are prompted to select a surface to trim.
Pick the upper surface.
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3 You are then prompted to select one of the following:

Shift select to select surfaces or click to select REGIONS.

The last option allows you to trim away the excess parts of the surface,
so this is the prompt you will respond to.

Click any part of the upper surface on the inside part that you want to
keep.

Digcard

The Trim tool places an indicator where you clicked and an option box
appears in the bottom right corner of the view.
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4 Click the Keep button.

The upper surface is trimmed.

5 Repeat steps 1 — 4 to trim the lower surface.
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Creating the nozzle surface

Next, you will create a planar surface across the mouth of the nozzle, to
complete the exterior shape of the vacuum body.

1 1 Choose the Surfaces > Planar surfaces > Set planar tool.
2 You are prompted to select a curve.

3 Click the straight-line curve along the center grid line to select it as the
first curve for the planar surface.
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The curve is selected and a Go button appears in the bottom right corner
of the view.

You are prompted to select another curve.
Click the front nozzle curve to select it as the second curve for the planar

surface. If the pick chooser appears, make sure that you pick the curve,
not the surface edge.

The curve is selected, and you are prompted to select another curve.
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5 Click the rear nozzle curve to select it as the third curve for the planar
surface.

The curve is selected. The three curves form a closed region within which
the planar surface will be created.

6 Click Go to create the planar surface.

N

The surface is created and highlighted in pale yellow.

7 Choose Pick > Nothing to deselect the planar surface.
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8 Use Diagnostic Shading in the Control Panel to view the model.

Save your work

1 Choose File > Save as to save the current scene.
2 Save your work in the wire directory of the Lessons project.

3 Name your file myvacuum2.wire.
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Part 3: Surface Fillet

Now that you have intersected and trimmed the upper and lower surfaces,
there is a sharp edge where the two surfaces meet.

To create a rounded transition between the two surfaces, you will create a
fillet surface using the Surfaces > Surface fillet tool.

The surface fillet tool will create a rounded surface that blends smoothly
between two surfaces, or two sets of surfaces. As well as creating the rounded
surface, the Surface fillet tool can also trim back the original surfaces to create
a finished continuous form. This trimming is achieved using curves-on-surface,
which are automatically created by the Surface fillet tool.

Opening the tutorial file (optional)

If you successfully completed Part 2, you can proceed directly to the next step,
Creating the body fillet.

If you were not successful in part 2, open the file called vacuum part3.wire,
located in the wire directory of the courseware project. This file contains the
completed model from Part 2.

Part 3 of the tutorial.
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Creating the body fillet

Next, you will create a fillet surface along the intersected edge of the vacuum
cleaner body.

The Surface fillet tool uses surface indicators to choose which side of a surface
to create the fillet. These indicators are easier to see in a wireframe view. So
you will first turn off the shaded view.

1 Return to a wireframe view by clicking the wireframe icon in the
Diagnostic Shading section of the Control Panel.

The upper surface only has lines showing on its edges. To improve the
visualization of the surface, and to make it easier to select, you can
increase the number of lines across the surface using the patch precision
tool.

Next, you will increase the patch precision for the upper surface.
2 Choose Pick > Object and select the upper surface.

3 Choose Obiject edit > Patch precision.
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Object Edit

You are prompted to enter the number of curves per patch. Type in 3
and press Enter.

The surface is now displayed with some dotted lines across its interior.
These dotted lines make the surface easier to visualize in wireframe, and
can be used to select the surface.

Next, you will create the surface fillet along the trimmed edge where the
two main surfaces meet.

4 Choose Surfaces > Surface fillet. Double-click the icon to open the option
box.
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¥ surface Fillet Control o ]
Simple | Advanced —|

Construckion Type COMNSTANT |

Section Type CIRCULAR |
Radis | 1ooon ||

% Contral Options

Auta Recale, J Continuity Check J

5 In the Radius section, type in a radius value of 0.75.

=¥ surface Fillet Control o ] 4]
Simple |ndvanced —|

Construckion Type COMSTAMT |
Section Type CIRCULAR |
Radus | 07500 ||

% Control Options
Auto Recalc, J Continuity Check J

6 Click the Advanced tab to open the advanced options for the surface
fillet tool.
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= surface Fillet Control i ] 3]
Simple I.ﬂ.dvanced

Construction Type COMNSTAMT |
Seckion Type CIRCULAR |
Surface Type MULTIFLE SURFACES |

Radivs | 07500 ||

Shart Edge Tolerance | 0.0010 U
Bézier Surfaces J

Explicit Contral J

% Flow Cantral

Skart DEFALLT |
Inkerior FREE |
End DEFALLT |
4 Contral Options
Trim Type AUTOMATIC |
Curvature Comb J Caontinuity Check J

Auka Recale, J

Recalc, Undao Al et

In the Flow Control section, there are pull-down menus for the Start,
Interior, and End of the fillet surface.

EDGE ALIGN
EXTEND
DEFAULT

The Start and End options are set to DEFAULT. For the Start and End,
select EDGE ALIGN.
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- § 0.
Single Surface J
% Flow Contral

Start EDGE ALIGMN l
Inter o FREE |
End EDGE ALIGN |

& Control Options
Trim Type AUTOMATIC l

This choice ensures that the fillet surface is built to the full length of the
edge, and the upper and lower surfaces are correctly trimmed.

Close the Surface fillet option box.

7 You are prompted to select the first set of surfaces. Pick the upper surface.

If the pick chooser appears, select the mono-rail surface.
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The surface is selected and highlighted in pink, an Accept box appears
in the bottom right corner of the view, and a pale blue arrow is displayed.

The blue arrow is used to decide which side of the surface the fillet is
built on. You need to specify the arrow direction for both surfaces to
ensure the fillet is built correctly.

For this upper surface, this arrow needs to point inwards towards the
inside of the vacuum cleaner body. If necessary, tumble the view to see
which direction the arrow is pointing.
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If it is pointing out from the surfaces, then click the blue arrow to reverse
it. If it is already pointing inwards, then continue to the next step.

8 Click Accept to select the first surface for filleting.

9 You are prompted to select the second set of surfaces. Click the lower
surface to select it.

The surface is selected and highlighted in yellow, an Accept box appears
in the bottom right corner of the view, and a pale blue arrow is displayed.
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Again, this arrow needs to point in towards the surface. If it is pointing
out of the surface, then click the arrow to reverse it. If it is already pointing
inwards, then continue to the next step.

10 Click Accept to select the second surface for filleting.

The fillet surface is created, and the upper and lower surfaces are trimmed.

11 Choose Pick > Nothing or click Enter to deselect all the surfaces.
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Creating the nozzle fillet

The Surface fillet tool can be used in different modes. The default mode, which
you used for the body fillet, is to create a circular fillet. This creates a constant
radius surface along the length of the fillet surface.

For the nozzle, you will create a chordal fillet. A chordal fillet maintains a
constant width of surface, instead of a constant radius. This will produce a
more regular surface when the angle between the two main surfaces varies

along their edge.
1 Choose Surfaces > Surface fillet. Double-click the icon to open the surface

fillet option box. In the Advanced tab, the flow control settings are
currently set to Edge Align for the start and end.

! surface Fillet Control - o] x|
Simple | Advanced ]

Span Placement | ONE-PER-BOUNDARY |

Radius | 07500 ||

Short Edge Tolerance | nooi0 ||

Single Surface | |
% Flow Control
Start EDGE ALIGN |
Interior FREE |
End EDGE ALIGN |

% Control Options

Trirn Type AUTOMATIC |
Curvature Comb | Continuity Check |
Ll Auto Recale, | |

Recalc. Lindo &ll [t

2 The Flow Control settings can be returned to the default settings. On the
pull-down menu for the Start and End settings, choose DEFAULT.
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Single Surface |
% Flow Control
Start DEFALLT |
Interiar FREE |
End DEFAULT |
% Control Options
Trim Type AUTOMATIC |

NOTE The ends of the fillet fall on the center-line of the vacuum design. As
the edges of the main surfaces are already aligned to the center-line, the
Surface fillet EDGE ALIGN adjustment isn’t required.

3 Inthe Construction Type setting, there are three choices on the pull-down
menu.

CHORDAL |
VARIABLE
CONSTANT

Choose Chordal from the pull-down menu to select a constant width
fillet.

4 Only a small fillet is required around the nozzle, so in the Chordal
Distance section, type in a value of 0.5.

ol
Simple_| Advanced _|I

Construction Type CHORDAL
Section Type CIRCULAR
Span Placement  ONE-PER-BOUNDARY

Chordal Distance | o.5000 ||

Close the Surface Fillet option box.

5 You are prompted to select the first set of surfaces. Drag a pick box around
the upper, lower and fillet surfaces, avoiding the planar surface.
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All three surfaces are selected and highlighted in pink, an Accept box
appears in the bottom right corner of the view, and a pale blue arrow is
displayed.

This arrow needs to point in towards the inside of the vacuum body. If
it is pointing out of the surface, then click the arrow to reverse it. If it is
already pointing inwards, then continue to the next step.

6 Click Accept to select the first set of surfaces for filleting.
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7 You are prompted to select the second set of surfaces. Click the planar
surface to select it.

If the pick chooser appears, pick the trim_surface.

The surface is selected and highlighted in yellow, an Accept box appears
in the bottom right corner of the view, and a pale blue arrow is displayed.
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This arrow needs to point upwards towards the inside of the vacuum
body. If it is pointing downwards, out of the surface, click the arrow to
reverse it. If it is already pointing upwards, continue to the next step.

8 Click Accept to select the second surface for filleting.

The chordal fillet surface is created, and the surfaces trimmed to create
a smooth, continuous exterior.
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9 Choose Pick > Nothing to deselect all the surfaces.
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Save your work

1 Choose File > Save as to save the current scene.
2 Save your work in the wire directory of the Lessons project.

3 Name your file myvacuum3.wire.

Part 4: Creating the Handle

In this section, you will create a hole through the vacuum cleaner body to
create a handle. As before, when you built the main body shape, you will
overbuild surfaces to create an intersection.

This time, however, you will not use the intersection and trim tools to create
a sharp-edged shape. Instead, you will use the Surface fillet tool to create a
rounded edge and trim at the same time.

Opening the tutorial file (optional)

If you successfully completed Part 3, you can proceed directly to the next step:
Creating the handle surface below.
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If you were not successful in part 3, open the file called vacuum part4.wire,
located in the wire directory of the courseware project. This file contains the
completed model from Part 3.

Part 4 of the tutorial.

Creating the handle surface

You will create the handle using a skin surface, built from the handle curve
provided in the tutorial file.

First, you will make a copy of the handle curve and move it to the side of the
vacuum, to create the two curves needed for the skin.

1 Choose Pick > Object and select the oval shaped handle curve.
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2 Choose Edit > Copy followed by Edit > Paste. The screen appears the
same, but a second curve has been created and placed on top of the
original, and is selected, ready to be moved.

3 Choose Transform > Move. Since you are working in the perspective view,
the mouse buttons can be used to specify a move in the x, y, or z direction.
Click and hold the middle mouse button and move the second curve in the
negative y-direction. Move the curve so it is well outside the vacuum
body surfaces.
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4 Use the F9 hotkey to display all four views, to check that the copied curve
is outside the main body.

5 Use the F8 hotkey to return to the perspective view.
Next, you will create a skin surface between the two handle curves.

6 Choose the Surfaces > Skin tool.

7 You are prompted to select the first curve. Click the first handle curve to
select it for the skin surface.
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The curve is highlighted, and you are prompted to select the next curve.
Click the second handle curve to select it.

The skin surface is created and highlighted in white.

8 Choose Pick > Nothing to deselect the skin surface.

9 Use Diagnostic Shading to check that the handle surface passes through
the body surfaces.
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TIP If the handle surface falls short of the body surfaces, use Pick > Object
to select the second handle curve. Then, use Transform > Move with the
middle mouse button to adjust the position of the curve. Because the skin
surface has construction history, it will be rebuilt to the new curve position
when the mouse button is released.

10 Return to a wireframe view by selecting the wireframe icon in Diagnostic
Shading.
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Creating the handle fillet

Next, you will use the Surface fillet tool to trim the handle and upper body
surfaces, and to create a rounded edge.

1 Choose Surfaces > Surface fillet. The settings you used before will be used
for this fillet surface, so you don’t need to open the option box.

NOTE If you have exited AliasStudio since building the last fillet, see Creating
the nozzle fillet on page 319 for the correct Surface fillet options to use.

You are prompted to select the first set of surfaces. Click the upper surface
to select it.

The surface is selected and highlighted in pink, an Accept box appears
in the lower right corner of the view, and a pale blue arrow is displayed.
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This arrow needs to point in towards the inside of the vacuum surfaces.
If it is pointing out from the surfaces, then click the arrow to reverse it.
If it is already pointing inwards, then continue to the next step.

2 Click the Accept box to select the first surface for filleting.

3 You are then prompted to select the second set of surfaces. Click the
handle surface to select it.
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The surface is selected and highlighted in yellow, an Accept box appears
in the bottom right corner of the view, and a pale blue arrow is displayed.

This arrow needs to point outwards from the handle surface. If it is
pointing in towards the center of the handle, then click the arrow to
reverse it. If it is already pointing outwards, continue to the next step.

4 Click Accept to select the second surface for filleting.

A small fillet surface is created, and the upper and handle surfaces are
trimmed.
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To create a comfortable handle, a larger fillet is required.
5 Choose Surfaces > Surface fillet.p to open the option window.

6 Type 1.25in the Chordal Distance field and press Enter to adjust the fillet

size.
> surface Fillet Control =1o
Simple |Advanced |
Construction Type CHORDAL |
Section Type CIRCULAR, |
Surface Type MULTIPLE SURFACES |
Chordal Distance | 1.2500 U
Short Edge Tolerance | 0.0010 U

A Recalc button appears at the bottom right corner of the view.

7 Click Recalc to rebuild the fillet.
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The fillet is rebuilt to the larger size, providing a more comfortable handle
design.

8 Choose Pick > Nothing to deselect all the surfaces.

9 You have now completed the main body shape for the vacuum cleaner
design.
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Save your work

1 Choose File > Save as to save the current scene.
2 Save your work in the wire directory of the Lessons project.

3 Name your file myvacuum4 .wire.

Part 5:Air Vents

In this section, you will create grooves to represent styled air intakes.

Opening the tutorial file (optional)

If you successfully completed Part 4, you can proceed directly to the next step,
Creating the groove surfaces.

If you were not successful in part 4, open the file called vacuum part5.wire,
located in the wire directory of the courseware project. This file contains the
completed model from Part 4.

Part 5 of the tutorial.
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Creating the groove surfaces

The groove surfaces will be created from three extruded tube shapes. The
profile of the tubes will be circular, and the path will follow the general shape
of the main body. To create an interesting intersection line, the path curve
will pull away from the body shape so the grooves fade out at the outer edge.

To match the character of the main body shape, you will use the original
nozzle curve as a path to extrude the three groove surfaces.

1 Choose Pick > Object and select the front nozzle curve.

NOTE The surfaces are highlighted in pink. This indicates the surfaces have
construction history. If the curve is modified, the surfaces will update. You
will not be modifying the curve; instead, you will take a copy so the shape
can be changed without affecting the surfaces.
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2 Choose Edit > Copy followed by Edit > Paste to create a copy of the curve.

NOTE The surfaces are no longer highlighted in pink, as the new curve is a
new copy with no relationship to the surfaces.

3 Choose Transform > Scale and type in 1. 5 to increase the size of the curve.
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4 Choose Pick > Nothing to deselect the curve.

This scaled curve will be used as a path curve for the extruded surfaces.

The three gray circles at the front of the vacuum cleaner have been
templated. You will now untemplate these so you can use them as the
generation curves for the extrude surfaces.

5 Choose Pick > Template and drag a pick box around the three circles.
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6 Choose ObjectDisplay > Template to return the curves to pickable
geometry.

You will now extrude the circles along the path curve.

7 Choose Surfaces > Swept surfaces > Extrude. You are prompted to select
curve(s) to extrude.

8 Pick all three circles.
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Click Go to select the circles for extrusion.

9 You are prompted to select the extrude path. Click the larger curve you
have just scaled to select it as the path curve.

Three surfaces are created, following the shape of the upper surface.
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Intersecting and Trimming the air vents.

You will now intersect and trim the three extruded surfaces with the upper
surface of the vacuum body.

1 With the three surfaces still selected, choose Surface Edit > Create
CurvesOnSurface > Intersect.
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The three extruded surfaces are highlighted in pink, indicating they are
selected for intersecting.

Because the three extruded surfaces are already selected, you are prompted
to select the surface to be intersected.

Pick the upper surface of the vacuum.

The surfaces are intersected and the curves-on-surface created.

Now, you will trim the excess from the surfaces, starting with the extruded
surfaces. In this trimming operation, it is easier to select the part of the
surfaces you want to discard, so you will use the Discard option in the
trim tool, instead of the Keep option.

Choose Pick > Object and drag a pick box to select the three extruded
surfaces.
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TIP If you have many surfaces to trim, you can select them all using a pick
box before choosing the trim tool.

4 Choose Surface Edit > Trim > Trim surface.

Discard

The surfaces are highlighted in pink, and you are prompted to select the
regions to trim.
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5 Click the first extruded surface, in the region to discard

6 DPick the second extruded surface, also in the regions that need to be
discarded.

7 Pick the third extruded surface, also in the regions that need to be
discarded.
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8 Click Discard at the lower right corner of the view.

The excess surfaces are discarded.

Next, you will trim the upper surface.

9 Still in the Trim tool, pick on the upper surface to select it for trimming.
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10 Click the main region of the upper surface to select it as the part of the
surface to keep.

An indicator is placed where you clicked and three buttons appear in the
bottom right corner of the view.

11 Click Keep to trim the surface.
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The upper surface is trimmed.

12 Choose Pick > Nothing to complete the trimming operation.
Now that you have created all the main surfaces, you will make the curves
layer invisible, so the surfaces can be viewed more clearly.

13 On the Layer Bar, click and hold on the curves layer to view the pull-down
menu. Select Visible to turn off the visibility of the layer.

| Defauayer [  cuves [,

In the Layer Bar, the curves layer is displayed with a dotted outline to
indicate it is turned off.

The curves are no longer displayed on the screen.

14 Use Diagnostic Shading to evaluate the results.
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Save your work

1 Choose File > Save as to save the current scene.
2 Save your work in the wire directory of the Lessons project.

3 Name your file myvacuums.wire.

Part 6: Power Button

In this section, you will create the on/off button for the vacuum cleaner.

You will create the button detail in two stages. First, you will create a recess
in the body surface where the button will sit. Then, you will create the button
so it sits flush with the body surface.

Because one set of surfaces will fit into another, you will use layers to organize
the geometry.

Opening the tutorial file (optional)

If you successfully completed Part 5, you can proceed directly to the next step,
Creating a cylinder for the power button.
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If you were not successful in part 5, open the file called vacuum parté.wire,
located in the wire directory of the courseware project. This file contains the
completed model from Part 5.

Part 6 of the tutorial.

Creating a cylinder for the power button

First, you will create a cylinder surface for the outline of the power button.

1 Return to the wireframe view using the Diagnostic Shading in the Control
Panel

2 Choose Layouts > Top or the F5 hotkey to switch to the Top view.
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3 Choose Surfaces > Primitives > Cylinder. Double-click the icon to open
the cylinder options.

= cylinder Options x|

. Cylinder

Object Degree
w1
Sweep I 360,00 deg

Sertinns | B []
Caps 2 |

Reset ‘ Save ‘ Exit | Go ‘

4 Set the Sweep to 180 and the Sections to 4 to create a half cylinder. Set
the Caps to O from the pull-down menu, to only create the side wall of
the cylinder.
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= cylinder Options

. Cylinder

Object Degree
V1
Sweep | 180,00 deg

Sections | 4 I
Caps 0 |

Reset ‘ Save ‘ Exit | Go ‘

Click the Go button to create the half cylinder.

5 In the Top view, hold down the Alt key to turn on grid snapping, and
click near the origin. Snapping the cylinder on the origin ensures that it
is centered.

6 With the cylinder still selected, choose Transform > Non-p scale. Type
in 4,-3,2 to scale the half cylinder to an oval shape, and to invert it so it
is on the right side of the grid.
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7 Choose Layouts > Left to switch to the Left view.

8 Choose Transform > Move. Hold down the Ctr/ and Alt keys to turn on
curve snapping. Point the cursor at the top edge of the upper surface and
click and hold down the left mouse button. With the mouse button still
pressed, move the cylinder until it is roughly half way between the handle
and the air vents.
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The cylinder moves along the edge.

9 Choose Transform > Rotate and type in 0,-40,0 to rotate the cylinder
around the y-axis. Check that the cylinder is entering the upper surface
at a good angle. If you need to adjust the angle further, click and drag
the middle mouse button to adjust the y-rotation.

10 Choose Layouts > Perspective, or the F8 hotkey to return to the perspective
view.
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11 Choose Pick > Nothing to deselect the cylinder.

Creating two surfaces for the button and the recess

The cylinder you have just created will be used twice. First, you will use it as
the sidewall of the power button, then a second copy will be used to create
the sidewall of the recess in the main body.

The upper surface will also be used twice. A copy will be used to create the
top of the power button. Most of the surface will be trimmed away, but the
part that is left will be flush with the vacuum body.
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The original upper surface will be trimmed to create the recess for the button.

To avoid confusion with these copied surfaces, you will first create layers for
the body surfaces, and for the power button surfaces.

1 Choose Layers > New to create a layer.

Defauliayer O . cuves A - O

2 Rename the layer body.

Defaultlayer | ___________

3 Choose Pick > Object. Click-drag a pick box over all the geometry to select
all the surfaces.

4 On the Layer Bar, click and hold on the body layer to see the pull-down
menu. Choose Assign to assign all the surfaces onto the layer.

Defaull ayer l

5 Choose Pick > Nothing to deselect all the surfaces.
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6 Now, you will create a second layer for the power button.

Choose Layers > New to create a layer.

8 Choose Pick > Object. Pick the half cylinder and the upper surface of the
vacuum body.

9 Choose Edit > Copy followed by Edit > Paste. The two surfaces are copied
and left selected.
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10 On the Layer Bar, click and hold on the power_button layer to view the
pull-down menu. Choose Assign to assign the two copied surfaces onto

the layer.

You now have two copies of the cylinder and top surface, one on the
body layer, and one on the power_button layer.

11 Choose Pick > Nothing to deselect the surfaces.

Creating the power button

Next, you will use the copied surfaces to create the power button. You will
use the Surface fillet tool to trim and round the edge of the power button.

1 On the Layer Bar, click and hold on the body layer to see the pull-down
menu. Choose Visible to make the body surfaces invisible.
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Only the two surfaces you copied are visible.

2 Choose Surfaces > Surface fillet. Double-click the icon to open the option
box.

Change the settings to Construction Type CONSTANT and Radius 0.25.

Simple I Advanced

Construction Type CONSTAMT |
Section Type CIRCLLAR |
Surface Twpe MULTIFLE SURFACES |

Radius | 0,2500 U

Close the Surface Fillet option window.

You are prompted to select the first set of surfaces. Click the upper surface
to select it.
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The surface is selected and highlighted in pink, an Accept box appears
in the bottom right corner of the view, and a pale blue arrow is displayed.

This arrow needs to point in towards the inside of the vacuum surfaces.
If it is pointing out from the surfaces, then click the arrow to reverse it.
If it is already pointing inwards, then continue to the next step.

3 Click Accept to select the first surface for filleting.
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4 You are then prompted to select the second set of surfaces. Click the half
cylinder surface to select it.

The surface is selected and highlighted in yellow, an Accept box appears
in the bottom right corner of the view, and a pale blue arrow is displayed.

This arrow needs to point inwards on the cylinder surface. If it is pointing
outwards, then click the arrow to reverse it. If it is already pointing
inwards, then continue to the next step.

5 Click Accept to select the second surface for filleting.
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The fillet surface is created, and the upper and cylinder surfaces are
trimmed to create the power button.

6 Choose Pick > Nothing to deselect all the surfaces.
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Creating the power button hole

Next, you will use the Surface Fillet tool to trim and round the edge of the

power button recess.

1 On the Layer Bar, click and hold on the power_button layer to see the
pull-down menu. Choose Visible to make the power_button surfaces

invisible.

[power_buron ]|,
Setstate & b
Visible v
Symmetry
Assign

2 Make the body layer visible by choosing Visible from the pull-down

menu.

Assign

. body A power butc
Setstate R B
Visible |
Symmetry
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3 Make the body active by clicking the layer tab to make it yellow. This
means all new surfaces will be assigned to this layer.

o O . coves [ [Epee—0) eover, buten A

4 Choose Surfaces > Surface fillet. The settings you used before are used for
this fillet surface, and so you don’t need to open the option box.

You are prompted to select the first set of surfaces. Click the upper surface
to select it.

The surface is selected and highlighted in pink, an Accept box appears
in the bottom right corner of the view, and a pale blue arrow is displayed.
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This arrow needs to point in towards the inside of the vacuum surfaces.
If it is pointing out from the surfaces, then click the arrow to reverse it.
If it is already pointing inwards, then continue to the next step.

5 Click Accept to select the first surface for filleting.

6 You are prompted to select the second set of surfaces. Click the cylinder
surface to select it.

The surface is selected and highlighted in yellow, an Accept box appears
in the bottom right corner of the view, and a pale blue arrow is displayed.

For the recess, the fillet needs to be created on the other side of the
cylinder.
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The blue arrow needs to point outwards from the handle surface. If it is
pointing in towards the surface, then click the arrow to reverse it. If it is
already pointing outwards, then continue to the next step.

7 Click Accept to select the second surface for filleting.

The fillet surface is created, and the upper and cylinder surfaces are
trimmed to create a recess for the power button.

NOTE Because you changed the direction of the blue arrow for this second
fillet, the result is different from the filleting of the power button.

8 Choose Pick > Nothing to deselect the fillet surface.
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9 Make the power_button layer visible by choosing Visible from the
pull-down menu.

You have now completed the main vacuum cleaner body surfaces.

Save your work

1 Choose File > Save as to save the current scene.
2 Save your work in the wire directory of the Lessons project.

3 Name your file myvacuumé.wire.

Part 7: Dust Bag and Cable Connector

In this section, you will create the dust bag and cable connector surfaces at
the rear of the vacuum cleaner.

Opening the tutorial file (optional)

If you successfully completed Part 6, you can proceed directly to the next step,
Extracting the body shape.
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If you were not successful in part 6, open the file called vacuum part7.wire,
located in the wire directory of the courseware project. This file contains the
completed model from Part 6.

Part 7 of the tutorial.

Extracting the body shape

At the back end of the vacuum cleaner there are two additional components,
a dust bag and a cable connector, shown on the sketch below.
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You will create these components as scaled copies of the rear surfaces of the
main vacuum cleaner body. By using the same shape, you will create a rhythm
of similar shapes, which gives the design its character.

You will start by creating copies of the body surfaces and placing them onto
a new layer.

1 Choose Layouts > Left to maximize the Left window.

2 Choose Layers > New to create a layer.

B | bodhy [ _power_button [ —Ell

3 In the Layer Bar, rename the new layer dustbag.

B | body O] | power_button [

Now, you will make a copy of the surfaces and assign them to the dustbag
layer.

4 Choose Pick > Object and drag a pick box around the end surfaces of the
vacuum body. Make sure you don’t select the handle or handle fillet
surfaces.
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5 Choose Edit > Copy followed by Edit > Paste. A copy of the surfaces is
made, placed on top of the originals, and highlighted.

6 Inthe Layer Bar, click and hold on the dustbag layer to see the pull-down
menu. Choose Assign to assign the copied surfaces to the dustbag layer.
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| body [0 _power_button [ [T ommea 1k

Set state % b

Visible v
Symmetry
Assign

Fick Obiects

7 Choose Pick > Nothing to deselect the surfaces.

8 On the Layer Bar, click and hold on the body layer and choose Set state
> Inactive to make the body surfaces inactive.

Set state %, b
Visible
Symmtry

The layer tab is displayed in pale blue to indicate that it is inactive.

@ _power_button ]

9 Do the same for the power_button layer to make the power button
surfaces inactive.

Now, only the copied surfaces on the dustbag layer are displayed and
pickable.
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Trimming the dust bag surfaces
Only the ends of the body surfaces are required for the dust bag and cable
connector.

Next, you will trim the surfaces so only the rear part of the shape is left. This
will make the surfaces easier to work with and easier to visualize.

You will trim the surfaces by using a curve to define the cutting line.

1 Choose Curves > New curves > New Curve by CVs.

You are prompted to enter the new edit point position. Hold down the
Alt key and click near the grid intersection shown below to position the
first edit point of the curve.
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Place the second edit point by clicking and holding the left mouse button.
Keep the mouse button held down and move the edit point until the
curve is roughly at the same angle as the back of the vacuum.

Make sure your curve is long enough to extend beyond the body surfaces.

2 Choose Pick > Nothing to deselect the curve.
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The Trim tool can be used to create a curve-on-surface directly from a
projected curve before trimming the surface. You will now use the curve
you have just drawn to cut away the front end of the surfaces.

3 Choose Surface Edit > Trim > Trim surfaceand double-click the icon to
open the option box. Click the 3D Trimming check box to turn on the
projection option in the trim tool.

=% Trim Control =10
30 Trimming ,7
Projection History J
Project Mormal J

Chain Select J

F Display Options
Show Intersections ,7

Region Selector USize  1.0000 | [

V¥Sze 1.0000 | [

4 You are prompted to select the surfaces to trim. Click and drag a pick box
around all the surfaces.
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The surfaces are selected and highlighted in pink.

o] o

You are then prompted to select one of the following:

Shift select to select additional surfaces or Select curves to
PROJECT or click to select REGIONS.

This time, you will use the Trim tool to project the curve onto the surfaces,
and so you will respond to the second prompt.

5 Click the curve you just created to select it as a curve to project.
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Discard

6 To see the effect of the projection, press the F8 hotkey to switch to the
perspective view.

You can see that a curve-on-surface has been created across the surfaces
and is shown in bright blue.

Still in the trim tool, you are now prompted with the three options. This
time you want to select a REGION of each surface to keep.

7 Zoom and tumble the view to get a close-up view of the rear of the
vacuum.
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8 Click in the rear part of the upper surface to select it as the part to keep.

An indicator appears on the surface to show it is selected for trimming.

9 Click the rear part of the fillet. Avoid clicking any of the lines on the fillet
surface, as these will be mistaken for projection lines.

TIP Zoom in to make it easier to select a part of the fillet surface with no
lines.

Part 7: Dust Bag and Cable Connector | 377



An indicator appears on the surface to show that it is selected for
trimming.

10 Click the rear part of the lower surface.

An indicator appears on the surface to show that it is selected for
trimming.

11 Click Keep in the bottom right corner of the view to keep the ends of the
surfaces.
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The surfaces are trimmed.

12 Choose Pick > Object and select the curve.

13 Choose Delete > Delete active, or press the Delete key on the keyboard to
delete the curve.

You have trimmed out a part of the vacuum design that can now be used
to create the dust bag and cable connector.
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NOTE The original body surfaces are unchanged, and are shown on the
invisible (pale blue) layer.

Scaling the dust bag and connector

Next, you will group the surfaces together so that they can be scaled and
positioned to complete the design of the dustbag.

1 Choose Layouts > Left to switch to the Left view.

2 Choose Pick > Object and drag a pick box around all the surfaces.
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3 Choose Edit > Group. The surfaces are now grouped with a single pivot
point, placed at the origin.

Next, you will move the pivot point to the end of the surfaces using curve
snapping. The pivot point will be used to control the scaling of the
surfaces.

4 With the group still selected, choose Transform > Local > Set pivot. Hold
down the Ctr/ and Alt keys to turn on curve snapping. Point the cursor
exactly on the top edge of the upper surface. (You may need to zoom in
to view the area in more detail.)

Click and hold the left mouse button and drag it to the pale blue cross at
the right end of the surface to position the pivot point.
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The pivot point jumps to the end of the surface edge.

5 Choose Transform > Scale and type in a value of 0.85 to shrink the
surfaces. A dialog box appears asking whether you want to delete the
construction history for the surfaces. Click YES.

The surfaces are scaled smaller to form the dustbag.

6 Choose Transform > Move. You are prompted to enter the move amounts.

= |Enter MCYE amounts (v, 23 (ARS): I

The prompt line displays (ABS) to indicate absolute mode. In absolute
mode, coordinates that are typed in will be measured from the origin.

382 | Chapter 6 Modeling aVacuum Cleaner



As the dustbag only needs to be moved slightly from its current position,
you will switch to relative dimensioning, so the coordinate values will
move the surfaces relative to their current position.

7 Typer and press Enter.

= |Enter MOVE amounts (v, 23 (RELY: I

8 Type 1.25,0,-0.5 and press Enter to move the dust bag 1.25 cm in x and
-0.5 cm in z.

NOTE The x,y,z values can be typed in with either a space or a comma
separating the numbers.

The dustbag is now in position.

Creating the cable connector

The cable connector component is created in the same way.

1 With the dustbag still selected, choose Edit > Copy followed by Edit >
Paste.
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A copy of the dustbag is created and is selected, ready to transform.

2 Choose Transform > Scale. Type in 0.6 to reduce the size of the group of
surfaces.

3 Choose Transform > Move. Type in , and press Enter to move the cable
connector 1.25 cm in x and -0.5 cm in z.
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4

5

NOTE You can move the surfaces freely using the mouse buttons if you want
to adjust the design.

Choose Pick > Nothing to deselect the surfaces.

On the Layer Bar, click and hold on the body layer to see the pull-down
menu. Choose Set state > Pickable to view the main body. Do the same
for the power_button layer.
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6 Use Diagnostic Shading to view the completed dustbag design.

For a concept design, it is typical for changes to be made regularly to the
model. During this phase, it is acceptable to leave the dust bag and
connector surfaces overlapping with the main body shape. This allows
you to quickly experiment with scaling and moving the components to
explore the design.

When the design is resolved, you would trim away the parts of the surfaces
that are intersecting the body, to create a continuous outer surface. This
is covered in Part 8, an optional extra stage in this tutorial.
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Save your work

1 Choose File > Save as to save the current scene.
2 Save your work in the wire directory of the Lessons project.

3 Name your file myvacuum7.wire.

Part 8: Completing the Model

In this section, you will complete the model by mirroring the surfaces. You
also have the option of creating the power cable to finish off the presentation
of the design.

Opening the tutorial file (optional)

If you successfully completed Part 7, you can proceed directly to the next step,
Mirroring the surfaces.

If you were not successful in part 7, open the file called vacuum part8.wire,
located in the wire directory of the courseware project. This file contains the
completed model from Part 7.
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Part 8 of the tutorial.

Mirroring the surfaces

Finally, you will mirror all the surfaces to create the final design.

1 Choose Layouts > Left or the F8 hotkey to switch to the perspective view.

2 Choose Pick > Object and drag a pick box around all of the surfaces to
select them.
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3 Choose Edit > Duplicate > Mirror r to open the mirror tool option box.

= Mirror Options

N Duplicate mirror

Mirror Type
* Duplicate “.~ Reshape

Mirrar Across

ey YT L

Reset ‘ Save ‘ Exit |

The vacuum cleaner surfaces are mirrored, and the whole design can now
be viewed.

5 Choose Pick > Nothing to deselect the mirrored surfaces.
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6 Use Diagnostic Shading to view the completed model.

Optional: Create the power cable

If you have time, you can create the power cable using an extruded surface,
as you did in the joystick tutorial. The curves are supplied as templates on the
curves layer of the tutorial file.
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Optional: Trimming the dust bag and connector

If you are feeling confident using the intersecting and trimming tools, you
may want to tidy up the rear of the vacuum cleaner by intersecting and
trimming the dust bag and cable connector.

Remember to intersect all dust bag surfaces with the body surfaces, and the
connector surfaces with the dust bag surfaces.

TIP Delete the mirrored surfaces, then do the intersecting and trimming. When
the trimming is complete, mirror the surfaces to create the completed model.
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Save your work

1 Choose File > Save as to save the current scene.
2 Save your work in the wire directory of the Lessons project.

3 Name your file myvacuum8.wire.

Conclusion

Congratulations! You have completed the vacuum cleaner model and have
used intersecting and trimming to create a detailed, complex model.

Important concepts to take forward to future modeling projects are:

B The technique of overbuilding surfaces, and then intersecting and trimming
them can be used to create detailed designs.

B For more complex models, use layers to organize the geometry and control
how the objects display on the screen.

B For a concept model, it is common to leave the surfaces overlapping as
the design goes through revisions and changes. The overlapping surfaces
will not be seen when the model is shaded and viewed.

B For a detailed, finished model, all the surfaces should be intersected and
trimmed, to create a single, enclosed outline. This can be used to create
rapid prototyping models and be exported to engineering CAD systems.

392 | Chapter 6 Modeling aVacuum Cleaner



Now that you have completed this vacuum modeling tutorial, do this quick
quiz to help you remember the tools and techniques you have learned.

1 Curve snapping helps you place or transform an object so that it snaps
to a curve or an edge. How do you turn curve snapping on?

(a) Hold down the Ctrl key

(b) Hold down the Alt key

(c) Hold down the Ctrl and Alt keys
(d) Hold down the Shift and Alt keys
(e) Hold down the Shift and Ctrl keys

2 Only one layer is active at any one time. How is the active layer displayed?

(a) The layer tab blinks

(b) All the geometry on the layer is shown in pale blue
(c) All the other layer tabs are hidden

(d) The layer tab is shown in yellow

(e) The layer tab is shown in red

3 When typing in X,y,z, dimensions, how do you switch from absolute to
relative mode?

(a) Choose Relative from the Control Panel

(b) Choose Relative from the Transform palette

(c) Type 1 after you have typed the dimension

(d) Type in r and enter, or just type an r before you type the dimension

(e) AliasStudio automatically knows that you need relative mode

4 What is the minimum number of Edit Points needed to create a curve
using the Curves > New curves > New Curves by Edit Points tool?

(a) one
(b) two

(c) three
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(d) four

(e) five

5 The Surface Edit > Trim > Trim surface tool can be used for which of the
following functions?

(a) To discard an area of a surface defined by a curve-on-surface
(b) To keep an area of a surface defined by a curve-on-surface

(c) To divide a surface into two areas defined by a curve-on-surface
(d) To project a line onto a surface to create a curve on surface

(e) All of the above

On Your Own

The modeling technique of overbuilding and trimming can be used to create
more detailed and intricate models. Use the following examples as inspiration
for practicing the skills you have just learned.

The 1970’s-style TV shown below is based on a simple sphere. The screen and
the controls are cut into the sphere using intersecting and trimming. The base
is a revolved surface. All the sharp edges have been finished with the Round
or Fillet tool.
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The car key model is typical of many electronic devices with function buttons.
You can use the same technique that you used with the vacuum cleaner power
button to create the key fob function key.
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The wheel shown below is created from one revolved surface and six skin
surfaces. Intersecting and trimming is used to cut the holes out of the revolved

surface.
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The barbecue fork is modeled in much the same way as the shapes would be
made in a workshop. Imagine the fork prongs as a sheet of steel, bent to give
the gentle curve along their length. The prong shape is then cut out. The
handle is made from two large mono-rail surfaces, intersected, trimmed and
then filleted.
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Quiz Answers

Answers to the Vacuum Cleaner Tutorial quiz
1 (c) Hold down the Ctrl and Alt keys.
2 (d) The layer tab is shown in yellow.

3 (d) type r before you enter the values, either on the same line, or press
Enter between the r and the values.

4 (b) Two

5 (e) All of the functions.
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Modeling an MP3 Player

Learning Objectives

In this lesson, you will build an accurate model of an MP3 player. You will learn how to:

Use Keypoint curves to create accurate geometric shapes.
Create surfaces with a draft angle.

Set up Construction Options for accurate modeling.

Create edges with a radius using the Fillet and Round tools.

Create symmetrical and duplicated geometry.
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New tools used in this tutorial

Object Edit > Offset

Edit > Duplicate > Object

Curves > Arcs

Curve Edit > Create > Fillet Curve
Surfaces > Draft/Flange

Surfaces > Round

Object Display > Template

Object Display > Invisible
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Introduction

Modeling to Dimensions

In the previous exercises you have focused on building complex forms, using
freeform shapes.

In this exercise, you will focus on geometric shapes and working to accurate
dimensions.

X,Y,Z Coordinates

To specify dimensions and locations in AliasStudio, you will refer to the X, Y,
Z grid directions.

An X, Y, Z location is called a coordinate.

To enter a coordinate, type the X, Y, and Z values into the prompt line. They
must always be in the X, Y, Z order, and the three numbers can be separated
by either a space or a comma: for example:

| B |Enter Move ameunts (x, v, 2) (4E5):10,20,5_
L —

Absolute and Relative Coordinates

Coordinates can be specified in two ways: absolute or relative.
Absolute coordinates are always measured from the origin.
Relative coordinates are measured from the last coordinate used.

In the prompt line, (ABS) or (REL) is shown, depending which mode you are
in. To switch modes, type the letter ‘t’ or the letter ‘a’ either on its own or
before typing the coordinate.
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El |Enter MOVE amounts (x, ¥, 2) (ABS): l

E |Enter MOVE amounts (x, ¥, 2) (REL): l

The Information Window

As well as entering coordinates in the prompt line, the Information Window
can be used to check or modify the dimensions of lines, curves and objects.

»> Information Window

B i **
Hame | line
Bounding Box | Invisle |
% pttributes
Length/Radiss AnglefSweep
lne  3.006 em | 0000

_ % Transform info

Translate | 00000 | 00000 |

Rotate | 00000 | 0.0000 |

scale| 10000 | tooon |

You will use the Information Window to specify the radius of arcs.

Keypoint Curves

In the previous tutorials, you created freeform curves using CVs and Edit

Points.

In this tutorial, you will use keypoint curves to create geometrically accurate

lines and arcs.
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Part |: Creating the Casing Curves

In this section, you will use Keypoint curves to create the outline of the MP3

player casing.

You will choose millimeters as the units for measurement and building, and
use X, Y, Z coordinates to accurately position the curves.

To save time, you will build only one quarter of the geometry, and use
symmetry to create the full model.

The dimensions of the casing are shown below:

40.0

5.25

TN
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Creating a New File

For this tutorial, you will create a file and work from the dimensioned drawing
to create your model.

Part 1 of the tutorial.

1 Choose File > New to open the File Browser.

If you already have a file open, you will be asked if it is OK to delete the
current file.

confirm

DELETE all objects,
shaders, wiews and actions
before starting a Mew session?

Yes ‘ o Cancel

Answer YES.

An empty file is created.
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Setting Up Modeling Units

When you are using dimensions to specify a model in AliasStudio, you first
need to select which units to use.

All the commonly used units are available:

ERRET R

For this tutorial, you will be working in millimeters, so first you will set the
modelling units to mm.

1 Choose Preferences > Construction Options. In the Units section, open
Linear and set the main units to mm. Close the window.
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> Construction Options

@
-
-

To help you visualize the scale of the new model, check the grid spacing.

2 Choose Construction > Grid preset and double-click the icon to open the
option window.

3 If the Grid Spacing is not set to 10 mm, change it to 10 mm in the Preset
Grid options window.

> Preset Grid Options

Grid preset

Grid Spacing 10,0000 T

TR —
=

B U N

4 Click Go to change the grid.

5 Maximize the Top window.
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6 Zoom into approximately 10 grid squares vertically; this will give you a
good view for the size of the MP3 player.

Creating the Casing Curves

First, you will create the side and top curves of the MP3 player casing.

1 Choose Curves > Keypoint curve toolbox, then Keypoint Curve Tools >
Lines > Line and use the Alt key to Grid Snap the start of the line to the
origin.

2 Grid Snap the end of the line to the grid point 4 grid squares up to create
a vertical line 40 mm long.
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3 With the curve still selected, choose Transform > Move and type in -25,0,0
at the prompt window to move the curve 25 mm to the left in the
x-direction.

TIP If the last coordinate numbers are zero, then you can omit them. For
example, 25,0,0 can be entered as 25 only. However, a coordinate of 0,0,25
needs to be entered in full.

Next, you will create the arc for the top of the MP3 player.
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The arc will define one half of the design, which will later be mirrored.
It is therefore important that the arc is tangent to the center line, so that
it will create a smooth result when it is mirrored.

So first, you will create a horizontal construction line to help create a
tangent arc.

4 Choose Curves > Keypoint curve toolbox, then Keypoint Curve Tools >
Lines > Line and use the Alt key to Grid Snap to the grid point at 0,40,0.

+

5 Using the middle mouse button, click to the right of the grid to create a
horizontal line.
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NOTE The length of the line isn't important; it just needs to be snapped to
the center grid line, and be horizontal.

Now you will create the arc at the top of the MP3 player.

6 Choose Curves > Keypoint curve toolbox, then Keypoint Curve Tools >
Arcs > Arc tangent to curve.

7 You are prompted to
Select the curve at location to make arc tangent to.

Click the horizontal line and, without releasing the mouse button, drag
the start point to the left end of the line, where it meets the grid.

NOTE The arc start point automatically snaps to the line, so you don't need
to use the curve snap (Ctrl and Alt).

+

8 You are prompted to

Enter end point of tangent arc.

Type -30,38,0 to position the end point.
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TIP The coordinate given for the end point gives you an arc similar to the
design shown at the start of this tutorial.

TIP If you want to modify the arc, and design your own shape, choose Curves
> Keypoint curve toolbox, then Keypoint Curve Tools > Drag keypoints and
click and drag the end of the arc until you achieve the desired curve. The
curve remains tangent to the center line.

9 You no longer need the horizontal line, so choose Pick > Object to select
it, and press the Delete key to delete it.
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Now you will use the Curve Fillet tool to create a smooth corner.
10 Choose Curve Edit > Create > Fillet curves.

11 You are prompted to choose a curve.

|SB|BEt primary fillsting CURYE. _ I

12 Pick the vertical line.

Then you are prompted to choose a second curve.

|Se|ect secondary Fileting CURYE. I
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13 Pick the arc.

14 When prompted to adjust the fillet radius, type in a value of 7.5.

|Radius = 10,0000, Adjust radius using mouse of keyboardi7.5_ p
1

15 Click Accept to create the fillet curve.

TIP Guidelines may be created when you use keypoint curves. They appear
as dotted lines which highlight when the cursor is near. They can be useful
when laying out a design, but you don’t need them for this tutorial.
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To delete the guidelines, choose Delete > Delete guidelines from the
menu.

Save your work

1 Choose File > Save as % to save the current scene.
2 Save your work in the wire directory of the Lessons project.

3 Name your file myMP3Player.wire.

For information on creating the Lessons project, or saving your work, see
Saving your work in a Windows environment on page 100.

Part 2: Creating the Side Surfaces

The design of the MP3 player features chamfered sides. You will now use the
Draft and Flange tools to create the side surfaces and a split-line feature.

The dimensions for the casing are shown below.
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Opening the tutorial file (optional)

If you successfully completed Part 1, proceed to the next step: Creating the
Side Surfaces, below.

If you were not successful in part 1, open the file called MP3Player part2.wire,
located in the wire directory of the courseware project. This file contains the
completed model from Part 1.

Part 2: Creating the Side Surfaces | 417



Part 2 of the tutorial.

Creating the Side Surfaces

First, you will move your curves away from the center line in the z-direction.
This will leave some space for a split-line feature you will create later in the
tutorial.

1 Maximize the Perspective Window.

2 Choose Pick > Object and drag a pick box over all the curves to select
them

3 Choose Transform > Move and type 10,0,0.25 in the prompt window to
move the curves up by 0.25 mm in the z-direction.

4 You will be asked about losing construction history, which relates to the
fillet curve. Answer Yes.
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confirm

An active item has construckion
history, Transforming the item
will cause history to be removed,
Do wou wish ko continue?

Wes Mo

Now you will create the side wall using the Draft surface.

5 Choose Surfaces > Draft surfaces > Draft/flange. Double-click the icon to
open the option window. You will start with the default Draft settings,
and then modify them after the surface is created.

>Draﬂ:{FIange Surface Options _IElliI
Simple |.ﬁ.dvanced

Construction Type Draft |

Angle  0.0000 | |

Surface Depth 100000 | |

6 As the curves are already selected, click Go to create the surface.

The default Draft surface is built. The default draft direction is in the
positive z-axis, which is correct for your design.
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TIP To change the draft pull direction for future designs, click the dotted
lines and arcs representing the axes.

Now you will modify the Draft Angle and the Surface Depth to match
the required dimensions.

7 In the Draft option window, change the settings to an Angle of -3 degrees,
and a Surface Depth of 2.

> Draft/Flange Surface Options =]

Simple | Advanced

Construction Type Draft |

fngle -3,0000 | |

Surface Depth  2.0000 | |

The Draft surface is rebuilt to the new settings.
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8 Choose Pick > Nothing to complete the surface creation.

9 Now you will build the chamfered surfaces.

10 Double-click the Draft icon to open the option window again. Change

11

the settings to an Angle of -45 degrees, and a Surface Depth of 5.

> Draft/Flange Surface Options =]

Simple | Advanced

Conskruction Type Draft |

fngle -45.0000 | |

Surface Depth 5.0000 H

NOTE You will build the chamfered surface to an approximate length. The
front face of the MP3 player will later be used to trim the side walls to the
correct height.

Pick the three top edges of the draft surfaces as the input curves for the
new draft surfaces.
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Click Go to create the chamfered surfaces.

12 Choose Pick > Nothing to complete the Draft surfaces.
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Creating the Split-Line

Next you will use the Flange surface to create the small split-line feature at
the center line.

The Flange surface can only be built from a surface edge, not a curve. This is
because it measures its angle from the surface edge, not from a draft direction.
So first, you will template your curves to make it easier to select the surface
edges.

1 Choose Pick > Component and modify the options so that only curves
will be selected.

2 TIP You can either double-click the Pick > Component icon to set up the
options in the option window, or you can use the small icons in the menu
bar, as shown below.

File Edit Delete Layouks

i B | |~ &2 | Bl
&

3 Drag a pick box across the model. Only the curves are selected.

4 Choose ObjectDisplay > Template to turn the curves into a template that
will not be selected by the Pick > Object tool.

Now you will create some small Flange surfaces to represent the split-line
detail.
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5 Choose Surfaces > Draft surfaces > Draft/flange. Double-click the icon to
open the option window. Change the Construction Type from Draft to
Flange.

> Draft/Flange Surface Options 10| x|
Simple |Advanced

Construction Tyvpe Flange |

Angle 00000 ||

Surface Depth| 10,0000 | ||

6 Change the Surface Depth to 0.5, and change the Angle to 3.

NOTE The angle of 3 degrees compensates for the draft angle of 3 degrees
on the sidewalls. So the flange surfaces will be built parallel to the ground
plane.

> Draft/Flange Surface Options | IElliI
Simple |Advanced

Construction Type Flange |

angle| 20000 ||

Surface Depth| 0.5000 | |

7 Click the lower edges of the side walls and click Go.

The small flange surfaces are created.
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10

11

Choose Pick > Nothing to complete the Flange surface.

To finish off the sidewalls, you will now create another set of flange
surfaces to meet the center-line.

Choose Surfaces > Draft surfaces > Draft/flange again, double-click the
icon to open the option window.

Change the Angle to 0 and the Surface Depth to 0.25.

=3 praft/Flange Surface Options i =]

Simple | fdvanced

Construckion Type Flange |

angle| 0.0000 ||

Surface Depth| 0.2500 ||

Choose the three edges of the flange surface you just created and click
Go.

Part 2: Creating the Side Surfaces | 425



12 Choose Pick > Nothing to complete the Flange surface.

13

The side profile of the surfaces shows how the draft angles and split-line
detail have been accurately created.
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TIP The Draft and Flange tools may create some extra curves-on-surface. Use
Pick > Object types > Curve on surface and drag a box over all the surfaces
to select them. You can delete these, as they aren’t needed.

Saving your work

1 Choose File > Save as % to save the current scene.
2 Save your work in the wire directory of the Lessons project.

3 Name your file myMP3Player2.wire.

For information on creating the Lessons project, or saving your work, see
Saving your work in a Windows environment on page 100.

Part 3: Completing the Casing

To complete the design, you will use a Plane surface to create the front of the
casing, and a Surface Fillet to trim and fillet it to the chamfered surfaces.

You will use Layer Symmetry and Mirror to create all the surfaces for the front
casing.
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Finally, you will duplicate the front casing to create the rear casing, and
organize all the geometry onto layers.

Opening the tutorial file (optional)

If you successfully completed Part 2, proceed to the next step: Creating the
Front Surface, below.

If you were not successful in part 2, open the file called MP3Player Part3.wire,
located in the wire directory of the courseware project. This file contains the
completed model from Part 2.

Part 3 of the tutorial.

Creating the Front Surface

First you will create the front face of the casing, and position it at the correct
height for the MP3 Player dimensions.

1 Maximize the Top window.
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2 Choose Surfaces > Primitives > Plane. You are prompted to enter the new
plane position. Use the Alt key and grid snap the plane to the origin.

The Plane surface is created 1mm square in size. It is already selected, so
you will now scale and move the plane to form the front face of the
casing.
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3 Choose Transform > Scale and click and drag the left mouse button to
make the plane large enough to see clearly.

Now you will set the pivot point for the Plane to the lower right-hand
corner.

4 Choose Transform > Local > Set pivot. Use the curve snap (Ctr/ + Alt) to
snap the pivot accurately to the bottom right corner of the plane.
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5 Now choose Transform > Move. Use grid snap (Alt key) to position the
plane exactly at the origin.

6 Use Transform > Non-p scale to size the plane to approximately fit the
design. Make sure that the plane overlaps the chamfered edges.

Next, you will move the plane up in the z-axis.
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7 Maximize the Left window

8 Choose Transform > Move and type 0,0,5.5 in the prompt window to
move the plane up 5.5 mm in the z-axis.

Filleting the Plane Surface

Now you will use the Surface Fillet tool to trim the front face and create an
edge with a radius in one operation.

1 Maximize the Perspective window.
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2 Choose Surfaces > Surface fillet and double-click the icon to open the
option window.

3 Change the Radius to 2.

Simple I.ﬂ\dvanced .

Construckion Type COMSTAMT |
Section Type CIRCULAR |
Surface Type MULTIPLE SURFACES |

Radius 2.0000 U

Recalc, Undo Al Mext

4 You are prompted to select the first set of surfaces. Select the plane.

5 Adjust the blue arrow (by clicking it) so that it points down, into the
surfaces.
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6 Click Accept.

7 Nextyou are prompted to select the second set of surfaces. Click the three
chamfered surfaces.

8 Adjust the blue arrow if necessary so that it points inwards to the
geometry.

9 Click Accept.

The edge with the specified radius is created and all the surfaces are
trimmed.
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10 Choose Pick > Nothing to complete the fillet.

Using Round for the Remaining Edges

Next you will create a radius on the remaining edges using the Round tool.

You could use either the Round or the Surface Fillet to create the softened
edge. As the surfaces already meet at a sharp edge, the Round tool will be
quicker to use.

1 Choose Surfaces > Round. You are prompted to select a pair of edges.
Click one of the edges between the chamfer and the side surfaces.
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\L—I |

A radius indicator appears and is highlighted in white.

2 Typein 2 at the prompt line to adjust the radius value to 2 mm.

Enter radius:
2

Enter radius:
Profile t=0.4275859 radius=2,000000

Py
EI Select a pair of edges or modify a profile.

3 Click the other edges to complete the round.
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4 Click Build to create the round surfaces and trim back the draft surfaces.

5 Choose Pick > Nothing to complete the round.
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Completing the Front Casing

The MP3 Player casing is made from two similar components, the front and
the back casing. You will complete the front and rear casings using the mirror
tool and Layer symmetry.

First you will create the lower quarter of the front casing.

1 Choose Pick > Object and drag a selection box over all the surfaces to
select them.

2 Choose Edit > Duplicate > Mirror 1 to open the mirror option window.

>> Mirror Options

Duplicate mirror

3 Choose the XZ plane and click Go.
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4 Choose Pick > Nothing to deselect the surfaces.

Layer Symmetry

You used mirror to create the lower surfaces, so that the top surfaces can be
modified, by adding a screen, and the lower surfaces can be modified by adding
buttons.

For the left and right sides of the design however, you want the geometry to
be the same on both sides. So for the left and right sides, you will use Layer
Symmetry to view a mirror image of the geometry, which will update as you
continue to build surfaces.

1 Choose Layers > New to create a layer for the front casing.

Defauliaver [ 11 [J[

2 Double-click in the layer tab and rename the layer Front Casing.

J DefaultLaver I —E‘E'

3 Choose Pick > Object and drag a pick box over all the surfaces to select
them.

4 Choose Assign from the Front Casing layer tab sub-menu.
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Defaultlayer (] |[—Front Casing I |

Set state B

The symmetry on layers is typically used in one of the three axis
directions. Now you will set the Symmetry Plane so that your geometry
is mirrored left to right.

The new layer is selected and shown in yellow. (If the layer isn’t selected,
you need to click the layer tab to select it).
5 Choose Layers > Symmetry > Set plane.

The current symmetry plane is highlighted in yellow. You need to change
this so that the geometry will be mirrored left and right.

wymmetry plane

Sek Plane || Set as Defaulk

6 Click the small brown square that represents the YZ plane.
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!
__}Syrmme.try plane

The large yellow plane changes to the right axis for your model.

Set Plane || Set as Defaulk

7 Click Set as Default to set this axis for all future layers.

Set Plane || Set as Default

8 Click Set Plane to set the plane for this layer.

Set Plane || Set as Default

On the Front Casing layer, choose the symmetry option from the layer
sub-menu.
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Defaultlayer (] |[—Front Casing I |

Set state B

The geometry on the layer is mirrored and shown as dotted lines to
indicate that it is only a visualization of the mirrored geometry, not real
geometry.

Creating the Rear Casing

Now is a good time to copy the surfaces for the rear casing, before you start
to detail the front.

First you will create a layer for the rear.

1 Choose Layers > New and rename the layer Rear Casing.

efaultl ayer D Front Casing l —El[

2 Choose Pick > Object and drag a pick box over all the geometry to select
it.
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3 Choose Edit > Duplicate > Mirror r to open the option window.
Choose the XY plane and click Go.

> Mirror Options

Duplicate mirror

The surfaces are mirrored.
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4 With the surfaces still selected, Assign them to the Rear Casing layer.
tLayer l Front Casing | [Rearcasma 1L

5 Turn on Symmetry on the Rear Casing layer.

6 Turn off Visible on the Rear Casing layer to make it invisible.

Saving your work

Save your work in the wire directory of the Lessons project. Name your file
myMP3Player3.wire.

Part 4: Creating the Screen Recess

The screen is cut out of the front face of the MP3 player.

You will Offset the outline of the casing to create the screen curves. You will
then Project them onto the front face to create Curves-on-Surface. These can
then be used to Trim out the aperture for the display screen.
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Opening the tutorial file (optional)

If you successfully completed Part 3, proceed to the next step: Creating Offset
Curves below.
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If you were not successful in part 3, open the file called MP3Player part4.wire,
located in the wire directory of the courseware project. This file contains the
completed model from Part 3.

Part 4 of the tutorial.

Creating Offset Curves

To keep the structured style of the design, the shape of the screen will echo
the curve at the top of the MP3 player.

Start by duplicating the edge of the top surface to create a reference curve.

1 Maximize the Top window.

2 Turn off the Symmetry on the Front Casing layer, and zoom into the top
half of the casing.

3 Choose Curve Edit > Create > Duplicate curve and select the lower edge
of the fillet surface at the top of the casing.

4 You will get a choice of picking the edge of the fillet surface or the edge
of the plane.

Select the edge of the fillet. This will give you a good quality curve.
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A curve is created that is a duplicate of the surface edge.

5 With the Curve Edit > Create > Duplicate curve tool already active, select
the fillet surface at the left side.

6 Again, choose the fillet edge, not the edge of the plane.
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7 With the curves still highlighted, choose Object edit > Offset and type
in -3 to create the top and side curves for the screen.
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8 Click Accept to create the offset curve.

Now you will duplicate and mirror the top curve to create the lower curve.

This time you will use a different technique for mirroring. The Edit >
Duplicate > Mirror tool always mirrors across a grid axis. You will use the
Edit > Duplicate > Object tool to mirror across an object’s pivot point.

So first, set the pivot for the curve.

9 Choose Pick > Object and select the upper curve.
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10 Choose Transform > Local > Set pivot and use the Ctrl key to snap the
pivot point to the end of the curve.

11 Choose Edit > Duplicate > Object q to open the option window.
Change the Scaling in the y-direction to -1.
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>> Duplicate Object Options

Duplicate object

IR | —

0.0000 0.0000 0.0000

0.0000 0.0000 0.0000

1.0000 -1.0000 1.0000

= e

TIP The Duplicate Object tool is used to duplicate and transform objects in
one operation. It is useful for creating patterns of many duplicates, and you
will use it later in the tutorial to create the pattern of control buttons.

Click Go to create a duplicated curve, scaled in the Y-direction to create
a mirrored copy.

12 Choose Transform > Move and type in 0, -28 to move the curve
downward.
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13 Choose Curve Edit > Create > Fillet curves and follow the prompts to
create fillets between the curves.
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Projecting the Screen Curves
Next, you will Project the curves onto the front surface to cut out the screen
shape.

The direction of projection is determined by the active window: the curves
will be projected perpendicular to the active window.

By continuing to work in the Top window, you will be setting the direction
of projection correctly.

1 Choose Surface Edit > Create CurvesOnSurface > Project.

2 You are prompted to select a surface. Pick the plane surface, and click
Go.
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3 You are then prompted to select the curves to project. Drag a pick box
over the screen outline curves you created.

4 Click Go to project the curves.
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5 Maximize the Perspective window.

You will now template the curves, so that you can see the
curves-on-surface more easily.

6 Choose Pick > Component and choose the curves-only option.

7 Drag a pick box over all the curves to select them.
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8 Choose ObjectDisplay > Template to template the curves.
Now you can see the curves-on-surface created by projecting.
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Next, you will trim the front face of the casing to create the opening for
the screen.

9 Choose Surface Edit > Trim > Trim surface. You are prompted to select a
surface to trim.

Pick the plane surface.

10 You are then prompted to select a region.
Click the plane surface, outside the screen area.
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11 Click Keep to trim the surface.

Creating the Screen Surfaces

Now you will create a chamfered edge for the screen, and a screen surface.

1 Choose Surfaces > Draft surfaces > Draft/flange. Double-click the icon to
open the option window.
Reset the Construction Type to Draft.

Set the Angle to 45 degrees and the Surface Depth to 1.5.
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5% Draft/Flange Surface Options I ] 4
Simple |Advance§

Construction Type Draft

angle| 450000 | |

Surface Depth| 1.50m0 ||

2 Select the edges of the screen to create the draft surface from.

3 Click Go to create the draft surface.
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If the surfaces are built in the wrong direction, click the blue dotted line
to switch the pull direction of the Draft surface.

To finish off the screen, create a planar surface for the face of the screen.

4 Choose Curves > Keypoint curve toolbox, then Keypoint Curve Tools >
Lines > Lineand use the curve snap (Ctr/ and Alt) to create a curve for the
center-line of the screen face.
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5 Choose Surfaces > Planar surfaces > Set planar and select all the lower
edges of the screen chamfer.
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6 Click Go to create the planar surface.

7 Assign all the surfaces to the Front Casing layer.

You now have lots of curves, so it’s a good idea to organize them onto a
separate layer.

8 Choose Layers > New to create a layer.

FrontCasing [ . Rearfesa B 0w O l

9 Change the layer name to Curves.

Cront Casing | .. Bear Casing _ -@ [ I
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11

12
13

Use Pick > Template to select the templated curves, and Assign them to
the new Curves layer.

Use Pick > Component to pick any remaining curves and Assign them
to the Curves layer.

Make the Curves layer invisible.

Turn Symmetry on for Front Casing layer, and use the diagnostic shading
to evaluate the design.

Saving your work

Save your work in the wire directory of the Lessons project. Name your file
myMP3Playerd.wire.

Part 5: Center Navigation Key

For most symmetrical designs, it is helpful to build the geometry centrally,
around the origin. This will let you use the mirroring tools to duplicate
geometry.

So, you will build the Navigation Key (and the control buttons in the next
section) at the origin, and later move them into the correct location on the
front casing.

A cross-section of the Navigation Key is shown below. Only the part of the
key that will be seen above the casing will be built.
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The dimensions for the Navigation Key profile are shown below. This will be
revolved to create the button surfaces.

|
=20
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Opening the tutorial file (optional)

If you successfully completed Part 4, proceed to the next step: Navigation Key
Curves below.

If you were not successful in part 4, open the file called MP3Player part5.wire,
located in the wire directory of the courseware project. This file contains the
completed model from Part 4.
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Part 5 of the tutorial.

Navigation Key Curves

You will create the cross-section profile of the Navigation key using Keypoint
curves, and then Revolve them to create the surfaces.

1 Turn off the visibility of the Front Casing layer.

2 Choose Layers > New to create a layer for the central navigation key.
Change the layer name to NaviKey.

sar Casing A |

Maximize the Left window.

First you will create a construction line to specify the tangency for the
center of the button.

TIP It can be useful to turn off the guidelines when you are using Keypoint
curves. To do this, choose Preferences > General Preferences r to open the
option window. In the Modeling section, choose zero for the Maximum
Number of Guidelines. This prevents any guidelines from being created.

> General Preferences

Interface ﬁ” General Prefesences
Inpat - |

Model Windows Maimurn rurrber of guidelines 0 I
Dram Modeling Layers mode
—

Paint

3 Choose Curves > Keypoint curve toolbox, then Keypoint Curve Tools >
Lines > Line and use Grid Snap (the Alt key) to place the start point at the
origin.
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Use the middle mouse button to place the second point of the line
horizontally to the left of the origin. The length of the line isn’t
important, as it will only be used to help create a tangent arc.

Now you will draw the line for the outer chamfered edge.

Choose Curves > Keypoint curve toolbox, then Keypoint Curve Tools >
Lines > Line again. When prompted to enter the start point of the line,
use Grid Snap (Alt key) to place the start of the line at the grid point at
10 mm in the X direction.

+

When prompted to place the end point of the line, type in R-2,0,1.

TIP The letter R is used to switch from ABSolute to RELative dimensioning.
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Now you will create an arc for the center of the button.

5 Choose Curves > Keypoint curve toolbox, then Keypoint Curve Tools >
Arcs > Arc tangent to curve. You are prompted to

Select curve at location to make arc tangent to.

Click the first line, and without releasing the mouse button drag the start
of the arc to the end of the line at the origin.

_‘,

+

You are prompted to enter the end point of the arc. Use the Point Snap
(Ctrl key) to place the end point of the arc on the top keypoint of the
angled line.

468 | Chapter 7 Modeling an MP3 Player



6 The horizontal line you created isn’t needed any more, so use Pick >
Object to select it and press the Delete key to remove it.

7 Choose Curve Edit > Create > Fillet curves and double-click to open the
option window.

Change the Radius to 1.87.

>> Curve Fillet Options

Fillet curves

Radius

I I B

Follow the prompts to create a 1.87-mm radius fillet between the curves.
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Revolving the Surfaces

Now you will revolve the profile curves to create the button surfaces.

1 Maximize the Perspective window.

2 Choose Pick > Object and select the profile curves.

3

4 Choose Surfaces > Revolve and double-click to open the option window.

Choose the Global option for the Axes. This will allow you to revolve
many curves at once, around the origin, not around each curve’s pivot
point.
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>* Revolve Dptions

Rewvalve surface

net | e | ex | e |

Click the Go button and the surfaces will be revolved.

5 Choose Pick > Object and the surfaces will automatically be selected.
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6 Choose Edit > Group to group the surfaces together to create the
navigation button.

Assign the grouped surfaces to the NaviKey layer, and make it inactive.

Assign the curves to the Curves layer.

Saving your work

Save your work in the wire directory of the Lessons project. Name your file
myMP3Player5.wire.

Part 6: Control Button

There are four Control Buttons, so you will start by creating only one, and
then later duplicate it to create the other three.

Each button is symmetrical, so to save time, you will only build one half of
one button, and use mirroring to create the other half.

The dimensions for the buttons are shown below.
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The button surfaces will be created using the Revolve, and Round tools.

Opening the tutorial file (optional)

If you successfully completed Part 5, proceed to the next step: Control Button
Revolved Surface below.
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If you were not successful in part 5, open the file called MP3Player part6.wire,
located in the wire directory of the courseware project. This file contains the
completed model from Part 5.

Part 6 of the tutorial.

Control Button Revolved Surface

First, you will create the outline circles for the button design.
1 Maximize the Top window

2 Choose Layers > New to create a layer. Change the name of the layer to
Control Buttons.

3 Choose Curves > Keypoint curve toolbox, then Keypoint Curve Tools >
Circular arc. You are prompted to enter the center of the circle.

Type in O to place the center of the circle at the origin.
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You are prompted to enter a point on the radius of the circle.

Type in 17.5 to create a circle with a radius of 17.5 mm.

4 Choose Curves > Keypoint curve toolbox, then Keypoint Curve Tools >
Circular arc. Y again and create a circle with the center at the origin and
a radius of 11 mm.
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Now you will use these circles to create an arc for the top surface of the
buttons.

Maximize the Left window and zoom into the right-hand side of the
circles. You will use the Keypoints on the two circles to locate the arc.

5 Choose Curves > Keypoint curve toolbox, then Keypoint Curve Tools >
Arcs > Arc (three point). You will be prompted to place the start point of
the arc. Use point snap (Ctrl key) and select the keypoint on the inner
circle.
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When prompted for the next point on the arc, select an approximate
location for the peak of the curve. This doesn’t need to be accurate, as
later you will set the radius of the arc accurately using the Information
window.

When prompted to place the end point of the arc, use the point snap
(Ctrl key) again and choose the keypoint on the large circle.

The arc is created at an approximate radius, but with an accurate start
and end point.

With the arc still selected, choose Windows > Information > Information
window.

Open the Attributes section, and change the Arc Length/Radius to 10.
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>* Information Window =0 =]

T arc#l0 e S
arc#10

[ o

i Attributes

Length/Radius

Arc 10,0000 1225841

The radius is changed, but the end points remain in the same locations.

Now you will move the arc up to raise the button surface above the casing.

7 With the arc still selected, choose Transform > Move and type in 0,0,0.75
to move the arc up 0.75mm in the z-direction.

8 Maximize the Top window. Leave the curve selected, as it will now be
used to create a revolved surface.
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9 Choose Surfaces > Revolve and double-click the icon to open the option
window.
Change the Sweep Angle to 45, and ensure that Axes is set to Global,
then click Go.

ol w5 I
Sweep Angle 45,0000 deg
Sections | g | J

Create Hicknee |7

TIP When revolving a smaller amount, you can reduce the number of sections
to reduce the isoparms in the revolved surface.
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The revolved surface is created.

Now you will temporarily hide the revolved surface and the arc, to make
it easier to work on the outline curves.

10 Choose Pick > Object and select the surface and the arc.

11 Choose ObjectDisplay > Invisible to temporarily hide the surface and the
curves.
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Creating the Control Button Draft Surfaces

Now you will trim the two circles to create the button outline.

1 Choose Curves > Keypoint curve toolbox, then Keypoint Curve Tools >
Break & Join > Break curve at keypoint.

Click the top keypoint of the outer curve.

Still in the Break at Keypoint tool, click the top keypoint of the inner
curve.
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The curve is split, and the top right-hand segments now have keypoints
at their centers.

You will now break the curves at these keypoints to create a 45 degree
segment.

Click the middle keypoint of each curve to break it into 45 degree
segments.
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2 Choose Pick > Object and select the parts of the circles you don’t need.

3 Press the Delete key to delete the curves.
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Trimming Curves

Next, you will trim the two arcs and the line to create the outline of a single
button.

1 Choose Curves > Keypoint curve toolbox, thenKeypoint Curve Tools >
Lines > Line and snap to the grid points (Alt key) to create a horizontal
line. You will create the line over-long so that it can be used for trimming.

2 Choose Transform > Move and type in 0,1 to move the line up by 1 mm
in the y-axis.
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3 Choose Curve Edit > Curve section.

You will be prompted to select a curve to trim. Click both arcs, above the
line and click the GO button

You will be prompted to select the trimming curves. Choose the line.
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The arcs are trimmed.

4 Choose Curve Edit > Curve section again and this time choose the line.
Make sure you select the curve in between the arcs, to keep that part of
the line.

When prompted to select the trimming curves, first choose the outer arc.
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Then choose the inner arc to complete the trimming.
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Creating the Draft Surfaces

1 Maximize the Perspective window.

2 Choose Pick > Object and select all the curves.

3 Choose Surfaces > Draft surfaces > Draft/flange and double-click to open
the option window.

Modify the settings to Draft Angle -2 degrees, and a Surface Depth of 2
mm
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> Draft/Flange Surface Options I ] 4

Simple | Advanced

Construction Type Draft |

angle| -2.0000 | |

Surface Depth| 2.0000 | |

TIP The pull direction may be set to -z from the last Draft operation. Click
the dotted blue line to make sure the pale blue arrow is pointing upwards in
a positive z direction.

NOTE Depending on your curves, you may need to change the Draft Angle
to +2 to get the side walls falling inwards with the draft.

4 Choose ObjectDisplay > Visible to make the revolved surface of the button
visible again.
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Intersecting and trimming the buttons

Now you will intersect and trim the button surfaces to create a trimmed model
and then use the Round tool to complete the button design.

1 Choose Pick > Object and pick the draft surfaces.

2 Choose Surface Edit > Create CurvesOnSurface > Intersect.

As the draft surfaces have already been selected, you will be prompted to
select the intersecting surfaces.

Click the revolved surface.
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The surfaces are intersected and curves-on-surface created.

3 Choose Surface Edit > Trim > Trim surface.
Follow the prompts to trim the revolved surface to keep the inner part.

Trim the draft surfaces to keep the lower parts.
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4 Choose Pick > Component to select all the curves and Assign them to
the Curves layer.

Rounding Multiple Edges

The surfaces built in the previous section need to be rebuilt for the Round
tool to work. Since the Rebuild tool is not available in all products, load the
file MP3Player_Part5_rebuild.wire from the CourseWare directory.

1 Choose Surfaces > Round and double-click the option box to open the
option window.

2 Change the Unequal Radius Corner to Single Surface to create a simple
rounded corner.
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> Round Control

F Defaul Corner Tvpes

R

Unequal Radius Corner SINGLE SURFACE |

e

3 Select one of the side edges, and type in 1 at the prompt line to set the
round radius to 1 mm.

1.0

4 Select the other side edge and leave the radius value at 1.
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5 Select one of the top edges and type in 0.35 in the prompt line to change
the round radius to 0.35mm.

6 Select the other three top edges.

7 Click the Build button to create the round.
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The advantage of using the round tool on multiple edges is that the blended
corner surfaces are built automatically.

Saving your work

Save your work in the wire directory of the Lessons project. Name your file
myMP3Player6.wire.

Part 7: Completing the Model

You will now complete the MP3 Player design by duplicating the control
buttons, and moving all the buttons into the correct position on the front
casing.

Opening the tutorial file (optional)

If you successfully completed Part 6, you can proceed directly to the next step:
Creating Four Buttons below.
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If you were not successful in part 6, open the file called MP3Player part7.wire,
located in the wire directory of the courseware project. This file contains the
completed model from Part 6.

Creating Four Buttons

Part 7 of the tutorial.

First, you will rotate the half-button into the correct orientation, and then
mirror the surfaces to create one full button.

1 Maximize the Top window.

2 Choose Pick > Object and select all the surfaces.
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3 Choose Edit > Group to group them all , with a single pivot point at the
origin.

4 Choose Transform > Rotate and type in 0,0,45.
You will be asked about losing construction history, answer Yes.

5 Choose Edit > Duplicate > Mitror r and select the YZ plane to Mirror
Across.
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>* Mirror Options

Duplicate mirror

6 Click Go to create the mirrored geometry.

7 Choose Pick > Object and select both halves of the button.

8 Choose Edit > Group to group them as a single button.
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You now have one complete button, in the desired orientation, so now
you will create three additional buttons.

Choose Edit > Duplicate > Object r

First, click the Reset button at the bottom of the option window. This
will restore all the default settings.

Then set the Number of duplicates to 3, and the Rotation to 90 degrees
in the z-axis.

>> Duplicate Object Options

Duplicate ohjeck

0.0000 0.0000 0.0000
0.0000 0.0000 90,0000
1.0000 1.0000 1.0000

Click Go to create the duplicates.

The four buttons are created.
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9 Make sure that all the buttons are on the Control Buttons layer, and set
the layer to inactive.

Positioning the Buttons

Now you will move the buttons into their correct location, centered on the
lower part of the Front Casing.

1 Maximize the Perspective window.
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2 Make the Front Casing layer visible.

3 Turn off the Symmetry on the layer.

4 Set the state of the Front Casing layer to Reference, so that it can be
snapped to, but not fully pickable.
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fautlayer [ FreneCasing (] fes cesna 0

5 Choose Curves > Keypoint curve toolbox, then Keypoint Curve Tools >
Lines > Line and use curve snap (Ctrl and Alt keys) to place the curve along
the edge of the casing.

/

You will now use the center keypoint on the new line to position the
buttons.
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6 Make the NaviKey and the Control Buttons layers Pickable.

N | [ Il ool Euttons ||
Set state oy P Pickabl v

Visible v

7 Choose Pick > Object and select all the buttons.

8 Choose Transform > Move. Use the point snap (Ctrl key) to position the
keys on the center Keypoint of the line.

You will be asked if you want to delete construction history: answer YES.
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9 To convert the Layer Symmetry geometry into real geometry, first set the
state of the layer back to Pickable.

Defaultlayer [ _ FrontCasng [l RearCasing [
—— -
Setstate B | L =

Visible v | Reference

10 Then, turn on the Symmetry for the layer.
Fronk Casing ID
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11 Select the layer and use choose Layers > Symmetry > Create geometry.

DefaultLayer l

The mirrored geometry is no longer shown in dotted lines, and can be
modified independently.

12 Do the same for the Rear Casing layer to complete the MP3 Player design.
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13 Use the Diagnostic Shading to evaluate the design.

Saving your work

Save your work in the wire directory of the Lessons project. Name your file
myMP3Player7.wire.
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Conclusion

Congratulations! You have created an accurate model of the MP3 Player.
You have learned to:

Use Keypoint curves to create accurate geometric shapes.

Create surfaces with a draft angle.

Set up Construction Options for accurate modeling.

Create edges with a radius using the Fillet and Round tools.

Create symmetrical and duplicated geometry.

Working accurately to dimensions will be an important part of most of your
design projects. Complete this quick quiz to reinforce the tools and techniques
you used.

1 How do you set up which modeling units (for example, mm or inches)
you will use for a model?

B (a) In the Preferences > General Preferences window.

B (b) In the Windows > Information > Information Window.
B (c) In the Preferences > Construction Options window.

B (d) Type in the units, i.e. ‘mm’ after you enter the value.
|

(e) In the Construction > Grid Preset option window.

2 When projecting a curve, what determines the direction the curve is
projected in?
B (a) You are prompted to type in the direction.

B (b) The active window: the curve will be projected perpendicular to
the window view.

B (c) There is an option in the Project option window.

B (d) Hold down the Shift key when selecting the curve.
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(e) It is determined by the mouse button you use to select the curve.

3 How do you modify the radius of an Arc or Circular Arc after you have
created it.?

(a) In the Attributes section of the Windows > Information >
Information Window.

(b) Use Object Edit > Query Edit and click the curve.
(c) You have to delete the curve and create a new one.
(d) Pick and scale the curve.

(e) Use Locators > Measure > Distance to apply a dimension, and then
change the number on the dimension.

4 Building geometry at the origin is a good idea because....

(a) Grouping objects will create a pivot point at the origin.

(b) The Edit > Duplicate > Mirror tools can be used to create
symmetrical geometry.

(c) The Layer symmetry tools can be used to work with symmetrical
geometry.

(d) You can use the center grid lines for snapping geometry to.

(e) All of the above.

5 The Round tool has what advantage over the Surface Fillet tool?

(a) It is more accurate

(b) You can chain select a row of edges
(c) It has Construction History

(d) It automatically trims the surfaces

(e) The Round tool can create a corner surface between three edges.

On Your Own

Now you can create accurately sized models, and use geometric shapes to
create a disciplined design. The Draft surface tool is particularly useful when
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designing plastic molded parts, but can equally be used to quickly create any
edge surface.

Below are some examples of similar projects that you can try.

This headset for a cell phone is constructed in a similar way to the MP3 player,
using arcs and Draft surfaces.

Most computer speakers make good subjects for practicing your modeling.
Take measurements and try to replicate the shape as accurately as you can.
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Have a look back at the Vacuum Cleaner tutorial to remind yourself how the
button was detailed. You can finish off your MP3 player model by recessing
and filleting the buttons and the button holes in a similar way.
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You can use Surfaces > Tubular offset to create grooves from projected
curves-on-surface. Use the Help > AliasStudio Help if you haven’t used this
tool before.

Quiz Answers

Answers to the MP3 Player Tutorial quiz
1 (¢) In the Preferences > Construction Options window

2 (b) The active window: the curve will be projected perpendicular to the
window view.

3 (a) In the Attributes section of the Information Window.

4 (e) All of them
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5 (e) The Round tool can create a corner surface between three edges.
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Modeling a Sports
Shower Gel Bottle

Learning Objectives

In this lesson, you will build a sports shower gel bottle. This lesson introduces you to surface
continuity. You will learn how to:

Create smooth transitions between surfaces
Model accurately for manufacture

Use Layer Symmetry

Change the degree of a curve

We will expect you to know how to do certain things, like opening and saving files, picking
objects, and moving around in the views, without being told which tool to use. If you cannot
remember, check the previous tutorials.

New tools used in this tutorial

Object Edit > Align > Align
Obiject Edit > Attach > Detach
Surfaces > Boundary surfaces > Square

Surfaces > Swept surfaces > Rail surface (Birail surface)

Surfaces > Multi-Surface blend > Freeform blend
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New Concepts

Continuity

In this exercise, you will learn how to create continuity between surfaces and
between curves.

The three main types of continuity used in AliasStudio are shown in the
illustrations of three curves below.

Positional Continuity The dashed curve touches the two solid curves, but
there is an angle between them and so there is a sharp break between the
curves.

Tangent Continuity The dashed curve has no angle difference where it meets
the solid curves. The Round surface tool and the Curve Fillet tool create this
type of continuity.

Curvature Continuity The dashed curve blends in even more smoothly to
the solid curves.

516 | Chapter 8 Modeling a Sports Shower Gel Bottle



NOTE Some curvature options aren’t available in the DesignStudio version of
AliasStudio.

There is one other use of continuity that you will use in this tutorial: Implied
Tangent.

Implied Tangent A curve or surface is created on the center line, and will be
mirrored. The Implied Tangent tools make sure that the two surfaces (original
and mirrored) will be tangent to each other.

Understanding these concepts and using the tools that control them enables
you to create smooth, organic designs in AliasStudio.

Construction Tolerances

Construction Tolerances are important as well, when matching surfaces.

Construction tolerances specify the accuracy of the Position, Tangent, and
Curvature continuity when surfaces are built. This is important if the model
is used for manufacture or is transferred to another CAD system.

For more detailed information, please read the explanation in Using AliasStudio
of continuity and in the Reference manual, Preferences > Construction Options.
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Part |: Creating Primary Surfaces

In this section, you will use the Square, Skin, and Align tools to create the
basic shape of the shower gel bottle.

You will build the front half of the bottle, which will later be mirrored to
complete the design. You will create a smooth connection between both halves
by controlling the implied tangent continuity across the center line.

When you create the shoulder surface, you will blend it smoothly to the main
bottle surface using tangent continuity.

g

Part 1 of the tutorial.

Opening the tutorial file

The tutorial file has curves for building the shower gel bottle.
1 Choose File > Open to open the File Browser.

2 In the File Browser, locate the courseware directory and set it as the
Current Project.

3 Open the file called showergel.wire, located in the wire directory in the
CourseWare project.

(For information on how to open a file, see Opening the tutorial file in
a Windows Environment on page 86)

confirm

DELETE all abjects,
shaders, views and actions
before Opening this File?

Yes ‘ Mo Cancel
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4 A dialog box appears, asking if you want to delete all objects, shaders,
views, and actions. Click Yes.

5 If your values for construction tolerances differ from those in the
showergel.wire file, you will be presented with a dialog.

confirm

The Construction Options of the retrieved file differ from the current session
Dia you wank bo keep the current Construction Options?

Option Type Current  Mew
| Linear Units - Main Units | em | mm
e

6 Click Accept New Settings to use the construction tolerances in
showergel.wire.

The file is opened.
The main bottle curves are visible and placed on a layer named Curves.

Other curves are on layers that are not currently visible; you will use these
later in the tutorial.

Setting the Construction Tolerances

Before you start to create your model, you will choose the construction
tolerances you want to work to.

1 Choose Preferences > Construction Options.
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> Construction Options 10| x|
name SetConstructionOptions
+/=

YA

% Construction Presets

Copy Delete

User Defined
CATIA Y4
CATIA NS
Pro/EMGIMEER
I-DEAS

Unigraphics
Solidwarks
General CAD Settings

-+ Lnits
+ Tolerances
+ Rational Flags

+ Fonts

The Construction Preset is set to User Defined. While this is suitable for
rapid concept development, a more accurate setting will be needed for
data transfer to a CAD or Rapid Prototyping system.

2 In the option window, choose General CAD Settings.
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> Construction Options 10| x|
name SetConstructionOptions
+/=

YA

% Construction Presets

Copy Delete

User Defined
CATIA Y4
CATIA NS
Pro/EMGIMEER
I-DEAS

Unigraphics
Solidwarks
General CAD Settings

-+ Lnits
+ Tolerances
+ Rational Flags

+ Fonts

To see what tolerances you will be working to, open the tolerances section
of the Construction Options window.

| General CAD Setkings

+ Linits

%+ Tolerances

¥ Fitting

4 Continuity

[aximum Gap Distance | 0.010000 Tim

Continuity Andle | 0,100000 deg

ContinuityCurvature| 0.100000 i_|

TIP For future projects, you can choose settings that match the CAD system
you will be exporting data to.

3 Close the Construction Options window.
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Creating the Main Bottle Surface

You will start by creating the main bottle shape using a Square surface.

1 Maximize the Perspective view.

2 Check that the Bottle layer tab is shown in yellow, indicating the new
surfaces you create will be assigned to it. If not, click the layer tab to make
it active.

o B

3 Choose Surfaces > Boundary surfaces > Square.

4 Double-click the icon to open the option window.
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RET

Simple |Advanced
Conkinity | Rebld |
1 FREE
2 FREE
3| | FREE [
4 | | FREE [
Recalc, Mezxt

In the Square option window, the four boundaries of the square are listed.

For boundaries, 2 and 4 change the continuity option to Fixed. This
ensures that the square surface accurately matches the curves.

1o %)

Simple |.¢\dvanced

Conkinuity | Rehld |
L | FREE [
2 FIXEL
3 FREE
4| | FIXED [

e
Recalc, Mext

For boundaries 1 and 3, change the Continuity option to Implied Tangent.
The Implied Tangent option ensures the surfaces will align smoothly
across the center line.
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Square Control

| simple |

You are prompted to select the four boundary curves. Click the curves in
the order shown.

When the fourth curve is selected the square surface is created.
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Creating the Neck Surface

1 Adjust the view to see the curves for the neck of the bottle.

2 Choose Surfaces > Skin and, when prompted, select the two neck curves
to create the neck surface.
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I

3 Now that you have built the main surfaces, turn off the Curves layer,
leaving only the surfaces visible on the screen.

Defaultlaver | ___ Curyes Jﬁl _ GripCurves_ _ jz

Creating the Shoulder Surface

The shoulder surface needs to blend smoothly from the main body surface.

First, you will create the shoulder as a simple skin surface from the body to
the neck. You will then create continuity between the shoulder and body,
using the Align tool.

It is useful to understand how the Align tool creates the desired continuity,
and you can see this by observing how the CVs and Hulls change as the Align
tool is applied.

Positional Continuity One row of CVs is aligned to the other surface. This
is the default continuity when you create the skin surface.
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Tangent Continuity Two rows of CVs are aligned to the other surface.

Curvature Continuity Three rows of CVs are aligned to the other surface.

|
Vs
f—

Creating the Shoulder Surface

First, create the shoulder surface with positional continuity.
1 Choose the Surfaces > Skin tool.

2 When prompted, select the edges of the body and neck surfaces to create
the shoulder skin surface.
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Aligning the Shoulder Surface

Now, you will use the Align tool to modify the shoulder surface, making it
Tangent to the body surface.

First, delete the Construction History of the shoulder skin, to allow it to be
modified.

1 With the shoulder surface still selected, choose Delete > Delete
construction history and answer Yes when prompted.

confirm

Delete construction history
for active objects 7

Wes Mo

2 With the surface still selected, turn on the CVs by clicking the CV and
Hull check boxes on the Control Panel. This makes it easier to see the
results of the Align tool.
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3 Choose Object Edit > Align > Align 2008. Double-click the Align icon to
open the option window.

= Align Control _[ol x|

Advanced

FIRST |
Conkinuity TAMGEMNT |

TModiFy

alicPartial Joins

'}
EI Lack Pas @it - Tioin -« General
i

Recalc. Reewverk ‘ Accept ‘

The Modify section is set to First; this means you need to select the
shoulder surface first, as this is the one you want to change.

The Continuity section is set to Tangent.
4 You are prompted to select the first object near the align location. This
is the skin surface you created for the shoulder.

Move the cursor to the junction of the bottle and shoulder surfaces. Click
the edge of the surface and select the skin surface from the pick chooser.
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5 You are prompted to select the second object near the align location.
Select the top edge of the body surface.

¥-_. o

The CVs of the shoulder surface are then modified to align the shoulder
to the bottle surface.
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Now, you will modify the character of the shoulder blend by moving and
scaling the CVs and Hulls.

6 Use the F9 hotkey to show the four modelling windows.

7 Choose Pick > Nothing to deselect the surface.
8 Choose Pick > Point types > Hull.

9 In the Back window, select the hull of the second row of CVs from the
top by clicking the red hull line.
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10 Choose Transform > Non-p scale and drag with the middle mouse button
to create a smooth shoulder shape.

11 NOTE The pivot point for the CVs defaults to the origin, so the CVs will scale
correctly.

12 In the Left window, drag with the middle mouse button to refine the
shoulder shape.
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13 With the right mouse button click the hull of the third row of CVs and
drag upwards to sharpen the shoulder profile.

Continue to adjust the vertical position of the hulls until you are happy
with the design.
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14 Choose Pick > Nothing to deselect the CVs.
15 Turn off the CVs and hulls, using the Control Panel.

16 Use Diagnostic Shading to evaluate the result.

TIP If you have the curvature option in the Align tool, you can use it to adjust
the third row of CVs and get an even smoother transition.

Saving your work

Now you will save the scene as a new file.
1 Save your work in the wire directory of the Lessons project.

2 Name your file nyshowergel.wire.

For information on creating the Lessons project, or saving your work, see
Saving your work in a Windows environment on page 100.

Part 2: Creating the Finger Grip

Having created the basic form of the bottle, you will now add the features
that give it a ‘sports’ character.

The finger grip area is created by removing part of the body surface, and
replacing it with a birail surface which follows the grip profile, and blends in
smoothly to the body.
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Part 2 of the tutorial.

Opening the tutorial file (optional)

If you successfully completed Part 1, proceed to the next step: Making Space
for the Grip Detail below.

If you were not successful in part 1, open the file called showergel part2.wire,
located in the wire directory of the courseware project. This file contains the
completed model from Part 1.

Making Space for the Grip Detail

To make space for the finger grip, you will split the body surface and discard
the part which will be replaced by the grip feature.

Because the isoparms on the surface are at a convenient location, you can use
the Detach tool to split the surface at an isoparm. You can snap to a particular
isoparm, using the Ctrl key.

Before detaching, delete the construction history of the surfaces.
1 Maximize the Perspective window.

2 Choose Pick > Object and select all the surfaces.
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3 Choose Delete > Delete construction history and answer YES when
prompted.

confirm

Delete construction history
for active objects ¥

es Mo

NOTE Detaching leaves a good quality edge on the surface. However, it is
not reversible, so we recommend you save before using Detach!

4 Choose the Object edit > Attach > Detach tool. Hold down the Ctrl key
and select the isoparm shown.
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TIP Move the mouse to check that the detach tool has locked on to the
isoparm.

The isoparm is highlighted and a Go button appears.

5 Click Go to detach the surface.

6 Choose Pick > Object and select the smaller piece of surface.
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7 Press the Delete key to delete the small surface.

A curve has been provided on the GripCurves layer to define the profile
of the finger grip.

8 Turn on the visibility of the GripCurves layer by selecting Visible from
its layer tab menu.
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Creating the Birail Surface

Now, you will create a Birail surface for the finger grip. The Birail will be
tangent to the edge of the body surface and tangent to the shoulder surface.
It will match the curve at the base with positional continuity, and have Implied
Tangency on the finger grip curve, where the surface will later be mirrored.

1 Choose Surfaces > Swept surfaces > Rail surface. Double-click the icon to
open the option box.
In the Generation Curve section, choose 2.

In the Rail Curve section, also choose 2.
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== Birail II Gen. Control

zeneration Curves

Rail Curves

2 Choose Position for each of the four Continuity options (you will change
these after the Birail surface is created).

If any of the Rebld boxes are checked, click in them to remove the check.

>> Birail II Gen. Control

PCSITION

POSITION I

POSITION

POSITION

TIP The Rebld option can improve the parameterization of an edge, typically
a trimmed edge. As all your edges and curves have good parameterization,
you don’t need to use it in this case.

3 You are prompted to select the edges of the birail. Select the curves in
the order shown:
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The birail surface is created.

With the surface still selected, and the option window still open on screen,
you can now adjust the continuity options at each edge.
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4 Change the following continuity settings:

gen2 Tangent
raill Tangent
rail2 Implied Tangent

>> Birail II Gen. Control

circles113 PCSITION
skin#z TANGEMT
square TANGEMNT

curve# 102 IMPLIED TAM

The surface is rebuilt with the new continuity settings.

542 | Chapter 8 Modeling a Sports Shower Gel Bottle



5 Choose Pick > Nothing to deselect the surface and use diagnostic shading
to evaluate the design.

TIP Use the Show menu on the window pane to turn off the model and the
grid. Remember to turn them on again when you remove the shading.

Creating the Base Surface

The base of the bottle will be created as a flat plane.
1 Choose Surfaces > Planar surfaces > Set planar.

2 You are prompted to drag/select curves. Drag a pick box over the two
base curves.
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3 Click Go to create the planar surface.

TIP The space bar can be used as a short cut instead of clicking Go.

4 Make sure that all the surfaces are assigned to the Bottle layer.

5 The curves are no longer needed, so turn off the visibility of the
GripCurves layer.

Save your work

1 Save your work in the wire directory of the Lessons project.

2 Name your file myshowergel2.wire.
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Part 3: Label Surface

In the Vacuum exercise, you intersected surfaces to create curves-on-surface
that could then be used for trimming.

In this exercise, you will Project a curve onto the surface, which will create
the curves-on-surface needed for trimming.

First, you will trim out the label shape from the main body surface.

Then, you will create a recessed surface for the label panel. This will be trimmed
slightly smaller so there is a space for a smooth blend surface to be built.

NOTE You cannot use Detach in this case to ‘cut’ the surface, as the desired shape
does not follow the isoparms of the surface.

Part 3 of the tutorial.

Opening the tutorial file (optional)

If you successfully completed Part 2, proceed to the next step: Trimming the
Label Area below.
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If you were not successful in part 2, open the file called showergel part3.wire,
located in the wire directory of the courseware project. This file contains the
completed model from Part 2.

Trimming the Label Area

First, you will project the label shape curve onto the bottle surface. The
projection direction will be determined by the active window, so you will use
the Left window.

1 Maximize the Left window.
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2 Make the LabelCurves layer visible.
__ fGripCurves_ _iZ] LabelCurves ID _ LogoCuryes _ JZ
I s

Set state By b

The layer has two curves for the outline of the label. The outer curve will
be used to trim away the main body surfaces.

Now, you will Project the outer label curve onto the body surface.
3 Choose Surface Edit > Create CurvesOnSurface > Project.

4 You are prompted to select a surface. Click the main bottle surface to
select it.
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5 Click Go to accept the surface.
You are then prompted to select the projecting curves.

6 Click the outer label curve to select it, and then click Go.

The curve is projected onto the surface.

7 Maximize the Perspective view to see the curves-on-surface more clearly.
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8 Choose Surface Edit > Trim > Trim surface.

9 You are prompted to select the surfaces to trim. Click the main bottle
surface to select it.

Discard

10 You are then prompted to select REGIONS. Click the part of the surface
you want to keep (the part outside the label area).
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11 Click Keep shown in the bottom right corner of the window.

The surface is trimmed.

12 Use Diagnostic Shading to verify the surface has been trimmed correctly.
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TIP If the trimming is not correct, click Revert at the bottom of the screen
to go back one step and re-select the trim regions. If you want to correct the
trim at a later stage, you can use Surface Edit > Trim > Untrim to restore the
surface to its untrimmed state.

Creating the Label Surface

If the bottle is to have a paper label, paper can only bend in one direction at
a time if it is to have no folds or wrinkles. Therefore the label surface should
only bend in one direction. This is called single-curvature.

You will create a single-curvature surface by using a Skin surface between two
identical curves.

First, organize your model using the layers.

1 Make the Bottle layer invisible using the layer sub-menu.

A capcures {4
T

There are two identically shaped curves for the skin surface; these will be
used to create the label.
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2 Choose Surfaces > Skin. Follow the prompts and select the two label
surface curves to create a skin surface.

Next, you will project the label outline curve onto the surface.

3 Maximize the Left window to set the correct direction of projection.

4 Choose Surface Edit > Create CurvesOnSurface > Project.
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As the surface is already selected, it is accepted for projection, and you
are prompted to select the projecting curves.

5 Click the inner label shape curve to select it, and then click Go.

The curve is projected onto the surface.

6 Maximize the Perspective view, to see the curves-on-surface more clearly.
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7 Choose Surface Edit > Trim > Trim surface.

8 You are prompted to select the surfaces to trim. Click the label surface
to select it.

Discard

9 You are then prompted to select REGIONS. Click the part of the surface
you want to keep (the part inside the label area). Then, click Keep shown
in the bottom right corner of the window.
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Discard

The surface is trimmed.

10 Make the Bottles layer visible, and assign the new surface to it.
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aCurves __ CapCurves_ _ jZ] Bottle ID Rl

Setstate i, B>

11 Make the LabelCurves layer invisible

Save your work

1 Save your work in the wire directory of the Lessons project.

2 Name your file myshowergel3.wire.
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Part 4: Adding Blend Details

Creating the Blend Surface

The label surface is recessed back from the main bottle surface. The gap between
the two surfaces will be bridged by a Birail surface, which will give the label
area its character.

To create the Birail, you will use the two trimmed edges as Rails, and create
two new curves for the Generation curves.

Part 4 of the tutorial.

Opening the tutorial file (optional)

If you successfully completed Part 3, proceed to the next step: Creating the
Generation Curves below.

If you were not successful in part 3, open the file called showergel part4.wire,
located in the wire directory of the courseware project. This file contains the
completed model from Part 3.
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Creating the Generation Curves

Previously, you used the Align tool to create tangent continuity between two
surfaces. Now, you will use the Align tool to create a tangent relationship
between a curve and the edge of a surface.

To keep the Birail surface smooth and taut, you will use a curve with only 3
CVs to define the character of the blend. Two CVs will control tangent
continuity to the label surface, and the third will control positional continuity
to the body surface.

TIP Using the minimum number of CVs needed in a curve or a surface helps to
keep your model light and smooth.

1 Zoom in to the area at the top of the label.

2 Choose Curves > New curves > New Curve by Edit Points.

3 Double-click to open the option window. In the Curve Degree section
choose 2. This will create a single-span curve with only 3 CV points.

=¥ New Curve (Edit Points) Options x|

N New curve (edit point)

knot Spacing

o
A =

S5 S 7

Curve Degres

Create Guidelines J

Reset ‘ Save ‘ Exit ‘ Go ‘

4 Use Curve Snap (Ctrl + Alt keys together) and click the edge of the body
surface. Then, without releasing the mouse button, drag to the bottom
of the edge until the blue cross turns to a yellow one, confirming that
you have accurately reached the corner of the surface.

558 | Chapter 8 Modeling a Sports Shower Gel Bottle



The first edit point of the new curve is placed.

5 Use Curve Snap again and click the edge of the label surface, then without
releasing the mouse button, drag to the top of the edge.
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NOTE The Birail tool requires that all boundaries are accurately aligned, so
it is important that the curve is snapped accurately to the corner.

6 Choose the Object Edit > Align > Align 2008 tool. Double-click the icon
to open the option window.

In the Continuity section, choose Tangent.
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> allign Control

7 You are prompted to select the first object near the align location. Click
the curve, near the label surface.

8 You are prompted to select the second object to align to.
Click the edge of the lower label surface.
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The curve is adjusted to be tangent to the surface.

9 Adjust the view so you can see the lower part of the label surface.

10 Create another Degree 2 edit point curve across the gap, using curve snap
to place the curve edit points exactly at the corner of the surfaces.
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11 Use Object Edit > Align > Align 2008 again to align the curve to the label
surface.

12 Zoom out to see the whole label area.
Building a Birail Surface with Continuity

1 Choose the Surfaces > Swept surfaces > Rail surface tool. Double-click the
icon to open the option window.
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2 Check that the options are set for 2 generation curves and 2 rail curves.
Adjust the Continuity settings to:

gen 1 Implied Tangent
gen 2 Implied Tangent
rail 1 Tangent
rail 2 Position

>* Birail II Gen. Control

'

IMPLIED TAMN
IMPLIED TAM
TAMGENT
POSITION

3 Because the Rails will be the trimmed edges of surfaces, choosing the
Rebld option on the two rails will improve the quality of the surface.
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>> Birail II Gen. Control

'

4 You are prompted to select the curves in order. Choose the curves and
edges as shown.

The Birail surface is created.
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5 Choose Pick > Nothing to de-select the surface.

6 Choose Pick > Object, then pick and assign the two curves you created
to the Curves layer.

7 Use Diagnostic Shading to evaluate the result.
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Completing the Model with Round Surfaces

To complete the model, you will soften all the sharp edges with Round surfaces.

1 Remove the Diagnostic Shading from the model.

2 Zoom in to the neck area.

3 Choose the Surfaces > Round tool. Click the edge between the neck and
the shoulder surfaces.

4 The default radius value is shown, and highlighted in white.

5 In the prompt line, type in a new radius value of 1. Then, press Enter.
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6 Click the Build button. A round fillet is created.

7 Choose Pick > Nothing to remove the round indicators.

8 Adjust the view to look at the edge of the label panel.

9 Use the Surfaces > Round tool again to create a fillet along the sharp edge
of the label birail surface.
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10 Choose Pick > Nothing to remove the round indicators.

11 Adjust the view to look at the base of the bottle.

12 Use the Surfaces > Round tool again to create a fillet.
As there are two edges at the base, click first on main bottle surface edge.
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Type in a Radius value of 10. Then, click the edge created by the finger
grip surface and the base. The round surface will then be built along both
edges.

Fou] e

13 Click the Build button to create the round surface.

14 Choose Pick > Nothing to remove the round indicators.
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15 Make sure that all the new surfaces are assigned to the Bottle layer.

16 Adjust the view and use the diagnostic shading to evaluate the rounds.

Save your work

1 Save your work in the wire directory of the Lessons project.

2 Name your file myshowergeld.wire.
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Part 5: Embossed Logo Details

In this section, you will create an embossed logo at the base of the pack.

You will use an offset surface to create the logo surface; trimming to create
the logo outline, and a Freeform Blend to join it to the main surface smoothly.

Part 5 of the tutorial.

Opening the tutorial file (optional)

If you successfully completed Part 4, you can proceed directly to the next step:
Trimming the Body Surfaces below.

If you were not successful in part 4, open the file called showergel part5.wire,
located in the wire directory of the courseware project. This file contains the
completed model from Part 4.
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Trimming the Body Surfaces

The transition surface will be created using the Freeform Blend. This tool
quickly creates a tangent or curvature blend between two edges, and is
particularly useful when the edges are made up of many sections.

The embossed logo surface will be created using the Offset tool.
You will start by projecting the outer logo curves onto the main surfaces.

1 First, make the LogoCurves layer visible.

_ LabelCurves _ _@ LogoCurves ||:|
I s

Set state Sy b

_ CapCurves. _ E

2 Maximize the Left window to specify the direction of projection.
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3 Choose Surface Edit > Create CurvesOnSurface > Project.

4 You are prompted to select the surfaces. Select the main bottle surface
and the finger grip surface.

5 Click Go. You are prompted to select the curves to project. As there are
many curves in the logo detail, drag a selection box over all the curves.
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All the curves are highlighted.

Click Go to project the curves. Curves-on-surface are created on the two
surfaces.

Maximize the Perspective window to see the curves-on-surface more
clearly.
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Next, you will trim away the main surfaces.

8 Select the Surface Edit > Trim > Trim surface tool. You are prompted to
select the surface to trim. Click the main bottle surface first.

9 When prompted to select the trim regions, click the part of the bottle
surface to keep, as shown.
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Click the Keep button to trim the surface.

The surface is trimmed to the outer curves, the inner curves are ignored.

Do the same for the finger grip surface, trimming away the small corner
of the logo that crosses into the surface.

10 Select the Surface Edit > Trim > Trim surface tool and follow the prompts
to trim the finger grip surface.
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The surfaces have now been trimmed to allow the logo details to be embossed.

Creating the Offset Surfaces

To create an ‘embossed’ effect, the main bottle surface will be offset by 0.5
mm, outwards from the bottle. This will then be trimmed to the inner logo
curves.

You will first create a layer for the new offset surface.

1 Choose Layers > New to create a layer.

VES_ _@ Biottls O L?- : O

The layer will only be used to temporarily organize the model, so there
is no need to re-name it.

Now, create the offset surface.

2 Choose Object edit > Offset and select the main bottle surface.
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3 At the prompt line, type in an offset value of 0.5. Click Accept to create
the surface.

4 Choose Pick > Object and you will see the new surface is already
highlighted.

5 Assign the surface to the new layer.
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6 Make the Bottle layer invisible so only the new surface is showing on the

screen.

_ logeCurves O] cCapCuves A Boitle

L]
Setstate
Visible
Symmetry
Assign
Pick CObjects

When the surface was offset, the curves-on-surface and trims were offset
with it. As you don’t want these, you will un-trim the surface and remove
the curves-on-surface.

7 With the surface still selected, choose Surface Edit > Trim > Trim divide.
Double-click the icon to open the option window.
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> Untrim Options

B I B

8 Choose the All option, so the surface will be fully untrimmed in one
operation.

9 Choose Pick > Object types > Curve on surface and drag a pick box over
all the curves-on-surface to select them.
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10 Press the Delete key to delete the curves-on-surface.

11 Maximize the Left view. You can see that the logo curves extend beyond
the surface by a small amount. The easiest solution is to extend the surface
slightly so the curves fit.
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You will use the Extend tool interactively, to extend the surface a small
amount by eye.

12 Choose Object edit > Extend and click the edge shown. You will be asked
if you want to remove the construction history — answer Yes.

confirm

&n active item has construction
history, IF vou continue,
histary will be remaoved.

Do you wish ko continue?

fes Mo

13 The edge is still highlighted. Click and carefully drag the left mouse button
to extend the surface just beyond the inner logo curves.
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TIP If you over-extend the surface, type in 0 at the prompt line to return the
surface to its original shape.

Trimming the Offset Surfaces

Now, you will project the curves onto the offset surface, so it can be trimmed
to the inner logo shapes.

1 Choose Surface Edit > Create CurvesOnSurface > Project.

2 When prompted to select the surfaces, select the offset surface and click
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3 When prompted to choose the curves to project, use a drag box to select
all the curves.

4 Click Go to project them onto the surface.

Next, you will trim the offset so that only the three inner shapes remain.

5 Select the Surface Edit > Trim > Trim surface tool and click the offset
surface when prompted.
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6 When prompted, select the three inner Regions, and click Keep.

The surface is trimmed into the three parts of the logo.
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Now is a good time to tidy up the layers.

7 Choose Pick > Object and select the offset surface.

8 On the Bottle layer tab, select Assign.
= Battls

The surface disappears from the screen because it has been placed on an
invisible layer.

9 Make the Bottle layer visible and check that the new offset surface is
there.

10 Make the LogoCurves layer invisible.
[ _ CapCurves_ I

11 Remove the temporary layer by choosing Layers > Delete > Unused layers.
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Creating the Freeform Blend Surfaces

To give a smooth ‘embossed’ edge to the logo, you will use the Freeform Blend
tool to blend from the outer to the inner shapes.

1 Maximize the Perspective view and use Diagnostic Shading to check that
the gaps have been created for the blend surfaces.

Next, you will create the freeform blend surface. As the logo shapes were
made up of many curves, you can use the Chain Select option to select
the whole edge.

2 Choose Surfaces > Multi-Surface blend > Freeform blend, and double-click
the icon to open the option window.

3 Choose the Chain Select option, and leave the option window open on

screermn.
1ol
Continuity TANGEMT |
Shape| 1.0000 | ]
4 Control Options
Chain Select |7 Continuity Check. J

Auto Recalc. J

Recalc Undo Al ‘ R ‘

588 | Chapter 8 Modeling a Sports Shower Gel Bottle



4 You are prompted to pick the input surface curves. Click the edge of the
first logo offset surface as shown.

The whole edge is selected and highlighted in pink.

5 Next, click the edge on the bottle surface.
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The edge is selected and highlighted in yellow.
6 Click Recalc to build the Freeform Blend.
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7 To continue building the blend surfaces, click Next in the Freeform Blend
option window.

>> Freeform Blend Control

| Simple |

.
o |

% Control Options

B
‘

= -

8 Repeat the process to create the other two blends.
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9 Use Diagnostic Shading to evaluate the logo embossing.

10 Finally, make sure all the surfaces are assigned to the Bottle layer.

Save your work

1 Save your work in the wire directory of the Lessons project.

2 Name your file myshowergel5.wire.

Part 6: Completing the Model

In this section, you will complete the model by mirroring the surfaces and
creating a cap.
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Part 6 of the tutorial.

Opening the tutorial file (optional)

If you successfully completed Part 5, proceed to the next step: Mirroring the
surfaces below.

If you were not successful in part 5, open the file called showergel part6.wire,
located in the wire directory of the courseware project. This file contains the
completed model from Part 5.

Mirroring the Surfaces

Finally, you will mirror all the surfaces using the Layer Symmetry tools.

1 Turn on Symmetry for the Bottle layer using the sub-menu on the layer
menu.
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2 Click in the layer tab to make the layer active. It will be shown in yellow
with a white border.

| - o

3 Choose Layers > Symmetry > Create geometry to convert the mirrored
image of the geometry into actual geometry.
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To complete the model as a closed volume, add a planar surface to the
top of the neck.

4 Choose Surfaces > Planar surfaces > Set planar and select the two top
edges of the neck. Click Go to create the surface.
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Volume Measurement

If you have built your model carefully so there are no gaps between the surface
patches, you can calculate the volume enclosed by those surfaces.

For the volume calculation to be accurate, all the surface normals need to
point outwards.

As you build you model, you aren't concerned with the direction of the surface
normals and they will be randomly pointing in or out of the model.

NOTE The Surface Edit > Orientation > Reverse Surface Orientation tool can be
used to show the direction of the surface normals.

For an accurate volume calculation, you need all the surface normals pointing
outward from the model.
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So, to create a good model for volume calculations, you will first unify normals
for the surfaces.

Preparing the Model for Volume Calculation

1 Make sure that only the bottle surfaces are visible on screen.

2 Choose Surface Edit > Orientation > Unify Surface Orientation. Drag a
pick box over the whole model to select all the surfaces.

Classify

3 The surfaces are highlighted,
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Classify

4 Click Classify.
The surfaces are highlighted in blue, and a Unify button is shown.

A blue arrow is also shown, indicating the direction of the surfaces. This
arrow should point out, away from the model. If it doesn't, click it to
switch the direction.
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5 Click Unify to unify the surface directions. A message is shown in the
prompt window confirming the surfaces have been unified.

E Marrals unified across 1 sek(s), l

Calculating the Volume

Now, you will calculate the volume of the bottle.
1 Choose Pick > Object and select all the surfaces.

2 Choose the Evaluate > Mass properties tool. The volume is created and
displayed in a separate window.

_iolx

Units T
frea 31683,529663
Yolume 336555918149
Cenkroid 1.18 | 0.00 72,15

Extract To File

Interpreting the Calculated Volume

The figure given in the mass properties window is in cubic millimeters. Most
packaging designs are measured in milliliters.
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To make the conversion, divide by 1000.
So, in this example, a volume of 336555 cubic millimeters is 336.5 milliliters.

Also, the volume measured is the external volume of the whole bottle. This
will include the liquid, the airspace at the top of the bottle and the thickness
of the plastic itself. Making an allowance of 25% is a good approximation of
the extra volume all these factors add to the desired product volume.

So, if our target is a product volume of 250 ml, you would expect to add 25%
to account for the plastic material and airspace, giving a target of 312.5 ml
for the external shape modeled. This would then be displayed as 312500 mm3
in the Mass Properties window.

Revolving a Cap

To finish off the model, you can build a simple cap from curves supplied on
the CapCurves layer.

1 Turn on the visibility of the CapCurves layer.

2 Select all the cap curves using Pick Objects on the layer sub-menu.
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Setstate By e

Choose Surfaces > Revolve and double-click the icon to open the option
window.

In the Axes section, select Global. This enables you to revolve all the
curves at the same time around the origin.
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>> Revolve Options

Rervolve surface

360.0000

6 Assign the new cap surfaces to the CapCurves layer.
The Shower Gel pack design is now complete.
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Save your work

1 Save your work in the wire directory of the Lessons project.

2 Name your file myshowergel6.wire.

Conclusion

Congratulations! You have completed the Shower Gel Bottle, and have an
understanding of continuity and how to build smooth forms in AliasStudio.
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You have learned how to:
B Create smooth transitions between surfaces
B Model accurately for manufacture

B Use Layer Symmetry

|

Change the degree of a curve

Now that you have completed this shower gel modeling tutorial, do this quick
quiz to help you remember the tools and techniques you have learned.

1 Which of the following can be toggled on and off using the Show menu
on the window pane?

(a) Model
(b) Lights
(c) Grid

(d) Pivots

(e) Locators

(f) All of the above

2 Which of the following tools have a Chain Select option?
(a) Round

(b) Tubular Offset

(c) Freeform Blend

(d) Profile Blend

(e) Tube Surface

(f) Draft / Flange

3 Where can you set up a mirror image of your geometry, one that will
update each time you modify or build a surface?

B (a) Use Edit > Duplicate > Mirror
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B (b) Use Transform > Rotate

B (c) In the Layer tab, use the symmetry setting.

B (d) Use the symmetry setting in the Control Panel

B (e) Use the Symmetry setting in each surface tool
How many CVs does a single-span, degree 2 curve have?
Hm (a) one

(b) two

(c) three

(d) four

(e) five

What kind of continuity does the Round surface produce?
B (a) You can choose either Tangent or Curvature

(b) None

(c) Positional only

(d) Tangent only

(e) Curvature only

hat is important when calculating the volume of a model?
(a) The surfaces represent a closed volume

(c) There are no duplicate surfaces

W

|

B (b) The surface normals all point outwards

|

B (d) Which units are set up in the Construction options
|

(e) All of the above
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On Your Own

This exercise has given you an introduction to the tools that can create
continuity between surfaces. Mastering these techniques fully takes time and
practice, and is one of the advanced topics to study in AliasStudio.

Below are some ideas for practicing and exploring these techniques.

Packaging design is a good area to look for freeform and smooth surfaces.
Below are two examples of shapes and features that you could try.
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The techniques you learned modeling the label area on the Shower gel bottle
can be used to create features on product designs and vehicle designs as well.

The finger recess on the back of this cell phone is created in the same way as
the recessed label.
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The raised center section of this car hood is blended into the main surface
using a Birail with curvature continuity.
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If you are using Studio, SurfaceStudio or AutoStudio versions of AliasStudio,
you have more options for creating curvature continuity surfaces.

If you are using one of these products, try rebuilding the shower gel bottle
with curvature continuity instead of tangent.

Look at the model supplied for Shaders and Lights on page 635. This version
of the shower gel bottle has been created using curvature continuity.

Quiz Answers

Answers to the Shower Gel Bottle Tutorial quiz
1 (f) All of them
(b), (¢), (d) and (e)
(¢) In the Layer tab, use the symmetry setting
(c) Three

(d) Tangent only

AN L A W N

(e) All of them are important.
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An introduction to
Rendering

Learning objectives

In this tutorial, you will learn the foundations of rendering and experiment with the toggle
shade tool.

You will learn:
rendering theory
resolution theory

shaders and texture theory

the hardware shader

|

|

|

B the Multi-lister
|

B editing shaders and textures
|

assigning shaders

To complete this tutorial, you will be supplied with the model of a personal digital assistant
(PDA). We will examine some of the key concepts of rendering, like the Render Globals settings
window, resolution, and the powerful interactive form of rendering, Hardware Shading.
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New menu items used in this tutorial

B Window Display > Hardware Shade
B Render > Globals

B Render > Multi-lister > List shaders

Overview

An overview of the rendering process.

After you have created objects, lights, and shaders, you can bring these
elements together in the final rendering process. AliasStudio offers industry
standard sizes and types of rendering with adjustable quality levels. Generally,
the better the rendering quality required, the longer the renderer takes.

The rendering pipeline
The rendering process requires that you set up surfaces, cameras, lights, and
any animation channels that may have been used in the scene. When a

rendering is executed, all of the information about the scene is either streamed
directly to the renderer for immediate rendering, or it is exported to a special
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file called the SDL file (Scene Description Language). This file can be saved
and rendered later using a command line batch renderer. Users with
programming experience can also edit the SDL file to change how it will
render.

Rendering types

To decide which rendering type is required for your work, you must decide
on the look you want.

Hidden-line - This rendering type produces an outline rendering of the scene
and renders objects using flat unshaded color.

.
\!

Raycast - This rendering type produces a smooth shaded rendering of the scene
that includes shadowing capabilities. Raycasting is faster than Raytracing, but
lacks the extra realism added by true reflections and refractions. If necessary,
reflections can be simulated in a Raycast rendering using environment maps
and linear transparency. For long animations, Raycasting is often used to keep
the rendering time for each frame short.
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Raytrace - This rendering type gives a smooth shaded rendering of the scene
that includes reflections, refractions, and shadows.

Render globals

Before rendering, you must decide on both the size of the image and how
detailed the image will be. The Render Globals window, under the Render
menu, is used to set the size and resolution of the image, the quality of
anti-aliasing, the raytrace rendering limits, and many other rendering
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parameters. Since many of the settings change the rendering time, you must
balance the need for quality with that of size.

M render Globals ]

Render ALL |

Animation J

Global Quality Level MEDIUM |

Global Quality Parameters { mid )
Composite Rendering Options
Memory Cplions

Blur Effects

Miscellaneous

Image File Output

€ € & & ¢ ¢ &

Hidden Line Rendering Parameters

EY)

Image file output

In the Image File Output section of the Render Globals window, you can set
which cameras or orthographic views are rendered and the size of the rendered

images.

F Image File Cukpuk

Format ALLAS |
Depth Format ALIAS |
Fields OFF |

Ignore Film Gate J

Gamma Correction I 1,000 .

Image Mask Depth

Image XY Ratio Lock J

% Resalution I 645 ]_ .
Y Resolution I 486 ’_J

Pixel Aspect Ratio I 1,000 | J

+ Predefined Resolutions

Renderings are bitmap images that consist of a matrix of pixels, each holding
a particular color. The size of the rendering is set in pixels, representing the
number of colored squares along the X and Y axis of the rendering.

The Predefined Resolutions section of the Render Globals window contains a
comprehensive list of image size standards you can choose from. As an
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example, North American image size for video is 645 x 486, which defines the
NTSC standard.

Rende oba ;IQIEI

Z Predefined Resclutions
Add Delete * i Aspect
NTSC £45 486 | 1.000
PaL = 576 1.000
Abekas NTSC (Mew) Fen 456 1,000
Abekas MTSC (Old) Fan 486 0,900

= abekas PaL Fen =) 1,067
Accom MNTSC Fan 486 0,900
Accam PAL Fen 576 1,000
4:2:2 7an 4586 1,000

= Chyron =] 484 1,000

ﬂ Galileo £40 486 | 1,000

If you want to render for print, you need to render at a pixel resolution that
will give you enough pixels for the size of the printing job. Many print jobs
use 300 pixels per inch (ppi) as a standard. To determine the final dimensions,
you must multiply the resolution by the desired image size in inches. For
instance, a 3" x 4" rendering would require a resolution of 900 (3 x 300) x
1200 (4 x 300) pixels. If you use the metric system, your standards may be a
little different.

TIP Try not to render images larger than required. Adding size to the render
resolution can add significantly to your render time.

Resolution - some theory

In order for a bitmap image to look good, the pixels must be as small as
possible, so they are not easily perceived individually by the human eye. Every
bitmap image has a resolution that determines how many pixels fill an inch,
pica, or centimeter. A 10 ppi (pixels per inch) image displays 10 pixels in every
linear inch of image. A 72-ppi image has 72 pixels per linear inch, and a
300-ppi image has 300 pixels per linear inch. As the image resolution gets
higher, the image quality improves, to a certain extent.

If you are taking the image to press, check with your printer to find the number
of lines per inch that are used — and double the number of lines to determine
the maximum resolution you should be using. If you have a well anti-aliased
picture, you can probably use a lower value (but always make it at least as
high as the number of lines per inch).
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For example, if your printer is using 85 lines per inch (say, for a newspaper),
your image should be rendered at a maximum resolution of 85 x 2, or 170
pixels per inch. If your printer is using 150 lines per inch, your image should
be rendered at a maximum resolution of 150 x 2, or 300 pixels per inch. Any
resolution greater than twice the lines per inch will not likely improve the
image — it will just take longer to render, and may cause some fine detail to
drop out.

These next two images show the same file — but, at different resolutions. The
first image is 40 ppi, and the second is 150 ppi.

Irmade rendered at 40 ppi

Imade rendered at 150 ppi

Resolution is used to determine how big an image will display or print on an
output device. Your monitor is an output device, as is your printer. Your
monitor is typically capable of 95 dpi (dots per inch). Therefore, if you want
to see a 4" x 5" image on your monitor, you need (95 dpi x 4") pixels and (95
dpi x 5") pixels, or 380 x 475 pixels. If you wanted to print the same image at
the same size on a 300-dpi printer (which usually has 57 lines per inch), you
would need (57 1pi x 2) x 4" pixels and (57 1pi x 2) x 5" pixels or 456 x 570
pixels. As you can see, the higher the image resolution, the more pixels you
are going to need to see the same size of image.
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Visualizing a PDA

()

the tutorial.
To open the tutorial file

1 Open thefile called pda_rendering.wire, located in the wire sub-directory
of the courseware directory.

NOTE For information on how to open a file, see Opening the tutorial file
in a Windows Environment on page 86.

2 A dialog box appears, asking if you want to delete all objects, shaders,
views, and actions. Click Yes.

Bonfirm x|

DELETE all abjects,
shaders, views and actions
before Opening this File?

Yes ‘ Mo Cancel

3 If your construction tolerance values differ from those in the
pda_rendering.wire file, you will be prompted by a Construction Options
dialog box. Click Accept New Settings to use the construction tolerances
in the pda_rendering.wire file.

618 | Chapter 9 An introduction to Rendering



confirm

The Construction Options of the retrieved fle differ from the current ses<ion
Do you want to keep the current Construction Options?

The file is displayed.

[Sraee]
File Edt Delete Layouts ObjectDisplay DisplayTgls Layers Canvas Render Animation Windows Preferences Utiities Help

[% @ Py i [Loft Togor ] e | srid | crv
Defaulttayer | Uppe rody | | 3futtons [ Transien D)

4 Next, choose Preferences > Workflows > Visualize. This will hide all tools
not needed for visualization or rendering work.

7
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5 Close the tool palette. To pick objects or components, you can use the
marking menus.

6 Choose Windows > Control Panel. This opens up a frame in the window
containing frequently used tools for the visualization process. Between
the menus, marking menus, and control panel, you have all the tools
you need to work on an image at your fingertips.
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7 Click the Maximize icon on the Perspective view to expand it.
Your AliasStudio window should look like the following illustration.

[ pesignstudio ( Version 12.0 License expires: 01-mar-2005 ): pda_renderingwire: \\Pc-designdocs\AW Documentation) (=] §

st "m

[ abiect <> [ name of item to pick ] unpick: [Left Toggle] [Middle Replace] [Right Remove] Mag | Grid | Crv

Defaullayer [ |  Upperody ) Lowersody | | 3futtons |0 Transiep [

Flle Edi Delets Layouts bjectDisplaDisplayTo was Render Animation

Resident Shaders

SEEE

Shaded mode

An overview of the hardware shade settings.

As a first step in the journey to understanding rendering, you will use shaded
mode. This tool provides a fast colored and shaded reference of a model in a
modeling window. You can also enable textures, shadows, reflections, and
more. For more information about all the functionality of this mode, see
WindowDisplay > Hardware Shade.

To enable shaded mode

1 Choose WindowDisplay > Hardware Shade r to open the Hardware Shade
window.
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'E Hardware Shade -Jo&d

Use Embedded File Settings J

Al windows J All Geometry |7

Shading method Per vertex |
Tessellator Accurate |
Quality MEDIUM |
Texture resolution 128 |
Light source DEFALLT |
Self Shadows J
Auto update |7

% Enable Environment Effects
Use Environment |7
Show Background J
Ground Plane J
Shader Glow J

Linear Reflection J

Edit Environment

% Optimize during Tumble
Self shadows J
Ground Plane Reflections J

Shader Glow J

Shade off Shade on

2 In the Hardware Shade window, click the Shade on button to shade the
model in the Perspective view.

Tumble about to get a good view of the model.
Click Shade off.
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3 Close the option window.

4 Now choose WindowDisplay > Hardware Shade without opening the
option window. It applies the Shade settings to the window, without
having to open the window.

You will notice that color and surfaces have been applied to the wire
frame of the personal digital assistant (PDA). These colors and textures
are created by a number of shaders, which are visible in the Resident
Shaders tab of the Visualization panel.

5 Now, turn off Shade by choosing WindowDisplay > Hardware Shade
again.
We will take a quick look at shaders, and the tools you can use to change
them.

Shaders and textures

An overview of shaders and textures.

After you have created wire frames, such as those supplied in the PDA model,
you will want to see them wrapped in surfaces that can then be transformed
into rendered images. To make the rendered images as striking and realistic
as possible, you need to apply shaders and textures to your objects.

AliasStudio uses shaders to define the appearance of your objects, so they look
as if they were created with real materials. Textures can also be applied to the
shaders to create more sophisticated visual effects. As you will discover in later
tutorials, you can even add special effects to shaders to make them appear
semi-transparent or to give them a sense of 3D relief.

Shaders

Shaders determine what surfaces look like (for example, color, reflectivity, and
roughness). Once you create a shader, you can assign it to one or more surfaces.
You can also layer more than one shader on any given surface.

The Visualization panel

The visualization panel provides you with fast access to libraries of shaders
and to the most-used capabilities of the multi-lister.

In the previous section of this tutorial, when you switched to shaded mode
via WindowDisplay > Hardware Shade, you were viewing a shader we already
applied to the model. Let’s now look at the shaders in the Visualization panel.
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Wisualize
@ Shader Library... '

environments

glass

plastic

rubber

metal |

Resident Shaders

[~ Resident shaders.
These are the shaders stored in your
wire file after you have created them or
assigned library shaders to objects in the
SCEne.

0 picked objects |

nene —Drag this bar down to increase the size

“- \ * ‘ of the Resident Shaders section.

& Shader Parameters

IMadel Lambert
SEE S
|

1 Drag the bar down until you see all the shaders in this wire file. The
resident shaders section should now look similar to the following image.
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Resident Shaders

All of these spheres are shaders that are assigned to different parts of the
PDA. To see which sphere is assigned to which part of the PDA, click a
sphere.

2 Choose the second icon from the left in this section of the panel:

¢ W@

This tool picks objects by the current shader. You can choose each shader
and click this tool to see which shaders are assigned to what parts of the
model by looking in the Perspective view after you have clicked this tool.

3 Click each shader, and then click the Pick Objects by Current Shader tool
to see the assignments.

You can also modify some attributes of shaders in the visualization panel.

4 Click the green shader, and then Pick Object by Current Shader.
You will see that the button at the top of the PDA is highlighted.
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5 Push the bar under the Resident Shaders section up to reveal the Shader
Parameters for this shader. The most commonly used shader parameters
are shown in this section of the panel.

% Shader Parameters
Made| Blinn

RGE Color

I

Transparency
|

Diffuse

[oeon [ [

Specular
| —

Spec. Rolloff
o300 | |

6 Click the green rectangle under RGB Color. This opens the color palette,
so you can choose a different color for the shader.
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Tabletop: Color

Swatches  Options

W'heel I EBlend ]F‘alettel

/s

Color Model

‘q

Colar Model RGE |

red| 1156 [N
Green| 92,32 -I-]
e 7457 NI

7 Change the color to orange by clicking the color wheel. You can modify
the color’s intensity in the HSV triangle. Close the window when you
have got a bright orange selected.

8 Notice that the color rectangle in the Visualization panel has changed
to orange.

9 Use the marking menu to pick nothing, then choose WindowDisplay >
Hardware Shade to see the model with an orange button.

10 For a better view without the wireframe, choose Model (unchecking it)
from the Show menu on the window bar to hide the wireframe.
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In addition to editing shaders, you can also create new shaders by copying
and modifying existing shaders, or import new shaders to your model from
a library by double-clicking a shader in the library.

The Multi-lister

The Multi-lister is the full interface you use to create, edit, manage, and display
shaders, textures, lights, and the environment. You also use the Multi-lister
to access the Control Window and the Color Editor.

To open shaders in the Multi-lister

1 Choose Render > Multi-lister> Shaders. A number of shaders has been

supplied for this tutorial. You can adjust the size of the icons by clicking
the right mouse button over the background of the multi-lister, and
choosing either Large Icons or Small Icons. The images in this tutorial
show small icons.

The Chrome shader was applied to the PDA case. Next, you will edit it
to make it reflect an environment.

In the Shaders window, double-click the Chrome icon.

Eshaders

»n 5

Ml S

Shader#t12 Fil

File#59 LEDArea  OMOFFButhonMOFFEutton# Shader# 1l

-
File | Edit ‘ List ‘ Delete

Shading ‘

save as | }'IEW shader | | shaders | | active

| | assign |
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The Chrome editor is opened. Notice there are two tabs: Software and
Hardware. You can use either tab for this exercise. The Hardware tab
shows a subset of the fields available on the Software tab: these fields are
used in WindowDisplay > Hardware Shade.

NOTE If you use the Hardware tab, you must first set the Shading method
to Per pixel or Per vertex in the Hardware Shade option window.

Granite#2: Filler Color

Swakches  Options

wheel I Blend IPaIette]

f". O

Color Model

%

>
4

Color Model RGE

4

Red| 150.00

Green| 75.00

Blue| 50.00

In the Shader Name field, rename the shader to Case.

Click the Map... button associated with the Reflection parameter found
in the Phong Shader Parameters section.

This opens the texture editor for the Chrome reflection.
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Sovome NP

F Tewture Procedures

% Surface

H-
ﬁ Checker

i Fractal

Mounkain

. Famp . Stencil
| - Water

% Environments

. Eall = Chrome

=
> Cube Sphere

Browse

5 Scroll down and click the Sky button located in the Environments section.
This opens the SkyTexture editor.
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=T
Tokal_bright. I 1.000

% Sun Parameters
Sun_bright. I
Hala_bright. I-

Elewation I 45,000 | J

pzmuth [ 145000 [ |

Siee [ osa |
Bur [ roon [

Atmospheric Settings
Floor Parameters

Cloud Parameters

- +« +

+ Calculation Guality

+ Color Balance

—| ¥ 3D Placement
4
|| # Effects

The Shaders window is updated to reflect the changes. Note how the
Chrome shader wears the Sky texture.

chrome

Filz ‘ Lisk ‘ Delete ‘ Shading ‘

save as | b‘uew shader | | shaders | | active | | assign |

6 To see the effect of your changes, look at the shaded model in the
perspective window.
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Now it is reflecting the sky.

Conclusion

Congratulations! You have completed this tutorial.

You now know

some rendering and image resolution theory
the Multi-lister

shaded mode

how to edit shaders and textures

the visualization panel
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Test your grasp of the material.

Now that you have completed the Introduction to Rendering tutorial, try this
quick quiz to see how much material you have retained.

1 Which rendering type offers true reflections, refractions, and shadows?
B (a) Raytracing

m (b) Hidden-line
B (c) Raycasting
B (d) Shade mode

2 If you are taking an image to press, check with your printer as to the
number of that are used.

B (a) Dots per inch
B (b) Lines per inch
B (c) Pixels per inch
B (d) All of the above
3 Shaders determine what __ look like.
B (a) Surfaces
m (b) Models
B (c) Images

m (d) All of the above

4 The is the primary interface you use to create, edit, manage, and
display shaders, textures, lights, and the environment.

m (a) Control window
B (b) Toggle shade settings
B (c) The multi-lister

B (d) The shaders window
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On Your Own

Experiments of your own design.
Now that you have begun your journey into the rendering of images, try
experimenting with the knowledge you have learned.

For example, you can

1 Continue to apply the Cloth shader to the other gears in the drill model.
2 Create new shaders that can be applied to the drill.

3 Experiment with the parameters found in the Toggle Shade Settings
options box.

Quiz Answers

Answers to the skill-testing questions found in the Introduction to Rendering
tutorial.

1la. The raytracer rendering type offers true reflections, refractions, and shadows

2b. If you are taking an image to press, check with your printer as to the
number of lines per inch that are used.

3a. Shaders determine what surfaces look like.

4c. The multi-lister is the primary interface you use to create, edit, manage,
and display shaders, textures, lights, and the environment.

How did you do on this quiz? If you got all of the answers correct,
congratulations! If you missed any of the answers, you may want to review
this tutorial before moving on.
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Shaders and Lights

Learning objectives

In this tutorial, you will learn how to create shaders and lights, and use Hardware Shade to
create rendered images of your design.

To complete this tutorial, you will be supplied with a scene of two plastic bottles.

New tools used in this tutorial

® Window Display > Hardware Shade

B Render > Multi-lister > Lights
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B Render > Create lights > Directional

m File > Export > Current window

m File > Show image

You will learn how to:

Create and edit shaders

Create and edit lights

Modify the Environment shader
Use Hardware Shading

Create an Image File from your scene

Introduction

The scene you will render will need different materials for the cap, bottle, and
label.

As well as having different colors, each material has different properties, such
as the size of the highlight, the brightness and color of the highlight, and the
reflectivity.

In this tutorial, you will learn how to simulate different materials by creating
Shaders and adjusting the Shader Parameters.

First, you will set up Hardware shading to view your model as a rendered
scene.

Then, you will create new shaders for the cap and the bottle, and apply a
graphic image to the label surface.

Finally, you will light the scene and cast shadows onto a floor plane, creating
a final composition, which you will output as an image file.
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Part |: Creating Shaders

In this section, you will use Hardware Shade to render a scene, and create
shaders for the caps, bottles and labels.

g

Part 1 of the tutorial.
Opening the tutorial file

1 Choose File > Open to open the File Browser.

2 In the File Browser, locate the courseware directory and set it as the
Current Project.

3 Open the file called Render Basics.wire, located in the wire directory

in the courseware project.

For information on how to open a file, see Opening the tutorial file in a
Windows Environment on page 86.

confirm

DELETE all objects,
shaders, views and actions
before Cpening this File?

Yes | Mo Cancel

A dialog box appears, asking if you want to delete all objects, shaders, views,
and actions. Click Yes.

If your values for construction tolerances differ from those in the
Render Basics.wire file, you are presented with a dialog:
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The Conskruction Options of the retrieved file differ from the current: sassion
Do wou wank bo keep the current Construction Options?

Option Type Current  Hew

| Linear Liits - Main Urits cn | mm

Click Accept New Settings to use the construction tolerances in

Render Basics.wire.

The file is opened. The scene has two shower gel bottles in different positions,
one with the cap open, and one with it closed.

Viewing a Shaded Scene

When setting up a model to be rendered, it is useful to work interactively with
arendered view. For this exercise, you will use Hardware Shade to work directly
on a shaded scene.

1 Maximize the Perspective view.
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2 Choose WindowDisplay > Hardware Shade q to open the Hardware Shade
Options.

ObjectDisplay  WindowDisplay | Lavers Canvas

T
Window Title Bar EI|

‘Window Sync

Hardware Shade [
Hidden line

Smoath

Transparency

v O Qa3

Toggles

3 Choose All Geometry from the option window and click Shade on at the
bottom of the option window.
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10/
J All Windows J

All Geometry ,7

Shade off ‘ Shade on

The bottles are now visualized using the Hardware Shading.

Choosing a Shading Model

The bottles have a matte finish, because they are using the Default shader,
which has Lambert shading model. There are four types of shading model in
AliasStudio:

B LAMBERT is useful for representing matte surfaces like plaster walls, paper,
or blackboards.

B PHONG is more complex, and gives highlights suitable for high-gloss
plastic, glass, and metals.

B BLINN provides more flexible highlights that can be adjusted for softer
plastics, satin finishes, and natural materials.

B LIGHTSOURCE makes the object look like it emits light, like an
incandescent bulb or flame.

As you gain more experience with shaders, you will understand which Shading
Models will produce results you want.

640 | Chapter 10 Shaders and Lights



Next, you will create three new shaders one for the bottle, cap, and label. After
that, you will choose the right shading model for each one.

Using the Visualize Control Panel

For this part of the tutorial, you will use the Visualize Control Panel to create
and modify shaders.

TIP If the Control Panel is not currently shown, choose Windows > Control Panel
to turn it on.

1 At the top of the Control Panel, choose the Visualize option.

e Default
Application Mode

v Default

Paint
Visualize

The Default Shader is shown in the Resident Shaders section.
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a Yisualize
- |_Shader Library. ..
environments

layered

rrak=l

Resident Shaders

If the name of the Default Shader is not shown underneath the blue
shader ball, you can turn on the icon labels in the General Preferences.

2 Choose Preferences > General Preferences r to open the preferences

window.
Windows  Preferences | Utilities  Help I
T
Workflows [
Menus [
Interface [

General Preferences a |

Performance Options...

Construction Options...

User Options [

3 The Interface section is opened. Check the Icon labels box to turn on the
icon text.
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-eneral Preferences

Tool Icons
o Texk & sl
. Medium ~. Large
Icon labels |7 Taoltips |7
Title bar info |7 Status bar |7

The Resident Shaders section in the Visualize Panel now shows the name
of the Default shader underneath the shader ball icon.

Resident Shaders

environn  defaults

It is good practice to not use or modify the default shader, as you will
copy it to create new shaders.

So first, you will create a shader for the bottle.

Creating a Bottle Shader

1 Click the Default shader to select it.

Below the resident Shaders section, there are four icons. Click the Copy
Current Shader icon to create a shader.
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Resident Shaders

environn  defaultst  default:

0 picked objects

¢ WHe

assign aickobjs copy flayered

2 Double-click the new shader icon to open the shader editor.

The default settings are shown.

I I”
| > DefaultShaders2 i[=] B3
| Software |[Hardware (per verkex] |
Shader Mame | DefaultShader#2
Shading Model LAMEERT

#  Lambert Shading Parameters

This will give a soft highlight for the bottle plastic.
[> Dctovitshadersz 5/

Software ” Hardware {per verkex) ]

Shader Mame | Eottle

Shading Model BLIMMN

% Blinn Shading Parameters

Now, you will choose a color for the bottle.

Change the Shader Name to Bottle, and the Shading Model to BLINN.

4 In the shader editor, open the Common Shader Parameters section.
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w
[

Swatches  Ootions

WheeIIE ﬂﬁ Ea

"I

4

Calor Model

4
Color Madel RGE

Green| 67.01 ._
sie| 7500 [T

5 In the Color Editor, choose a color for the bottle.
The color chip updates, and the Bottle shader shows the new color.

A Common Shader Parameters

Coor IO
|
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Resident Shaders

environn  defaultst  botrle

Now, you will Assign the new shader to the bottle surfaces.

6 Select the bottle surfaces by using the Pick Objects option on the Bottles
layer sub-menu.

ayer ) Botte (] C

Setstate T, B

All the bottle surfaces are selected.

7 Click the Assign icon on the Visualize Panel to assign the new shader to
the bottle surfaces.
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¢ v &

assign pickobis copy layered

The bottle surfaces are now shown in the new shader color.

Now, you will repeat this process for the cap shader.

8 Click the default shader to select it. Then, choose the Copy Current Shader
tool to create a second new shader.

ervironn  defaultst  boktle

9 Double-click the icon of the second new shader to open the shader editor.
Change the Shader Name to Cap and the Shading Model to PHONG.

In the Common Shader Parameters section, choose a color for the cap.
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EF T o)X

| software | Hardware (per vertex] |

Shader Mamne: | Cap

Shading Model PHONG

+ Phong Shading Parameters

% Comman Shader Parameters

Calar | - | J— Map ...
Incandescence | Map .,
Transparency | Map ..,

Now, you will assign the shader to the cap surfaces.

10 Pick the cap surfaces using the Cap layer sub-menu.

11 Assign the Cap shader to the cap surfaces using the Assign icon in the
Visualize Panel.

A small bright highlight appears on the caps illustrating a glossy plastic
material.

12 Close the shader editor window.

13 Choose Pick > Nothing to de-select the label surfaces.
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Modifying Shaders in the Visualize Panel
The most common parameters for a shader can be accessed in the Visualize
Panel.

Now, you will give the cap a more shiny appearance, and the bottle a softer
finish.

1 Click the Cap shader to select it and open the Shader Parameters section
of the Visualize Panel.

Resident Shaders

environn  defaultst  bottle

cap

0 picked objects

¢ WHhe

assign Jickobjs copy layered

+ Shader Parameters

2 Modify the Shinyness value to make the highlight on the cap smaller.
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% Shader Parameters
Model Fhong
RGE Color
= I
Transparency
-
Diffuse
0,800 [ |
Specular
[~ | I
Shinwvness
| 62 | ]
Fefleckivity
| 0500 | |
Reflect Backaround J

The cap material should look more shiny.

TIP You can use Render > Direct render to see the changes more accurately.

3 Click the Bottle shader to select it.

4 In the Shader parameters section, modify the Eccentricity and Spec. Rolloff
values to make the bottle plastic look less shiny, with a softer surface
finish.

(= | |
Spec. Rollaff

coess [ [

Eccentricity
| o476 | |

Reflectivity
I ]

The two images below show the changes you will see in the materials.

650 | Chapter 10 Shaders and Lights



TIP Only the most commonly used parameters are shown in the Visualize
Panel. To access all the parameters for each shader, either double-click the
shader ball icon, or use Render > Multi-lister> Shaders.

Saving your work

Now, you will save the scene as a new file.
1 Choose File > Save as to open the File Browser.
2 Save your work in the wire directory of the Lessons project.

3 Name your file myRender Basicsl.wire.

Part 2: Adding a Label

In this part of the tutorial, you will take a graphic design for the label of the
shower gel bottle, and apply it to the label surface.

The process of applying the graphic is called Mapping.

The graphic file (shown on the left) is in a standard format, such as a .tif or
.jpg. It can be mapped onto a surface (shown on the right).
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The result is that the graphic file follows the U and V directions of the surface.
If the surface is trimmed, the graphic appears on the part of the surface that
is visible.

To apply the graphic as a colored label, you will map the Color parameter.

TIP Mapping can be used on many of the shader parameters, such as transparency,
bump, or reflection.

Opening the tutorial file (optional)

If you successfully completed Part 1, proceed to the next step: Create a Label
Shader, below.

If you were not successful in part 1, open the file called
Render Basics part2.wire, located in the wire directory of the courseware
project. This file contains the completed model from Part 1.
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Part 2 of the tutorial.

Create a Label Shader

1 Click the Default shader to select it. Then, choose the Copy Current

Shader tool to create a third shader.

environn  defaultst  bottle

2 Double-click the icon of the new shader. Change the Shader Name to

Label and leave the Shading Model set to LAMBERT to represent a matte

paper label.
=
{ > DefaultShaders#2 13|
[ =Software  |[Hardware (per vertex |
Shader MName | Label
Shading Model LAMBER.T

F  Lambert Shading Parameters

Resident Shaders

envirann  defaultst  bottle

.

cap label
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You don’t need to change the color of the shader, as you will now map
the label graphic onto the Color channel. The graphic image will replace
the default blue color.

Mapping the Color Channel

1 In the Label shader editor, click the Map... button beside the Color
parameter.

T

sare || Hardware (per vertex) |

Shader Mame | Label

Shading Madel LAMBERT |

Lambert Shading Parameters

Diffuse | 1,000 1

Commaon Shader Parameters

Calor J Map ...
Incandescence | Map ...
Transparency | Map ...

2 The Texture Procedures window appears. Choose the Surface > file texture.

EE -ox

% Texture Procedures

% Surface

H-
E Checker

3 The File Texture editor is opened. Choose the Browse button next to the
Image section.
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N =loi
4=} Hardware (per vertex)

Mame | File#10 oM OFF
= Texture Parameters

Image | Browse

Lse Extension o] OFF

The File Browser opens into the pix directory of the Lessons project. To
retrieve the file that contains the label image, navigate to the courseware
directory.

Go I 'lj Praject I

Lookin:IE}Dix j = c

rﬁshowerGel_Label Jif

4 Select the showerGel Label.tif image.
The pathname of the label file is shown in the Image section.

T .ol

are |[ Hardware {per vertex) ]

j Marme | Filz#10 ON OFF
File Texture Parameters

Image |Lessons'l,pix'l,ShowerGeI_LabeI.tif Browise

Use Extension [ ] OFF

Leave the editor window open on the screen, as you will use it later to
modify the position of the label.

The shader icon in the Visualize Panel shows the label wrapped around
the shader ball.
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Now, you will assign the label shader to the label surfaces.

5 Pick the label surfaces using the Layer sub-menu.

6 Assign the Label shader to the label surfaces using the Visualize Panel
Assign icon.

7 The label graphic now appears on the label surfaces.
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Choose Pick > Nothing to de-select the surfaces.

The placement of the label can be modified in the Surface Placement
section of the texture editor window.

In the Rotate section, type in 90 degrees to see an alternative label
position.

4% Surface Placement

Rotate 90,000
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11 Return the label rotation to zero degrees, to get the correct label view.

Toggle off the wireframe and grids using the Show button in the
Perspective window pane.

LY

L T T T T
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TIP To see how the label graphic is applied to the shader choose Render >
Multi-lister > Shaders. The Multi-lister is an alternative to the Visualize Panel
for working with shaders. (You will use it in the next section to work with
lights.)

In the Multi-lister, you can see the label graphic is shown as a File Texture
attached to the Label shader. If you want to delete the label graphic, you
can select it in the Multi-lister and use Delete > Active on the Multi-lister
menus.
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Environment DefaultShader Bottle

NOTE Don’t use Delete > Active from the main menus, as this will delete
any geometry selected in the scene!

Layered Shaders
Unused Shaders
Shaders

Lights

All

Active |

Edit ‘ Lisk ‘ Celete Shading

hew shader || shaders || ackive || assign

Save your work

1 Save your work in the wire directory of the Lessons project.

2 Name your file myRender Basics2.wire.
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Part 3: Lighting the Scene

Opening the tutorial file (optional)

If you successfully completed Part 2, proceed to the next step: An overview
of lights used in AliasStudio below.

If you were not successful in part 2, open the file called
Render Basics part3.wire, located in the wire directory of the courseware
project. This file contains the completed model from Part 2.

g

Part 3 of the tutorial.

An overview of lights used in AliasStudio

Lights illuminate objects. If your scene contains no lights, it will render entirely
black.

There are different types of lights you can use:
Ambient Light

Directional Light

Spotlight

Point Light

Linear Light

Area Light

Volume Light

For most of your scenes, you will use one Ambient light and either a Directional
light or Spotlight for the main lighting effects. Additional lights may be used
occasionally, to create special lighting effects or to fill in dark areas.

Default Lights

When you choose WindowDisplay > Hardware Shade, a set of default lights
are automatically created to light your scene.
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The default lights are one Ambient and one Directional light.

Lights in the Multi-lister

When you create lights, they are listed in the Multi-lister.
LiB/x]

Light Light#2

Lisk ‘Delene

[s.awas Ihewshedet " lighits H active

If you double-click a light icon in the Multi-lister, you open the Light editor.
This is where you can set and edit the light parameters such as Intensity and
Color.

=T

Software || Hardware {per vertex) |

Type DIRECTICNAL |

i Active Effects

Light N OFF

Cast Shadows fol 1] OFF
Glow OFF |
Hala OFF |

Lens Flare O OFF

& Comman Parameters

Colar | - | J Map ...

Intensity | 1.0000 |

Exclusive Link N OFF

BB

Light Radius | 1,000 1
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Lights in the Modeling Windows

Lights are also shown in the modeling windows. This allows them to be
positioned and rotated, so that lighting and shadows can be accurately
controlled.

The lights are shown as green symbols (yellow when selected), a different one
for each type of light.

Ambient light Directional
sy mbaol light symbol

The light symbols can be toggled on and off using the Show panel on each
window pane.

Shadows

The shadows a light casts can be used to help compose the scene.

In hardware shade, a virtual Ground plane can be enabled, which allows
shadows to be cast. You can choose to cast these shadows from one of your
lights, or from some preset lighting options.
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In Software rendering (Render > Render), shadows will be accurately calculated
as the light falls on the geometry. So, for example, you will need to create a
floor surface for shadows to be cast onto a floor.

Lighting your Scene

Now, you will apply these concepts to the lighting in your scene.

The initial Hardware shade settings use a preset lighting option, which only
gives you limited control over lighting in the scene.

Instead, you will use the default lights listed in the Multi-lister to light the
scene. This will give you complete freedom to adjust the lights and shadows.

First, you will modify the Hardware Shade options to display the effects of the
default lights in the scene.

1 Choose WindowDisplay > Hardware Shade r to open the option window.
In the Light source option of the Settings, choose ALL LIGHTS.

> Hardware shade settings

The lighting on your model changes, showing the effect of the Default
lights in the Multi-lister.

In Enable Environment Effects, turn on Ground Plane.
Click Shade on.
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Shadows on a Ground Plane

Next, you will display the shadows cast by the lights, so you can design the
lighting for your scene.

First, you will enable the ‘virtual ground plane’ in the Environment shader.
This is an invisible floor plane that catches the shadows, but does not appear
rendered in the scene.

1 Double-click the Environment shader to open its option window.

environn  defaulkst  bottle

cap

2 Click the Hardware tab at the top of the option window.

3 Open the Ground Plane section.
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o
Software Hardware (per vertex) |

+ Background

$ Ground Plane

Enable J

]
j + ShaderGlow

The Ground Plane options are opened.

L=

Software || Hardware (per vertex) |

+ Background

% tround Plane

Presvigw J

Height 0.000 J

shadows J
Reflection J

B |

4 Check the Shadows box, and modify the Shadow Blur and Shadow
Transparency until you get an acceptable shadow in the shaded view.

=T

Software || Hardware (per vertex) |

+ Background

% Ground Plane

Previgw J

Height | 0.000 J
shadows |7
Shadaow Blur | 0442 J
Shadaw Position ISER DEFIMNED |
= Shadow Transparency | 0.453 J

Reflection J
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5 Close the Environment window.

Changing the Light Direction

Now, you will rotate the Directional light to modify the shadow direction.

1 Choose Layouts > All windows > All windows or F9 to show all four
windows.
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In the Top window, the two lights are shown, but are partly hidden by
the model.

2 In the SHOW button in the Top window, choose Model to remove the
wireframe view. This makes it easier to see the lights in the scene.

v Model

The two default lights are shown as green symbols.

3 Choose Pick > Object and select the Directional Light.

TIP You can Transform > Scale the light symbol to make it easier to see. This
will not change the lighting effects.
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4 Choose Transform > Rotate and use the right mouse button to rotate the
light in the z-axis.

Observe the effect on the shadow in the perspective view, and position
the shadow so that it falls to the right side of the bottles. This shadow
position helps to emphasize the design of the finger grip.

TIP It is often easier to view and manipulate the lights in the 2D windows
than in the Perspective window.
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Creating a New Light

Now that you have changed the light to create an interesting shadow, the
lighting on the bottles has changed.

You will now create another light to fill in the dark areas.
1 Choose Render > Create Lights > Directional.

2 You are prompted to place the light in the scene. In the Top view, click
near the origin to place the light.

NOTE The location of a directional light does not affect the lighting in the
scene, only the rotation of the light makes a difference.

3 With the light still selected, choose Transform > Rotate and click and
drag the middle mouse button to rotate the light in the y-axis.
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4 Observe the direction of the light in all the windows, and continue to
rotate it in any of the three axes, until it is illuminating the dim areas of
the bottles.

The bottles may be over-lit, as the new light has an Intensity of 1. Now, you
will modify the second light using the Multi-lister.

1 Choose Render > Multi-lister > Lights.
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Light Light#2

The new light is shown in the Multi-lister.

Double-click the new light icon to open the option window.

Open the Common Parameters section, and reduce the intensity to around

0.5.
W=
Software ” Hardware {per wertex) |
Type DIRECTIOMAL |

+ Ackive Effects

& Commaon Parameters

Colar | -+ | J@

Intensity | 05000 |

i
ﬂ Exclusive Link | On | OFF |

3 Check the shaded view and adjust the light intensity further, if necessary.
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Save your work

1 Save your work in the wire directory of the Lessons project.

2 Name your file myRender Basics3.wire.

Part 4: Creating an Image

In this section, you will use the Hardware shade rendering to create a high
quality image that can be used for presentations or work-in-progress
discussions.

Opening the tutorial file (optional)

If you successfully completed Part 3, proceed to the next step: Setting the
Image Quality below.

If you were not successful in part 3, open the file called
Render Basics part4.wire, located in the wire directory of the courseware
project. This file contains the completed model from Part 3.
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Part 4 of the tutorial.
Setting the Image Quality

First, set the quality of the Hardware Shade to High.
1 Maximize the Perspective window.
2 Choose WindowDisplay > Hardware Shade r.

3 In the Quality pull-down menu, choose High.

4 In the Enable Environment Effects section, turn on Show Background.
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The High quality settings include the display of the background color.
This defaults to black, which obscures the shadows.

NOTE The High quality settings may also slightly change how the lights
appear on the surfaces. You can modify the intensity or direction of the lights
to adjust the image.

Now, you will change the background color using the Environment
shader.

In the Visualize Control Panel, double-click the Environment shader icon
to open the Environment editor window.

Resident Shaders

environm  defaulkst  bottle
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Software | Hardware (per pixel) |

+ Image-Based Lighting
+ Background
+ Ground Plane

+ ShaderGlow

§| + Light Tunnel Controls

In the Background section of the Hardware tab, change the color to white
(or another color you choose).

Semroment =T

Software || Hardware (per pixel} |

+ Image-Based Lighting

% Background

Calar | - J Map .,

% Pix File Backdrop

§| Backdrop | Browse

The shaded view updates to the new background color.

£
N
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Adding Ground Plane Reflections

To add realism to the image, you can add a reflection in the ground plane.

1 In the Ground Plane section of the Environment shader options, check
the Reflection option to see a reflection of your model in the ground
plane.

> Environment

[ Hardware (per pixe

i faround Plane

Reflection |7

Reflectivity | 0,500 |

Reflection Depth | 10,000

2 Modify the Reflectivity and Reflection Depth options to change the
reflections in the view.
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Exporting an Image

Now, you can set up the view and export the image.
1 Tumble the view to frame and compose the image you want to capture.

2 Choose File > Export > Current window r to open the option window.

> Save Current Window Options x|

%‘ Export current window

Image File Type

o iped . als
~.~ Liff with alpha
. brp{z4bits) ~. bmp{3zbits)

Specify Image Size |7

Maintain Aspect Ratio J

Harizontal Size | 1280 | J
WYertical Size | 1024 | J
Reset ‘ Save ‘ Exit | Go |

The Image File Type defaults to .tif. You can specify an alternative format,
if necessary.
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The Image Size defaults to the screen size. You can choose an alternative

image size by choosing Specify Image Size.
3

Go | 'l j Praject |New Project 'l

Savein:lbpix j Lol cF E-
ShowerGel_Label. tif

Object name: ImyFlender Save

File Types: IAII Files (*%) j Cancel

Click Go to save the image. The File Lister appears.

2|

4 In the Object Name section, type in myRender and click Save.

The image is created and saved in the pix directory

5

[ FCheck myRondertf - 128001024 - L2

Fie Vew e

e ||| s O

of your current project.

To view the image in AliasStudio, choose File > Show image.

Alternatively, you can view the image using any Windows or graphics
software, or import it into your presentation documents.
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Save your work

1 Save your work in the wire directory of the Lessons project.

2 Name your file myRender Basics4.wire.

Conclusion

Congratulations! You have completed a visualization of the shower gel bottles.
The basic skills you have learned in this tutorial will enable you to visualize
your models to a high quality at every stage of your design.

You have learned to:
Create and edit shaders
Create and edit lights

|
|
B Modify the Environment shader
B Use Hardware Shading

|

Create an Image File from your scene

To help you remember the rendering techniques you used, try this short quiz.

1 Which Shading Model would you use to render a pool ball?
B (a) Lambert

m (b) Blinn
B (c) Phong
m (d) Lightsource
2 Which of the following can’t you do in the Visualize Control Panel?
B (a) Assign a shader to a surface
B (b) Modify a light

B (c) Change the color of a shader
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B (d) Change the shading model of a shader
B (e) Select objects used by a particular shader

3 Where do you enable the Ground Plane option for receiving shadows?
B (a) In the Light editor

(b) In the Shader editor

(c) In the Environment editor

(d) In the Hardware Shade Settings

(e) In the General Preferences

4 Which of these techniques you learned in this tutorial won’t apply when
you do a software render using Render > Render?

B (a) Setting up shaders
(b) Setting up lights
(c) Using a Ground Plane for shadows and reflections

(d) Tumbling the view to set the scene viewpoint

(e) Setting the Environment color

5 Which of the following does not affect the light cast by a Directional
light?
B (a) Position in the modeling windows

(b) Rotation in the modeling windows
(c) The intensity value

(d) The color

(e) The layer it is on is not visible

On Your Own

Now that you have an understanding of how to create shaders and lights,
practice your skills on the following projects.
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You can create new shaders to illustrate different color options for the design.
Use the object lister to select the individual bottles and caps.

You may want to design your own label graphic and apply it to the label
surfaces.

> obect Lister SSIT=If

Shaw TP

% Cap_1

g’ Bottle_1

i Label_1

%/ Bottle_2

¥ Cap 2

% Label_z
@ persp

Use the scene you have just set up and create some detail views of the design.
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Use Bookmarks to save particular views, so that you can re-render them as
your design progresses.

D reBIEN ~on B0

'| W Viewing Panel
5 o u| -~
2> EJT 3
2 i 53
lookat &
Plane view |:|
Perspective
BookMarks
Coen 1 edit 1
Side_View
Close_Up
RenderView

All the previous models that you created can be rendered using the techniques
shown.

For example the joystick handle is likely to be made from soft-touch plastics,

so try using the Blinn shader. Vary the Eccentricity and Specular Rolloff values
to create different plastic finishes for the different elements.
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For the MP3 Player, you may want to drag some shaders from the shader
library to create metallic finishes.
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Quiz Answers

Answers to the Rendering Tutorial quiz
1 (c) Phong
2 (b) Modify a light

3 (c) The Ground Plane is enabled in the Hardware settings tab of the
Environment shader editor.

4 (c) Using a Ground Plane for shadows and reflections

5 (a) The position of a Directional light doesn't affect the light it casts on
the scene.
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More rendering

Learning objectives

In this tutorial, you will learn more advanced rendering techniques, including color mapping,
bump mapping, environment mapping, 3D textures, and raytracing.

In this tutorial, you will learn how to:

edit the Render Globals parameters
create a background environment
create a sky texture

create a fractal texture
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create a granite texture
create a bulge texture
delete a texture

raytrace a scene

adjust surface reflectivity

Part |: Editing the Render Globals parameters

In this section, you will adjust the Render Globals parameters to improve the
quality of the rendered image. Then, you will render the scene again, and save
your work.

You will begin by re-rendering the scene from the last tutorial.

g

Part 1 of the tutorial.
Opening the tutorial file

1 Choose File > Open to open the File Browser.

2 In the File Browser, locate the courseware directory and set it as the
Current Project.

3 Open the file called more rend.wire, located in the wire file of the
CourseWare directory.

For information on how to open a file, see Opening the tutorial file in a
Windows Environment on page 86.
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A dialog box appears, asking if you want to delete all objects, shaders,
views, and actions. Click YES.

NOTE If your values for construction tolerances differ from those in the
more rend.wire file, you will be presented with a dialog. Click Accept New
Settings to use the construction tolerances in more rend.wire. The file is
opened.
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Rendering the scene

1 Select the Render command ().Render > Render The file browser opens.

2 In the File Browser, go to the Lessons project. Set the Lessons project as
the Current Directory. (For information on how to do this, see Saving
your work on page 99).

3 In the Lessons project, open the pix directory.

4 Type render3 in the Object name field, then press Enter or click the Save
button.
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Go I "Ij Project |Set|:1.l|erl "I

Sa\.'e'rrl-rjpb-: jﬁﬂ'
[E beckgrouwnd.tit ] Trmage.m Bl pds_iconz.tF E
8] buttons tif Mouse_fronk.tF 8] pda_jzona. b [
] courtyard_ball Mouse_side. 1 E pdz_icond. tif E
A Fror_Final [ Mouse_top. b 8l e _jcons £ =
=] fron:_final.m a pda_final.uf E pdz_studa.tif E
Image E pda_icon E rematefinal E
4 | |
Okjeck name:  [rendesd Save
Fie Typest  [AlFies 1] = Cancel

I | Proviow Slape Edion I
Meke lean I
Creale e |
A

The file browser closes and the render begins.

When rendering begins, the Render Monitor opens.

When the render is complete, click the Show button on the Render
Monitor.

3 Render Monitor

The render is displayed.
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The body of the teakettle has a chrome material assigned to it, the grip
has a plastic yellow material assigned to it, and the table top has a flat
brown material assigned to it.

Also, you can see that the render is very faceted, especially any area with
relatively high curvature, like the metal handle and the base of the
teakettle. This faceting is often called “nickeling,” after the faceted edges
on old Canadian and American five-cent pieces. There are two variables
that affect the quality of the render. The first is the overall quality setting
that you assign to the rendering process in general, and the second is the
tessellation of the model.

Click the close box on the rendered image and the Render Monitor to
close both windows.

Editing the Render Globals parameters

1
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Select the Render Globals command (Render > Globals) to open the
Render Globals window.

More rendering



Render Globals g@

Render ALL
Animation
Global Quality Level MEDIUM

Global Quality Parameters { mid )
Composite Rendering Options
Memory Options

BElur Effects

Miscellansous

Image File Oukput

“ ¢ ¢ ¢ ¢ ¢ ¢

Hidden Line Rendering Parameters

#

The Render Globals window allows you to set all the variables for the
quality of the final render, including the size and type of image.

Click MEDIUM in the Global Quality Level field.

A pop-up menu appears.

Render ALL
Animation
Global Quality Level MEDILM
+ Global Quality Parameters { mid ) HIGH

MEDIUM
LOowW

+ Composite Rendering Options

Global Quality Level is one of the most important variables in the Render
Globals window, because it specifies the quality of the final render. LOW
produces a faster image, but the render quality will be significantly
reduced: the final result will be faceted, and may not contain all the
reflections that would be achieved with a higher setting.

HIGH produces a very high quality image, but the image will also take
longer to compute.

The rendering process is an iterative process. The typical rendering process
is to set some variables in the scene and then render a test image to see
the results, then change one or some variables and re-render the scene
to see the new results.

For this reason, when you are starting the rendering process, you will
typically render the scene using LOW or MEDIUM Global Quality Level,
to make the rendering speed faster. After you have achieved the look you
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are happy with, you will render the scene at HIGH Global Quality Level
to achieve a better quality result.

3 Set the Global Quality Level to HIGH.

| Render Globals g@
Render ALL
H ‘ Animation
Global Cuality Level HIGH

4 Click the tab called Global Quality Parameters to open this section.

Render Globals g@
J Render ALL
Animation
| Global Quality Lewvel HIGH
E‘ + Global Qu@ameters { high )
e 1

5 Set Mesh Tolerance to 0.02.

Render Globals E]@
Render ALL
_ Animation
Global GQuality Level HIGH

% Global Quality Parameters ( high

Tessellator Accurate

Mesh Tolerance (cr) 0.02000
fuy
E‘ Displacement. Detail ]

When an image is rendered, its surface is divided into triangles. This
process is called tessellation. Each surface of a model has a specific
tessellation value. When the tessellation value is low, the surface is divided
into few triangles and it may appear faceted when rendered, even if the
Global Quality Level is set to HIGH. In some cases, the only way to reduce
the faceting is to increase the model's tessellation value. Tessellation value
is another important variable in the quality of a final render.

Mesh Tolerance is the maximum allowable distance (measured in
centimeters) between a NURBS surface and its tessellated version. By
setting Mesh Tolerance to a low value, you increase the quality of the
final render. (What actually happens is that the tessellation value for the
entire scene increases.)

6 Close the Render Globals window.
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Rendering the image again

1 Select the Render command (Render > Render).
The file browser opens to the pix directory of the Lessons project.
Click the Save button to overwrite the previous file named render3.

A dialog box appears, asking if you want to overwrite or replace the file.
Click OK.

The rendering process begins.

2 After the render has completed, click the Show button on the Render
Monitor to view the image.

The entire model is much smoother; in particular, the handle and the
base of the teakettle are no longer faceted.

3 Click the close box of the Render Monitor and rendered image windows
to close them.

Save your work

1 Choose File > Save as to open the File Browser.

2 Save your work in the wire file of the Lessons directory.
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3 Name your file myadv_rend.wire.

For information on creating the Lessons project or saving your work, see
Saving your work on page 99.

Part 2: Creating a background environment

Next, you will create an environment that will be used to reflect onto the
teakettle.

g

Part 2 of the tutorial.

Creating a cloudy sky background environment

First, you will create a sky texture with clouds for the background of the scene.

1 Open the Multi-lister window, and display only the shaders (Render >
Multi-lister > Shaders).

2 Double-click the Environment shader to open the Environment Control
Window.

Environment

The environment shader allows you to determine the type of image that
is produced in the background of your scene. The environment can be
either a 2D image or a series of images that produces a 3D environment.
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| Software | Hardware (per pixel} |

4 Pix File Backdrop

Backdrop | Browse

Sequence oy} OFF

% Background

Fog
ShaderGlow

Phoko Effects

+ + ¢ ¢

Master Lighting Control

3 In the Background section, click the Map button next to the Color field
to open the Texture Procedures window.

Background

There are three types of textures: Surface, Environments, and Solid.

4 Click the three texture tabs to open them.

Laads

% Texture Procedures E

The Surface section contains 2D textures.
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The Environments section contains procedural environments that give
the appearance of real objects in the scene without adding additional
geometry.

F Environments

The Solid section contains textures that appear to be created from a block
of solid material, like wood or marble.

More rendering



5 Click the Sky button in the Environments section.

| F Environments I

This opens a parameter window called SkyTexture. The sky texture is a
very “procedural texture” that simulates a sky. “Procedural” means that
the program executes a series of commands to create the texture, instead
of using a 2D image of the sky. The sky texture can simulate a sunrise or
sunset, or you can create a sunset as it might appear on some faraway
planet.
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-ioix]

[ Software [ Hardware {per pixel) |

- Name SkyTexture#2 GH ﬁ

% Sky Environment Parameters

Total bright. | romo |
% Sun Parameters
Sun_bright. ’7
Halo_bright. F
Blevation | 45000
feimuth | 145000 |
See | osm |
Bur | oo

¥ Atmospheric Settings

+ Floor Parameters

+ Cloud Parameters

¥ Calculation Quality
+ Color Balance

+ 3D Placement

+ Effects

For this example, you will not be creating an animated sky, but you will
create a static sky.

In the SkyTexture Control Window, click the Cloud Parameters tab.

Biur 1.000
+ Atmospheric Settings
+ Floor Parameters

+ Cloud Paramet:

This section contains variables that control the clouds in the sky.
Currently, there are no clouds in the sky texture, as you can see in the
Multi-lister swatch. One way to create clouds is to map a two-dimensional
texture to the Cloud texture variable.

Click the Map button next to the Cloud texture variable.
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F  Cloud Parameters |

{ niok mapped ) | Mﬁﬁll—
1

Cloud_bright,

Sunset_bright. -+

Cloud texture

Density 1.000
Threshald 0,500
Power 1.000
Altitude 0,200

Halo_size 20,000

The Texture Procedures window appears.

SkyTexture#2 M=)

% Erwironments

. Ball ; Chrome
. Cube . Sphere
=

% Salid

. Projection . Snow

. sCloud - sFractal
D sMarble
. Leather . Granite
. Yolume

sRock

)
EI + Texturable values

Erowse

8 Click the Fractal button in the Surface section. This is a two-dimensional
texture that works well to simulate clouds and other textures like fog or
smoke.
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SkyTexture#2 =Jloled

% Texture Procedures

%+ Surface

N -
ﬁ Checker

A new Control Window appears called Fractal. You do not need to edit
the default variables for the fractal texture, because they are sufficient
for producing a good cloud image.

L=

| Software | Hardware (per pixel) |
ﬂ Mame | Fractal#2 0N OFF

% Fractal Texture Parameters

ampltude | 1,000 I

Threshold | 0.000 J

Ratio | 0707 [ |

Level_min | 0.0 J
Lewvel_max | 9.0 J
Animated Ol OFF

Tme | o000
Intensity
Eilur

Sutface Flacement

Label Mapping

+ + ¢+ + +

Effects

|Lale |

NOTE The Multi-lister now contains a Fractal swatch. The Fractal texture is
used to simulate clouds. These clouds are visible in the SkyTexture swatch.
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11

SkyTexture Fractal

Click the left arrow at the top of the Fractal Control Window.

Fractal#? (=<
Snﬂiware ” Hardware (per werkex) ]
@: Name Fractal#2 oM OFF
” % Fractal Texture Parameters

This brings you back to the SkyTexture Control Window.

Click the Floor Parameters tab to open this section.

SkyTexture#2 =Jo&d

Software |[ Hardware (per vertex) ]

- Marne: | SkyTextures#2 On @

4 sky Ervironment Parameters

Tatal_bright. | 1.000 ]
¥ 5un Parameters

+ Atmospheric Sett"ngs

[ -+ Floor Param =
= 1

Click the OFF option next to the variable Has_Floor. This turns off the
default floor in the Sky texture. We do not need the floor, because the
table top obscures the ground.

% Floor Parameters

Has_Floor On CFF

Floor texture 1" ™Map ...

+ Cloud Parameters

The floor disappears from the SkyTexture swatch in the Multi-lister.
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12 In the Sun_Parameters section, drag the slider in the Elevation field down
towards zero. Notice that the sky texture in the Multi-lister becomes
orange, as it does in real life at sunset, and finally black.

5 Sun Parameters
Sun_bright. [E0 [
Halo_bright. rjli
Elevation | 45.000 .
Azimuth [ 145.000 [
size [ 0431 ||

Now, drag the slider back to its maximum value. Notice how the sky
texture changes from black to orange and finally to a very bright washed
out color.

Set the Elevation value to 40, to mimic the sun at noon. Change the size
of the sun variable from a value of 0.531 to 2.0 and change the azimuth
value from 145.0 to 0.0.

& 3un Parameters
Sun_bright.
Halo_bright.
Elevation 45,000
Azimuth 0,000
Size 2.000

Elur 1.000

The SkyTexture swatch updates.
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sky Texture 0|

13 Close the SkyTexture Control Window and the Multi-lister.

Rendering the scene

Now, you will render the scene to see the sky texture.

1 Select the Render command (Render > Render).
The File Browser opens to the pix directory of the Lessons project.

2 Type render4 in the filename field, then click the Save button.
The File Browser closes and the render begins.

3 Click the Show button on the Render Monitor to view the rendered image.
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NOTE The sky texture is in the background of the image. Because the sky
texture surrounds the scene, if you moved the camera angle and re-rendered

the scene, you would see the sky from another position.

4 Click the close box in the Render Monitor window and the rendered
image window to close them.

Save your work
1 Save your work in the wire file of the Lessons directory.

2 Name your file myadv_rend2.wire.

Part 3: Creating a 3D solid texture

Next, you will create a granite 3D solid texture that will be used for the
tabletop.
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Part 3 of the tutorial.
Creating a granite texture

1 Open the Multi-lister window, and display only the shaders (Render >
Multi-lister > Shaders).

2 Double-click the Tabletop shader to open the Tabletop Control Window.

Tabletop

3 In the Tabletop Control Window, change the Shading Model to Phong.
This will allow you to create a more reflective surface for the tabletop.
Phong is good for polished stone -- the highlights are based on the light's

color.
B Tabletop =Joled
Software " Hardware {per vertex) ]
J Shader Mame Tabletop
Shading Model PHOMG

4 Click the Map button next to the Color field to open the Texture
Procedures window.

Common Shader Parameters |
Color Meplaly
Incandescence Mglz_l,,l_

5 In the Solid section, click the Granite button.
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Tabletop g@

% Texture Procedures

+ Surface

¥ Environments

& Solid

Projection . Sniow
sCloud - sFractal

sMarble

Leather

Py sWood . Walume
Z

The Granite Control Window opens.

Granite#2 =Jo&d

Software " Hardware {per vertex) ]

Color2 -»

|
|
L]
i

Colar3 -

Filler Calar
Cell Size 0.1500
Densiky 1.0000
Miz Ratio 0.5000
Spottyness 0.300
Randomness 1.000
Threshaold 0.500

Creases oM QFF

+ Color Balance

%I -+ 3D Placement

6 Within the Granite Texture Parameters, there are four variables that
control the color of the granite. Click the color swatch next to the Filler
Color parameter.
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Granite#2 =1

Software || Hardware (per vertex) | [

Colorz | -» |

Color3 | - |
| Filler Color IT
r | r

The Color Editor opens.

Tabletop: Color

Swatches  Options

‘Wheel | Blend |Palette
4
7 O
St

Color Model H

Y A

Color Mode| REE

red| 11362 [T
Green| 92,32 -I-:l
se| 7457 [T

7 Select a teal color, or set the red value to 51, green to 255, and blue to
255. Drag the cross hair cursor on the color triangle toward the bottom
apex, which will darken the color.
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Tabletop: Color

Swatches  Options

Wheel I Blend IPaIette]

/'l

Calor Model HaY

%

Color Model RGE

red| 2215 [T
Green| 56,02 -I-:I
ciue| se.02 [N

8 Now, you will change the colors of the small aggregate stone flecks within
the granite. Click the Color2 parameter to open the Granite:Color 2
Editor.

& Granite Texture Parameters

Color3 -
Filler Colar

Darken the color by moving the cross hairs down on the triangle.

|
Colorz | = = |
|

710 | Chapter || More rendering



Granite#2: Color2 [

Swatches  Options

Whes! | Blend |Palette

k4 [ ]
/'
Caolar Madel HSY

y

Color Madel RGE

red o150 [
areen| 135,18 -1-]

| 5.2 [N

Click the Color3 parameter to open the Granite: Color 3 Editor.

% Granite Texture Parameters

Filler Colar

Colarl |
Colarz
Colard ==kl J_
I

Darken it, as well.
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Granite#2: Color3

Swatches  Options

Wheel I Blend IPaIette

4. HEEEEEN
4 o] | |
Color Model HSY

%

Color Model
Red
Green

Blue

10 Look at the Tabletop swatch in the Multi-lister. It displays the edited
Granite texture.

Tabletop  |C

NOTE The flat brown shader originally assigned to the Tabletop shader is
invisible, because color textures supersede the shader color.

11 Close the Color Editor, Granite Control Window, and Multi-lister.

Rendering the scene

Now, you will render the scene to see the granite texture on the tabletop.

1 Select the Render command (Render > Render).
The File Browser opens to the pix directory of the Lessons project.

2 Click the Save button to overwrite the previous file named rendera4.
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A dialog appears, asking if you want to overwrite the file. Click OK.

The rendering process begins.

3 Click the Show button on the Render Monitor to view the rendered image.

The tabletop now has a granite surface. Although the camera angle that
you are using does not show the thickness of the tabletop, if you were to
re-position the camera to view the table thickness and re-rendered the
scene, the table would look like it was cut from a solid piece of granite.

4 Click the close box on the window bar of the rendered image to close it.

Save your work

1 Save your work in the wire file of the Lessons directory.

2 Name your file myadv rend3.wire.
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Part 4: Creating a 2D bump texture

In this section, you will create a shader for the Grip surface by duplicating an
existing shader. Then, you will apply a bump map to the new shader to create
the effect of a bumpy surface.

g

Part 4 of the tutorial.
Creating a shader for the Grip surface

1 Open the Multi-lister.

2 Click the Plastic shader to make it active.

3 In the Multi-lister, select the Copy command (Edit > Copy).

A new shader is created called Plastic#2. We are creating a shader instead
of modifying the original plastic shader, because the original shader was
also shared by the Decorations layer. We don’t want to change the shader
on the decorations, just on the grip.
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4 In the layer bar of the modeling window, click the Grip layer button, and
select the Pick Objects option.

5 Assign the new Plastic#2 shader to the grip.
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Unlink Lights
Link Lights
Pick Objects
List Objects. ..

Layer Shaders

|
Assign Shader —Q_— |
~

9
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Shading

assign

Choose Pick > Nothing to deselect all objects.

Double-click the Plastic#2 shader to open the shader's Control Window.

You will change the characteristics of the material to be more like a hard
sponge. The surface will still be somewhat shiny, but will not be very

reflective.

Set the Diffuse parameter to 0.2.

Plastic#2

BEX

Software ” Hardwate (per vertes) ]

Shader Name |

Shading Madel

Flastic#2

PHCOMG

% Phong shading Pararmeters
Diffuse | 0,200

|

@oss | 1,000

Set the Shinyness value to 2.

More rendering
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Plastic#2 E]@
_SoFtware ” Hardvsare {per verkex) ]
Shader Mame Plaskic#2
Shading Model FHOME
% Phong Shading Parameters
Diffuse 0,200
Gloss 1.000
e Specular
Specularity 1.000
Shinyness 2
Reflectivity 0,500
Reflection | { not mapped ) |
%I Use Environment On CFF

10 Click the color swatch to open the Color Editor.

11

% Common Shader Parameters

Color [ = | I

Incandescence

In the Color Editor, click to open the Swatches section, click a red swatch,
then close the Color Editor.

Swatches  Options

Wheel | Blend |Palette

A1 |
P

At the Shader Name cell

, change the shader name to Grip.
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|
Software || Hardweare {per pixel) | M
Shader Mame | Grip I&

Shading Model PHOMNG |

4 Phong Shading Parameters

Diffuss | 0,200 ]
Shinyness | 2 ]
| Reflectivity | 0,500 ] Map .,
Feflection | { not mapped ) | Map |
Refl. Backgnd ON OFF

4 Common Shader Parameters

fI Color J Map .
> Incandescence | S| Map ... |

Creating a bump map for the Grip shader

To create an effect of a bump on a surface, you use a technique called bump
mapping. Any image can be used as a source for creating a bump on a surface.
Typically, the image used in a bump map is gray scale. For example, to create
a golf ball, you would use an image that was all white with gray circles
darkening to black at their centers on it. The computer would push the surface
inwards everywhere there was a dark circle on the image. The darker the color,
the farther it gets pushed from the surface.

It is important to note that bump maps create the appearance of a bump on
a surface, but do not affect the surface. The edge of a bumped object will retain
its original smoothness. If you need to the edge or profile of an object to be

bumpy as well, consider using a displacement map, which alters the surface

when the image is rendered.

Now, you will create a bump map on the grip shader using a texture from
within AliasStudio.

1 In the Grip Control Window, click the Special Effects tab.
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s

_SoFtware ” Hardware {per pixel) ]
Shader Name | arip
Shading Madel PHOMG
% Phong Shading Parameters
Diffuse: | 0,200 J
Specular l— Map ..,

Shiryness | 2 J
Reflectivity | 0,500 [ Map ...
Reflection | { not mapped ) | Map |

Refl, Backand o CFF

% (Common Shader Parameters

Calor J Map ...
Incandescence | Map ..,
| Transparency | Map 1o,

+ SpeylEffects
|
+ Glow

+ Clearcoat Settings

Click the Map button next to the Bump parameter.
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| Software [ Hardwiare {per pixel) |

Refl. Backgnd ON OFF
% Common Shader Parameters
endescence | M|
Transparency Ui M

% Special Effects

Burmp | { ot mapped ) | i

Displacement | { not mapped ) | Map ...

Shading Map | Map ...

Translucence | 0,000 J

Transl, Depth | 0,500 J

opacky Depth | 0,000 J

Lise Back Colar Ol OFF

%I Matte Transp. | 0,000 ]

The Texture Procedures window is opened.

3 In the Surface section, click the Bulge texture. You will use this texture
as the image in the bump mapping procedure.
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Z Texture Procedures

& SurFace

H-
E Checker

Skencil

o
1
=
=]

‘Water

Browse

The Bulge Control Window is opened.

b

4 Click the Surface Placement tab to open it.

[=TE

_Software |[ Hardware {per pixel) ]

- IName | Bulge#Z

[on s ]

F Bulge Texture Parameters

Uwidth | 0,100 J

wwidth | 0,100 |

+ [ntensity
|

J Ralur
+ Murface Placement

+ Label Mapping

+ Effects

[l |

The Surface Placement parameters control the number of times the image

is repeated across the surface.
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5 Click the Urepeat field and type 20, then press Enter. Click the Vrepeat
field and type 20, the press Enter.

g
Software " Hardware (per pixel) ]

& Surface Placement

Rotate | o000 |

Urepeat | 20,000 J

Wrepeat |  zn.000 ]

Uoffset | o000 |

Woffset | 0.000 J

Mirrar oy} OFF
Stagger oy} JFF
Chord Length (o]} CFF

4
|22l| % Label Mapping

6 Look at the Grip swatch in the Multi-lister. The bulge texture is apparent.

7 Close the Control Window and the Multi-lister.

Rendering the scene

Now, you will render the scene to see the bumpy grip texture.

1 Select the Render command (Render > Render).

The File Browser opens to the pix directory of the Lessons project.

2 Type renderS in the filename field, then click the Save button.
The File Browser closes and the render begins.
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3 Select the Show button on the Render Monitor to view the rendered
image.

The grip now has a bumpy surface.

4 Close the rendered image and Render Monitor.

Save your work

1 Choose File > Save As to open the File Browser.
2 Save your work in the wire file of the Lessons directory.

3 Name your file myadv_rend4.wire.

Part 5: Raytracing

So far, you have been rendering your scene using a type of renderer called a
raycast renderer. A raycast rendering requires a lot of tricks to make it look
real, because raycasted images do not produce true reflections or refractions.
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There is a second type of renderer called a raytracer. This type of renderer is
much more accurate and can produce accurate reflections and refractions.
Raytracing is also a process that takes much longer to compute than a typical
raycast render.

In this section, you will learn how to raytrace an image. First, you will delete
the Chrome texture from the Metal shader. Then, you will raytrace the scene.

()

Part 5 of the tutorial.

Deleting the chrome texture

In the previous tutorial, you applied a chrome texture to the teakettle surface.
The chrome texture is assigned to the Metal shader. Now, you will delete this
texture because it will not be needed when raytracing.

1 Open the Multi-lister window, and display only the shaders (Render >
Multi-lister > Shaders).

Chrome#2

2 Click the Chrome#2 swatch to make it active.
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3 In the Multi-lister, select the Delete Active command [Delete > Active].

4 Click the OK button to confirm that you want the chrome to be deleted
from the model.

—

5 Close the Multi-lister.

Raytracing the scene

1 Select the Render options command (Render > Render 1) to open the
Rendering Options window.

The Rendering Options window is opened.
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3 Rendering Options x|

4 Render

Renderer Type

’ Raycaster .~ Powercaster

..~ Raykracer .~ Powertracer
~.~ Hidden Line

Tesk Render J

Resek ‘ Save ‘ Exit | Go ‘

In the Renderer Type section, click Raytracer.

Renderer Type

L Raywcaster .~ Powercaster

I:_.‘ .- Powertracer
|

~. Hidden Line

Click the Save button to save Raytracer as the Renderer Type.

The Rendering Options window is closed.

Select the Render command (Render > Render).
The File Browser opens to the pix directory of the Lessons project.

Type render6 in the filename field, then click the Save button.
The File Browser closes and the render begins.

Rendering a raytraced image takes longer than rendering a raycasted
image. This is because raycasting requires more time to compute
reflections and refractions in a scene.

Click the Show button on the Render Monitor to view the rendered image.

More rendering



The sky texture is reflected in the entire scene, including the teakettle
and the tabletop. The reflection of the grip is visible in the top of the
teakettle, and the reflection of the teakettle is visible in the tabletop.

7 Close the rendered image and Render Monitor windows.

Adjusting the reflectivity of surfaces

In some cases, you may prefer to limit the amount of reflection that occurs
on a surface. Next, you will change the reflectivity of the teakettle and the
color on the teakettle.

1 Open the Multi-lister.

2 Double-click the Metal shader to open its Control Window.
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3 In the Metal Control Window, change the Reflectivity value from 0.5 to
1.0. This will make the teakettle very reflective, similar to a mirror.

S heta BE,

Software |[ Hardware {per vertex) ]

Shader Name Mekal

Shading Maodel BLINM

% Blinn Shading Parameters
Diffuse 0.500
Glass 1,000

e Specular Map .,

Specularity 1.000

Spec. Rolloff 0,300

Eccentricity 0.186

Reflectivity 1.000 Map ...
Reflection | { not mapped ) | Map ...
%‘ Use Environment o'} OFF

4 Click the Color field to open the Color Editor.

Common Shader Parameters,
Color Map...
Incandescence - Map...

Transparency Map...

5 In the Color Editor, change the color of the metal surface from grey to
red. Then, move the cross hairs along the long edge of the color triangle
to make the color darker.
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> etk coor Y

| Swatches  Ookions

Wheel I Blend |Palette

d | O
7 EEN
H3Y

Color Model

%

Caolor Madel RGE

red| 110.c0 [N
Green| 10.04 H-:l
tiee] 100+ [

6 Close the Color Editor.

:Eulur Editor: Defaultshader: =5

Swatches  Options

I\.Iamel

Color Model H3Y |

7 Click the Tabletop shader to display its parameters in the Control
Window.

8 In the Reflectivity field change the setting from 0.5 to 0.2. This will reduce
the amount of reflection on the tabletop.
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Tabletop E]@

Software || Hardware (per vertex) |

% Phong Shading Parameters
Diffuse 0,800

Gloss 1.000
_ Speculat Map ...
Specularity 1.000
Shinyness 20
Reflectivity 0,200 Map ..,
Reflection | { not mapped ) | Map ...
%I Use Environment O OFF

9 Close the Tabletop Control Window and the Multi-lister.

Raytracing the scene again

1 Select the Render command (Render > Render).
The File Browser opens to the pix directory of the Lessons project.

2 Type render7 in the filename field, then click the Save button.

The File Browser closes and the render begins.

3 Click the Show button on the Render Monitor to view the rendered image.
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The teakettle is red, as opposed to gray. The reflectivity of the teakettle
in the new render is very high, like a perfect mirror. The tabletop is not
as reflective as it was in the previous render.

Save your work

1 Save your work in the wire file of the Lessons directory.

2 Name your file myadv_rend5.wire.

Conclusion

Congratulations! You have completed this rendering tutorial.

You now know how to:

B improve the quality of a final render by adjusting variables in the Render
Globals window

W create a background environment, specifically a cloudy sky at noon

W create a solid three-dimensional texture (granite)
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create a two-dimensional bump texture (bulge)
delete a texture

raytrace a scene

adjust the reflectivity of surfaces

Now that you have RayTraced the teakettle, do this quick quiz to see how
much you remember.

1 What method of rendering produces accurate reflections?

2 There are three buttons on the bottom of the Render Monitor. Name
them.

3 In the color editor, what effect does lowering the value slider have on
the color?

B (a) makes it darker
B (b) makes it lighter
B (c) changes the hue
B (d) makes the color more intense
B (e) makes the color more pastel
4 To reduce the nickeling on an object when its rendered,
B (a) fix the shading in the shader control window
B (b) rebuild the model with more CVs to make it smoother

B (c) adjust its tessellation in the Render Globals window

For the answers, see Quiz Answers on page 733.
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On your own

Now that you have rendered the teakettle, try creating more complex shaders,
environments and lighting for the other models you have created, like the
shower gel bottle and the remote control. Practice raytracing the images.

Quiz Answers

Answers to Rendering the Teakettle Tutorial quiz
1. Raytracing.

2. Show, Log, and Abort/Exit are the three buttons on the Render Monitor.
The third button changes its name from Abort to Exit when a render job
completes.

3. (a) It makes the color darker.
4. (¢). Adjust its tessellation in Render > Globals.

How did you do on this quiz? If you got all of the answers correct,
congratulations! If you missed any of the answers, you may want to review
this tutorial before moving on to the next tutorial.
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Introduction to
animating

Learning objectives

In this tutorial, you will animate the teakettle that was modeled in a previous tutorial. We
will examine some of the basic concepts of presentation animation, like keyframes, motion
paths, and turntable animation.

You will learn how to:

animate objects using keyframes
play the animation using the time slider

edit the animation in the Action Window

move a keyframe
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B animate objects using a motion path

B animate cameras and views

B animate objects using turntables

New menu items used in this tutorial

Animation > Editors > Action window
Animation > Keyframe > Set keyframe
Animation > Show > Toggle time slider
Animation > Turntable

Animation > Tools > Set motion

Animation basics

An overview of some key concepts involved with animation.

Animating an object means changing one or more characteristics or attributes
of the object over time. An object generally has many attributes, or animation
parameters, that can be animated. In AliasStudio, you can animate objects as
well as lights, cameras, and shaders to create animated sequences.

Frames and Keyframes

The basic unit of measurement for all animations is the frame. For a typical

animation, you set a specific number of frames per second, which determines
the timing of the motion and the length of the animation in frames. Typically,
video is set at 30 frames per second and films are set at 24 frames per second.

To animate any object, light, camera, or shader, you must set keyframes.
Keyframes are frames that specify the parameters of an item at specific points
in time. After you have set two keyframes, AliasStudio interpolates the action
for the frames between the keyframes. This is very similar to how a traditional
cel animator works. A senior animator (you) creates and sets the key poses for
your objects and characters, then passes them to a junior animator who draws
the “in-between” frames.
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The Time Slider

In order to play the animation, you will use the time slider. When enabled,
the time slider appears in the interface just below the AliasStudio menu and
layer bar. Enable the time slider by choosing the Animation > Show > Toggle
time slider menu item.

File Edit Delete Layouts ObjectDisplay ‘WindowDisplay Lavers Canwvas Render  Animation  ‘Windows Preferences  Ukiities  Help
=, object | El |Use mouse of enker name of itemn bo pick f unpick: [Left Togale] [Middle Replace] [Right Remave] | .‘3 @ “? |>
Category DefaultLayver D
Start 0.00 10,00 by 1.00 0,000 Fps
- End so.00 | 91111111 /B0 11 FRR T TBR R EA u

At the right end of the time slider are icons similar to those on a VCR or DVD
player that let you play, stop, rewind, or fast-forward an animation. Above
the controls are fields that show the current frame and frames per second.

In the center of the time slider is the scrub bar containing a series of ruler-marks
and numbers that indicate the individual frames of the animation. The current
frame is indicated by the gray rectangle, or frame indicator, that moves along
the scrub bar.

At the left end of the time slider are input fields that allow you to set the range
of frames to be displayed in the scrub bar.
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Part 1 of the tutorial.
To open the tutorial file

1 Open the file called animation basics.wire, located in the wire
sub-directory of the courseware directory.

NOTE For information on how to open a file, see Opening the tutorial file
in a Windows Environment on page 86.

2 A dialog box appears, asking if you want to delete all objects, shaders,
views, and actions. Click Yes.
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DELETE all objects,
shaders, wiews and actions
before Opening this File?

Yes ‘ Mo Cancel

3 If your construction tolerance values differ from those in the
animation basics.wire file, you will be prompted by a Construction
Options dialog box. Click Accept New Settings to use the construction
tolerances in the animation basics.wire file.

The Construction Cptions of the retrieved file differ from the current session
Do yiou wank ko keep the current Construction Options?
Cption Type Currenkt Mew

Lineat Units - Main Units crm T
Linear Units - Reset Grids OFF on
Curve Fit Distance Tolerance 0.0100000 cr | 0.0100000 rom
Curve Fit Checkpoints 5 10
Max Surf Spans 100 10
Continuity Maximum Gap Diskance | 0.0100000 cra | 0.0100000 rmrm
Trim Curve Fik 0.0010000 crm | 00050000 rmm
Defaul: Modeling Fork Size 11 10
Topology Distance 0.0200000 crn | 0.0200000 rmrm

eep current settings) Accept Mew Settings

The file is displayed.
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Preparing to animate

Setting up the animation environment.
In this tutorial, you will create a two-second animation sequence. At 30 frames
per second, the length of the animation will be 60 frames.
To enable the time slider and prepare the animation environment
1 Choose Animation > Show > Toggle time slider to turn on the display of
the time slider, if it is not displayed.
2 Type o in the Start field at the very left of the time slider. Press Enter.

3 Set the End value to 60. Press Enter.

~ “references Ukilities Help

<[5 point |_srid | curve|

- Decoration [E 40 |

100 | soooo—the——Set the
M - ebE o] || fPswvalue

4 At the very right of the time slider, type 30 in the fps field. Press Enter.

Part I: keyframing animation | 739



File Edit Delete Lawouts

object &

Defaultlayer I |

Start [ o0 Set the Start
. End 60,00 and End values

Setting keyframes

An overview and the proper procedure for setting keyframes in the animation
sequence.

A keyframe represents an object's position at a specified time in the animation
sequence. An object can be animated by setting a few keyframes at certain
points. AliasStudio then fills in the object's motion between each pair of
keyframes. This process, known as “in-betweening,” calculates the object's
placement in between keyframes.

Before setting keyframes, it is best to plan your animation by taking stock of
what you have available. For instance, in this tutorial, you have been supplied
with a complete model. Because an animation sequence involves changing
the characteristics of the model’s components, you should set a keyframe with
the completed model before you make any changes to the model’s
arrangement, in case you want to return to the original state.

For this animation, we are going to show the model of the teakettle coming
together. Because we have the completed model already, we will make our
starting model the last frame of the animation, and build the animation to
frame O by taking the kettle apart.

To set keyframes

1 Choose Animation > Keyframe > Set keyframe r to open the Set Keyframe
Options box.

2 Ensure that Frame is set to Current.
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:‘_Set Keyframe Options
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Click Save to close the options box.
Choose Pick > Nothing to deselect all items.

Move the frame indicator in the scrub bar to frame 60, the last frame of
the animation sequence.

In the Back view, dolly out and track to the right a bit, pick the bird that
sits on the spout of the teakettle.
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7 Choose Animation > Keyframe > Set keyframe to create a keyframe for
the bird at its current position.

This marks the last frame of the animation sequence with the model
intact.

8 Choose Pick > Nothing to deselect all items.

9 Move the frame indicator in the scrub bar to frame o, the first frame of
the animation sequence.

10 Choose Transform > Move.

11 Drag the mouse to move the bird to a location similar to the image below.
The bird should be in line with the teakettle’s base, along the Y-axis.

%

12 Choose Animation > Keyframe > Set keyframe to create a keyframe for
the bird at its current position.

Frame 0 is then set as the first frame of the animation.
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Playing the animation

Procedure for playing the animation.
To play the animation

1 Click the Play button in the time slider to play the animation.
[ oo B[ 1o [ 30.zon fes
M4 |« J44 <d B P be b ,,]JI

2 Click the Stop button in the time slider, or click anywhere in the Left
view, to stop the animation.

Start 0.00 |
End enoo J01 1 |51 || 19

3 Click the frame indicator and drag the mouse back and forth to
interactively play the animation.

Drag the frame indicator

| |
Jor v 0se Ty Tl 200 25

About the animation

When an animation sequence begins to play, it begins at the starting frame
number entered into the time slider. In your sequence the animation, also
begins at the point of the first keyframe, frame 0. Through the course of the
animation sequence, the bird moves from its point of origin to the point
specified by the second keyframe. AliasStudio has created all of the in-between
points for this animation.

Based on 30 fps, this animation is comprised of 60 frames of individually
rendered pictures.

1 Save your work in the wire sub-directory of the Lessons directory. Name
your file myanim.wire.

For information on creating the Lessons project or saving your work, see
Saving your work on page 99.
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Editing the animation curve tangents

Changing the animation via the Action Window.

About the Action Window

The Action Window offers a graphical description of your animation. It charts
parameters, such as translation, rotation, scale, and visibility against time,
which is measured in frames. The result of this mapping is a set of animation
curves that describe how various parameters will animate.

In the Action Window, you can see keyframes and the interpolated curves
between the keyframes.

P Action Windove =100 x|
LstMode Edit CurweTook Pk Xform Wiews DispTook ActonTools TangentTyps Preferences
3 : |vﬂ.|e

The horizontal axis represents time and the vertical axis represents the
parameter's value. Each keyframe is indicated by a small red dot.

The parameter names are listed along the left side of the window.
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You can pick keyframes and change the “in-betweening” motion of the
animation curve. As a result, you can make objects speed up or slow down by
changing the shape of the animation curve. You can also add, remove, or edit
keyframes to refine the animation or action curve.

When working with animation curves in the action window, there are several
tangent types that can be used to affect the look of an animation.

Below are the tangency options that let you control the motion between
frames.

Tangency Type

Smooth

A smooth transition is made between the
keyframe before and the keyframe after
the selected keyframe. Its tangents are co-
linear (that is, they are both at the same
angle). This ensures that there is no jerki-
ness at the keyframe. The angle of the
tangents is a weighted average of the
slopes between the two keyframes on
either side of the new keyframe. Setting a
keyframe to Smooth sets the tangent type
of the in- and out-tangent of the keyframe
to smooth.
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Tangency Type

Linear seg in

The action is in a straight line between the
previous keyframe and the selected key-
frame. The out-tangent of the previous
keyframe and the in-tangent of the selec-
ted keyframe lie along this straight line.
Setting the tangent type of a keyframe to
Linear seg in changes the in-tangent type
of the picked keyframe to linear and the
out-tangent type of the previous keyframe
to linear.

Linear seg out

The action is in a straight line between the
selected keyframe and its next keyframe.
The out-tangent of the selected keyframe
and the in-tangent of its next keyframe lie
along this straight line. Setting the tangent
type of a keyframe to Linear seg out
changes the out-tangent type of the picked
keyframe to linear and the in-tangent type
of the next keyframe to linear.

VD

Slow seg in K

The movement slows as it enters the key-
frame. Setting the tangent type of a key-

frame to Slow seg in changes its in-tangent
type to slow and the out-tangent type of

the previous keyframe to fast.
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Tangency Type

Slow seg out

The movement is slower at the beginning
of the curve segment following the key-
frame. Setting the tangent type of a key-
frame to Slow seg out changes its out-
tangent type to slow and the in-tangent
type of the next keyframe to fast.

Fast seg in

The movement is faster going into the se-
lected keyframe. For example, a car accel-
erating. Setting the tangent type of a key-
frame to Fast seg in changes the in-tangent
type of the picked keyframe to fast and the
out-tangent type of the previous keyframe
to slow.

Fast seg out

The movement is faster going out of the
selected keyframe, as in the example of
throwing a ball. Setting the tangent type
of a keyframe to Fast seg out changes the
out-tangent type of the picked keyframe
to fast and the in-tangent type of the next
keyframe to slow.

In/Out

The movement eases out of the new key-
frame, and eases in to the next keyframe.
Setting the tangent type of a keyframe to
In/Out changes the out-tangent type of
the picked keyframe and the in-tangent
type of the next keyframe to in-out.
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Tangency Type

Flat Il;-se\
Y

The in- and out-tangents of the new key-
frame are horizontal (that is, with a slope
of 0). Setting the tangent type of a key-

frame to Flat changes the in- and out-tan-
gent types of the picked keyframe to flat.

4

Step

The out-tangent of the new keyframe is
flat. The curve segment is also flat (horizont-
al) until the next keyframe, at which point
it jumps up or down to the value of that
keyframe. The step tangent type is useful
for animating Boolean (ON/OFF) values
such as node visibility or the presence/ab-
sence of a light's shadows. A value larger
than 0.5 means ON, and less than 0.5
means OFF. Setting the tangent type of a
keyframe to Step changes the out-tangent
type of the keyframe to step. If a keyframe's
out-tangent type is Step, then the in-tan-
gent type of the next keyframe is ignored.

Fixed

The tangents of the selected keyframes
become fixed at their current angles. A
tangent type that is Fixed means the value
of the angles does not change unless you
explicitly modify the tangent. This can be
useful if you set a tangent to a certain
angle which you would like to maintain
even if the keyframe or the segments
around the keyframe are modified.
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To edit the animation in the Action Window

1 With the bird selected, choose Animation > Editors > Action window to
open the Action Window.

2 Choose Views > Look at in the Action Window menu for a better view
of the animation curves.

3 Click each of the parameter names to select and highlight its
corresponding curve.

NOTE The Y and Z animation curves are diagonal while the others are
horizontal. When an animation curve is horizontal, its parameter does not
change over time. Because the bird moves upwards on the Z-axis and moves
along the Y-axis, both the Y and Z animation curves are diagonal.

4 Click the parameter name (Y Tra) to select it. This is the Y-Translation
parameter that shows how the object moves along the Y-axis. The curve
is a straight line because the bird moves at a constant speed. The
parameter and the diagonal line are highlighted.

0.00
O

5 Choose TangentType > Slow seg out from the Action Window menu to
change the tangent of the curve at each keyframe. This changes the bird's
speed at the beginning of the animation.

The diagonal line becomes curved, so the bird will begin moving very
slowly and gradually increase its speed until the end of the animation,
when it will suddenly stop.
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6 Close the Action Window to close it.

7 Click the Play button in the time slider to review the changes to the
animation.

8 Click the Stop button to end the animation.

Adding keyframes
Adding keyframes to the animation to change the movement of the bird.
To add keyframes to an animation

1 Choose Pick > Nothing to deselect all items.
2 Move the frame indicator in the scrub bar to frame 55.

3 In the Back view, move the bird to a location above and to the left of the
spout.
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4 Choose Animation > Keyframe > Set keyframe to create a keyframe for

the bird at its current location.

Click the Play button in the time slider to review the change to the
animation.

NOTE Before adding the third keyframe, the bird moved directly to the spout.
By adding the third keyframe, the bird now arcs into the spout.

6 Click the Stop button in the time slider to end the animation.

Editing the animation curves

Additional techniques for editing animation curves.

To use keyframes to edit animation curves

1

With the bird selected, choose Animation > Editors > Action window to
open the Action Window.

From the Action Window menu, choose Pick > Nothing to deselect all
curves.

From the Action Window menu, choose Pick > Keyframes.

Drag a pick box around all keyframes to select them. Selected keyframes
are highlighted in yellow.
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5 Choose Tangent Type > Linear seg in from the Action Window menu to
change the tangent of each curve at each keyframe.

The smooth curves are now straight line segments that will make the
bird’s motion abruptly change at each point.

6 Click the top left corner of the Action Window to close it.

7 Play the animation and review the changes.

Moving keyframes on an animation curve

Editing the animation curve by moving keyframes.
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To move keyframes on an animation curve

1 With the bird selected, choose Animation > Editors > Action window to
open the Action Window.

2 From the Action Window menu, choose Pick > Nothing to deselect the
curves.

3 From the Action Window menu, choose Pick > Keyframes.

4 Click the second keyframe of the Z-Translate curve to select it (keyframe
55).

5 From the Action Window menu, choose Transform > Move.

6 Using the right mouse button, drag the keyframe along the horizontal axis
from approximately 3.6 to 10.0.

7 Close the Action Window.
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8 Play the animation and review the changes.

9 Save your work in the Lessons project as myanim2.wire.

Part 2: animating along a motion path

Setting a curve to become the motion path for an object.

g

Part 2 of the tutorial.

About motion paths

A motion path is a NURBS curve that represents the path along which you
can animate an object. For this tutorial, a motion path is used to animate the
knob.

You must follow two simple rules when using motion paths:

B Place the object and its pivot point at the origin because it is the pivot
point that follows the motion path. In this tutorial, you will not have to
set the pivot point, but you should be aware of how to prepare an object
for an association with a motion path. Move the object to the origin, then
group the object. This places a new pivot point at the origin for the new
grouped object, which controls the amount of offset from the motion path.
Or, you could just move the pivot point of the new group to the object.

B Set the direction of the motion path curve. Objects follow the direction
of the curve. If the animation seems to go backward, reverse the motion
path direction using Curve Edit > Reverse Curve.

To animate along a motion path

1 Click the Knob layer to make it active. The layer background color should
change to dark yellow.

Kniob g [
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Click the Motion Path layer and hold down the mouse button to select
Visible from the menu. A curve will become visible.

Make sure nothing is picked.

In the Perspective view with the Knob layer active, use the Pick > Object
tool to select the knob that sits on top of the teakettle’s lid.

The curve to be used as the motion path

Choose Animation > Tools > Set motion r to open the Set Motion Options
box.

In the Set Motion Options box, set Start Frame to 0 and End Frame to
60.
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B !5&!: Motion Options

Skart Frame I 0.00

End Frame I 60,00

7 Click Go.

8 With the knob now highlighted in purple, click the curve to set it as the
motion path.

9 Play the animation to review the changes. The knob moves along the
motion path at a constant speed while the bird flies in from off screen.

Editing the timing curve
An overview of the timing curve and editing procedures.

About the timing curve

With the knob selected, open the Action Window and use View > Look at to
see the animation curves associated with the motion path animation.
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The animation curves are much more complex than the previous animation.
When an object is animated along a motion path, AliasStudio creates a
keyframe for each frame of the animation. In the above image, the keyframes
are represented by red dots.

There is one diagonal line that stands out on the graph - this is the timing
curve. The timing curve is straight and diagonal because it represents the
constant rate of speed the object travels in the animation sequence.
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To edit an animation sequence that employs a motion path, modify the CVs
associated with the motion path curve, or change the timing curve. As a general
rule, do not edit animation curves that result from a motion path as they can
be somewhat complex.

To edit a timing frame

1
2

Choose Pick > Keyframes from the Action Window menu.

Select the end keyframe on the timing curve, as highlighted in the image
above.

Choose Transform > Move from the Action Window menu and move
the keyframe from its current location to 600 on the vertical axis.

Choose Tangent Type > Slow seg in from the Action Window menu. The
changes should resemble the image below.
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5 Close the Action Window.

6 If not already enabled, turn on the shading for the model by using the
WindowDisplay > Hardware Shade menu item.

7 Play the animation and review the changes. The knob moves along the
motion path with a varied speed.

TIP To see the animation without the presence of the motion path, use the
Motion Path layer menu to make the curve invisible.

8 Save your work as myanim3.wire.

Part 3: editing a motion path

Modifying CVs to edit the knob’s motion path curve.

Having reviewed the animation, you will have noticed that the knob collides
with the bird. We will fix this by editing the motion path.

Part 3: editing a motion path | 759



g

Part 3 of the tutorial.
To edit a motion path

1 Choose Pick > Nothing to deselect all objects.

2 Choose Pick > Object and click the motion path curve to select it.

3 Choose ObjectDisplay > Control r to open the Display Control window.
4

Set Scope to ACTIVE and make sure that only the Hulls and CVs options
are enabled, then click Go.

I=TEY
SCope ACTIVE

Al _on | oFF |

s v

Hulls |7

Edit Points

Surface Iso

Key Paints

Blend Points

S S S

Exit T

5 Click Exit to close the Display Control window.
The Hulls and CVs associated with the motion path curve are now visible.
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CY Mation path curve

6 Choose Pick > Point types > CV.

7 Choose Transform > Move, then pick the CV in the Top view as
highlighted in the image below.

Pick this CV

8 Drag the right mouse button down to position the CV in a location similar
to the image below.
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Move the selected CV
to this location

9 Use these same techniques to move the bottom three CVs into positions
similar to the image below.

762 | Chapter 12 Introduction to animating



Move the bottom three CV's to these locations

10 Choose Pick > Nothing to deselect all objects.

11 Play the animation to review the changes. The collision between the
knob and bird has been resolved.

12 Save your work as myanimd.wire.

Part 4: animating the camera

Animating the view of the scene by creating keyframes for the view’s camera.
Cameras can also be animated along motion paths.

Part 4 of the tutorial.
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To animate the camera

1 Maximize the Perspective view.

2 Tumble, track, and dolly the camera’s view to get a better view of the
motion path curve and the model.

3 In the Perspective view’s window title bar, click the camera icon to select
the view’s camera.

PEREDE

Click the camera icon

A green dot, indicating the camera’s pivot point, appears in the view.

4 Tumble, track, and dolly to adjust the view for the beginning of the
animation. The beginning camera position should resemble the image
below.
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The first frame

5 Create a keyframe at frame o for the camera at this position.

6 Adjust the view for the middle of the animation to resemble the image
below.

The middle frame

7 Create a keyframe at frame 30 for the camera at this position.

8 Adjust the view for the end of the animation to resemble the image below.
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The end frame

9 Create a keyframe at frame 60 for the camera at this position.
10 Play the animation to review your changes.

11 Save your work as myanim5.wire.

Turntable animation

An overview of turntable animation.

Turntable animation is used for the presentation of completed models. Similar
to a record player, turntable animation rotates the model in a circular fashion.

To set up a turntable animation

1 Open the file called animation basics turntable.wire, located in the
wire sub-directory of the courseware directory.

NOTE For information on how to open a file, see Opening the tutorial file
in a Windows environment.

2 A dialog box appears, asking if you want to delete all objects, shaders,
views, and actions. Click Yes.

3 If your construction tolerance values differ from those in the
animation basics turntable.wire file, you will be prompted by a
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Construction Options dialog box. Click Accept New Settings to use the
construction tolerances in the animation basics turntable.wire file.

4 Choose Animation > Turntable from the menu and set the following:

Set... To...

Axis z

Direction Positive
Rotate About Average
Frames / Rev 60.00

™ rurntable Options x|

@ Turntable

Axis
o Y
Direction
. Negative
Rotate About
. ran

~.» Center of Bounding Box

FramesjRew I &0.00 I—J
Create SDLFile |

Reset ‘ Save ‘ Exit | Go ‘

5 Click Go.

NOTE Watch how the active objects rotate about a center that is the
calculated average point of each object's rotation pivot point.
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Stop the animation.

Choose Animation > Turntable r to open the Turntable Options box.

In the Turntable Options box, set Rotate About to Origin.

O 0 N o

Click Go.

NOTE Watch how the active objects rotate about the point of origin 0, 0, 0
(where the three world axes cross).
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10 Stop the animation.

11 Save your work as myanimé.wire.

Conclusion

Congratulations! You have completed this tutorial.
You now know how to:

set and move keyframes

use the time slider to play back animation
edit animation in the Action Window

add keyframes to the middle of an animation
set a motion path

animate a camera

create a turntable animation
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Test your grasp of the material.

Now that you have animated the teakettle, try this quick quiz to see how
much material you have retained.
1 Keyframe animation is...

(a) Having the objects in the scene rotate around the X, Y, or Z axis over
the course of the animation.

(b) Creating a curve in a scene, along which an object or camera will
move over the course of an animation.

(c) Setting placement, scale, rotation, and other aspects of objects at
particular times, and having the AliasStudio software determine the scale,
rotation, placement, etc. for all other times in the animation sequence.

(d) All of the above.

(e) None of the above.

2 Turntable animation is...

(a) Having the objects in the scene rotate around the X, Y, or Z axis over
the course of the animation.

(b) Creating a curve in a scene, along which an object or camera will
move over the course of an animation.

(c) Setting placement, scale, rotation, and other aspects of objects at
particular times, and having the AliasStudio software determine the scale,
rotation, placement, etc. for all other times in the animation sequence.

(d) All of the above.

(e) None of the above.

3 Motion path animation is...

(a) Having the objects in the scene rotate around the X, Y, or Z axis over
the course of the animation.

(b) Creating a curve in a scene, along which an object or camera will
move over the course of an animation.

(c) Setting placement, scale, rotation, and other aspects of objects at
particular times, and having the AliasStudio software determine the scale,
rotation, placement, etc. for all other times in the animation sequence.

(d) All of the above.

(e) None of the above.
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4 What is the standard frame rate for NTSC video?

5 In the Action Window, you can modify tangents of animation curves at
certain points. What are the points?

On Your Own

Experiments of your own design.
Now that you have experimented with keyframe, turntable, and motion path
animation, try animating some of the other objects you have created.

For example, you can

B Create a turntable animation of the PDA.
B Use keyframe animation to assemble the Reitveld chair.

B Plot a motion path to fly the shampoo bottle through the scene.

Quiz Answers

Answers to the skill-testing questions found in the animation basics tutorial.

1 (0). Setting placement, scale, rotation, and other aspects of objects at
particular times, and having the AliasStudio software determine the scale,
rotation, placement, etc. for all other times in the animation sequence.

2 (a). Having the objects in the scene rotate around the X, Y, or Z axis over
the course of the animation.

3 (b). Creating a curve in a scene, along which an object or camera will move
over the course of an animation.

4 The standard frame rate for NTSC video is 30 frames per second (fps).
5 The points at which you modify animation curve tangents are keyframes.

How did you do on this quiz? If you got all of the answers correct,
congratulations! If you missed any of the answers, you may want to review
this tutorial before moving on.
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More animation
techniques

Learning objectives

In this tutorial, you will animate the teakettle that was modeled in a previous tutorial. We
will examine some of the more advanced concepts of presentation animation, like more
complicated animations, animating the environment, and rendering the animation.

You will learn how to:

B set an object’s pivot point for tighter rotation
B review and edit animations for object collisions

B use the SBD window
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B use the Shaders window to set Environment shaders
B edit Environment shaders

B use and edit grid textures

B animate the Environment shader

B use the Animation > Show > View frame menu item
B use the Parameter Control window to set attributes
B render an animation

|

use FCheck to view the rendered animation (in Windows)

New menu items used in this tutorial

Animation > Editors > Param control
Animation > Show > FCheck

Animation > Show > View frame

Render > Globals

4§

Part 1 of the tutorial.
To open the tutorial file

1 Open the file called more animation.wire, located in the wire sub-directory of the
Courseware directory.

NOTE For information on how to open a file, see the Animation Basics tutorial.

2 The file is displayed.
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Part |: Creating an exploded view animation

Where to begin the animation.

In this tutorial, you will animate some of the teakettle’s components to create
a more complicated animation. Given that the teakettle provided in this
tutorial is a complete model, you will begin the animation by capturing its
completed state, and then pull apart some of the model’s components for the
animation. These same principles can be used to create complex exploded
view animations.

The images below represent the basic flow of the animation that you will build
in this tutorial.
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Preparing for the animation
Setting the parameters of the animation environment.
To prepare the animation environment.

1 Choose Pick > Nothing to deselect all objects.

2 Choose Animation > Keyframe > Set keyframe r to open the Set Keyframe
Options box.
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3 Ensure that Frame is set to Current.

:‘_5et Keyframe Options

.'
ol

o

4 Click Save and exit the options box.

5 Set the following values in the time slider:

Set... To...

Start 0

End 100

fps 30
The SBD window

A summary on how to incorporate the SBD window into the project workflow.
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The SBD window

Before you move further into the tutorial, let’s look at another way of selecting
objects. SBD stands for Scene Block Diagram, and represents all elements of
the scene as blocks or rectangles. The SBD window contains a diagram showing
the hierarchical structure of the objects and data in a scene. You can pick
objects in the SBD window, and track and dolly its view of the graph. The
SBD can be useful to see the relationship between the model components,
and for isolating members of a group.

To open the SBD window

1 Choose Pick Objects from the Decoration layer menu. This will help to
isolate the group in the SBD window.

2 Choose Utilities > SBD > Open SBD Window.

3 Track and dolly in the SBD window to find the highlighted rectangle that
represents the knob on the lid (“decoration”).

4 With the knob group still selected, choose Windows > Information >
Information window to open a window that enables you to rename
objects.

5 In the Information Window, change the name to Lid_knob.
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Lid_knob

Dt

Knobsphere round_group#3

ol

T Lid_knob +++ A
Name [ Lid_knob
ter [+
Layer Name | Decoration |
+ Transform info
+ Pivot infa
% + Bounding box info
1=l

Note how the rectangle that represents the Lid_knob group in the SBD
window updates the name as well.

Finding and setting the names of objects is useful, and can help you
clearly identify specific parts of an object or scene.

To pick an object by name

1 Choose Pick > Nothing to deselect all items.

2 Choose Pick > Object.
3 In the prompt line, type Lid_knob, then press Enter.

Enter name of item ko pick, ) unpick;Lid_knob_ I

You can either use the above method to isolate an object in a group, or
you can use the SBD window.
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Lid_knob

Deco

node#11858 Knobsphere

Setting the initial keyframe
Moving the teakettle components to their ending positions.
To set the end keyframe

1 Choose Pick > Nothing to deselect all items.

2 Move the frame indicator in the scrub bar to frame 100.

o
|Jad It Jdd

3 Choose Pick > Object and draw a pick box around all of the objects in
the scene.
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4 Choose Animation > Keyframe > Set keyframe from the menu. This sets
the final location of the teakettle components at keyframe 100.

To set the position of the knob

1 Choose Pick > Nothing to deselect all items.

2 Move the frame indicator in the scrub bar to frame 0.

Trame indicator setto 0.

3 In the Back view, click the knob that sits atop the teakettle’s lid.

4 In the Left view with the knob selected, use Transform > Move to drag
the knob to the far left of the teakettle.
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5 Choose Animation > Keyframe > Set keyframe from the menu. This sets
the initial location of the knob at keyframe 0.

To rotate the grip

1 Choose Pick > Nothing to deselect all items.
2 Click the title bar of the Back view to make it active.

3 Right-click on the Grip_Handle layer in the Layer Bar and choose Pick
Objects from the menu.

The handle and grip of the teakettle are selected similar to the image
below.

The grip is & group of ohjects.

The pivot point far the grip rests at the origin.
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4 Choose Transform > Local > Set pivot.

5 Move the pivot point to the location shown in the image below.

Mowe the pivot point to this location. By mowing the pivot point
to this location, you'll have a tighter turning radius for the next
step.

6 Choose the Transform > Rotate tool.

7 In the Left view, use the middle mouse button to rotate the grip and handle
to a position similar to the image below.
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Rotate the grip and handle to this angle.

Note the pivot point's location and how the
object rotates in a tighter circle.

TIP Avoid rotating the grip any further than what is shown above. The handle
will lose the visual connection with the teakettle body.

8 Choose Animation > Keyframe > Set keyframe from the menu. This sets
the initial location of the grip at keyframe O.

To move the bird

1 Choose Pick > Nothing to deselect all items.
2 Choose Pick > Object and in the Back view pick the bird.
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3 Choose Transform > Move and drag the bird so that it rests on top of the
lid where the knob was.

The teakettle components should be arranged to resemble the image
above.

4 Choose Animation > Keyframe > Set keyframe from the menu. This sets
the initial location of the bird at keyframe O.
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To move the decorative balls

1 Choose Pick > Nothing to deselect all items.
2 Make the Left view active.

3 Choose Pick > Object, then type Dec_Balls in the prompt line. Press Enter.
The decorative balls should be highlighted as shown in the image below.

The pivot point far the grouped decorative balls.

4 Choose Transform > Move and move the objects to the location shown
in the image below.

5 Choose Transform > Local > Set pivot and move the decorative balls’
pivot point to the position shown in the image below.
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It is important to note that the animation created for the Dec_Balls group
applies only to that group. The group consists of two components,
Dec_Balll and Dec_Ball2. As separate objects, these components do not
have any assigned animation.

This hierarchical relationship is best demonstrated in the SBD window.
After setting the animation for the Dec_Balls group, note how the
rectangle representing the Dec_Balls group changes to a slanted
parallelogram. The rectangles representing Dec_Balll and Dec_Ball2
remain the same.

6 Choose Transform > Rotate and enter the values 0,0,360 into the prompt
bar. Then press Enter.

<::=|Enter ROTATION amounks (x, v, 2) (AES)H0,0,360_
T

By grouping these two objects and rotating the group, they will rotate
about the group’s pivot point, instead of about their own centers.

7 Choose Animation > Keyframe > Set keyframefrom the menu. This sets
the initial location of the decorative balls at keyframe O.

Reviewing the animation

Reviewing the animation to find collisions.
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To review the animation

1 Play the animation and watch the objects move.
2 In the Perspective view, turn on WindowDisplay > Hardware Shade.

3 Stop the animation and manually move the frame indicator in the scrub
bar for greater control over the animation sequence.

4 Tumble, track, and dolly the camera to different camera positions for a
closer examination of the animation.

By now, you should have noticed that as the bird moves, it passes through
the spout. This needs to be corrected.

YWhen reviewing the animation, watch for
collisions between objects. Play the animation
from warious angles to ensure a clean
SEQUENCE.

Editing the animation

Fix the collision by adding keyframes.
To set additional keyframes

1 Choose Pick > Nothing to deselect all items.
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2 Move the frame indicator in the scrub bar to frame 60.

3 In the Back view, choose Pick > Object and select the bird.

4 Choose Transform > Move and drag the bird to a position that matches
the image below.

5 Choose Animation > Keyframe > Set keyframe from the menu.

6 Play the animation to review the changes. The bird should now arc into
the spout.

7 If it still collides with the edge, go to frame 60, move the bird a little
higher, and choose Animation > Keyframe > Set keyframe again. You will
be asked if you want to overwrite 9 keyframes in the animation. Click
Yes.

8 Save your work in the Lessons project as more _anim2.wire.

Part 2: animating shaders

A walkthrough of how to animate a component other than the model.
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In this section of the tutorial, you will create an environment shader using
the sky procedure. The purpose of this exercise is to create a component of
the scene, other than the model, that can be animated. This procedure creates
a horizon and lets you set the environmental sky and floor.

g

Part 2 of the tutorial.
To use the sky procedure for the environment

1 Ensure that no objects are picked, either by choosing Pick > Nothing or
by using the marking menu for the left mouse button.

2 Choose Render > Multi-lister > Shaders to see shaders in the multi-lister.

3 In the Multi-lister window, double-click the Environment shader.

When you initially open the Multi-lister
window, the Environment shader is black.

DefaultShader

Metal Chrome#?2

The Environment editor opens.

In the Background section of the Environment editor, click the Map...
button associated with the Color parameter.
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Click the Map... button

o [=[ 3

Color n| \MED

% Pix File Backdrop

% Background

Backdrop I I Browse
Sequence O CFF
+ Fog

¥ ShaderGlow

+ Photo EFfects

ﬂ + Master Lighting Control

J + Texture Procedures

fl + Texturable Values
5

Browse

Expand this section

4 In the Texture Procedures section, expand the Environments section and
click the Sky button.
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SSenvionment R =l

% Texture Procedures
¥ Surface
& Environments Expand the
Erwironments
. Ball ﬁ Chraome section
. Cube . Sphere
r— .
- Sky Click the Sky
buttan
+ Solid

él + Texturable Values

Erowse

This produces a new map, SkyTexture#2, in the Shaders window.

The Environment shader changes to dark
gray. The arrow shows the relationship with

the Sky Texture.
The default sky

i5 shown in the
Sky Texture
map.

Environment | SkyTexture#?2

DefaultShader . Metal

The Shaders window becomes the SkyTexture#2 editor. The default sky
is in the background.
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[N renwresz =TT

ﬂ Name [ shyTextures: o OFF

F  Sky Environment Parameters
Total bright, [ 1000 [ |
Sun Parameters

fermospheric Settings

*

-

&

Floor Parameters

Has floor [ oN  OFF
Foortoure [ES [ ..
+ Cloud Parameters
+ Calculation Qualiy
-+ Color Balance

—![ ¥ 30 Placement

=] + Effects

5 Inthe SkyTexture editor, expand the Sky Environment Parameters section
and set Total_bright to 0.700, and in the Sun Parameters section set
Elevation to 90.000.
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:'-_SkyTexture#Z =10 x|

* [ Stetwerz | on o

% Sky Environment Parameters

Total bright. [ o700 | |

F  sun Parameters

N

- [
Elevation [ oo.00n | |

[1as000 |

[ 1o |

% Floor Parameters

-+ [

6 In the Floor Parameters section, click the Map... button associated with
Floor texture.

After clicking the Floor texture Map... button the SkyTexture color map
opens.
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1=

& Texture Procedures

+ Surface

+ Enviranments

% Solid

. Projection
. sCloud
D sMarble

. Leather

shood

Expand the
Solid section

iaranite

Walume

)
EI + Texturable Yalues

Browse

7 In the map window, go to the Solid section under Texture Procedures,
and click the Leather button.

The Leather#2 icon appears in the Multi-lister and is assigned as the floor
of the environment.
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The Environment shader has heen
updated to reflect the changes previously
applied.

Environment SkyTexture#2 lﬁ

Leather#2 DefaultShader

The Sky Texture#2 icon updates to reflect
the addition of the Leather shader. The
arrows confirms the addition.

At this point, you can close the editor window.

To add clouds to the sky texture

1 In the Multi-lister window, click SkyTexture#2 to change the editor.

2 Inthe Cloud Parameters section, click the Map... button beside the cloud
texture to choose a cloud map.

796 | Chapter 13 More animation techniques



gl

et SkyTexturef2

Name | Sifestresz

& Sky Environmenk Parameters

Total bright, [ o700 | |

& SUn Parametess

& Armospheric Settings

+ Fo

of Paramesters

g

% Coud Parameters

Cloud texture | { not mapped § Iﬁ%
Clowd_bright. -‘1 |

sunset bright, [+ | 1]
Dersity [ 1000 [ |
Thresheld | 0500 | |
Power [ 1,000 | 1]
akituds | 0zon0 [ |
|

Halo_size | 20,000

+ Calculation Cuualiy

+ Colar B

slance

+ 3D Placennent

+ EFfects
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M=

% Texture Procedures

<+ Surface

. file E Bulge
E Checker
Fractal™ % EEE Grid
| —_—
Iounkain
M
. Rarnp . Stencil
- Wakter

-¥ Environments

Clath

Moise

+ Solid

&
EI + Texturable Yalues

Browse

The Fractal#2 icon appears in the Shaders window. This is used to calculate
the cloud coverage.

4 In the Multi-lister window, click SkyTexture#2, to change the editor back
to the SkyTexture#2 editor.

5 Inthe Cloud Parameters section, set the Density to 2.0, to create a denser
cloud formation.
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:‘_SkyTexture#Z O] x|

- [ syreawsrz | on ofF

& Sky Environment Parameters
0,700 !

& Cloud Parameters

Density I 2,000

[ 1o [ ]
[ oz [
[ zoom [

6 Close the editor windows.

To set the environment’s placement

1 In the Multi-lister window, click the texture placement icon in the bottom
right corner of the sky texture.
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Environment

Leather#2 . Fractal#2

A green texture grid and directional arrow appears in the modeling
window representing the environment.

2 Choose Pick > Nothing to deselect all items.
3 Choose Pick > Object and click the green texture grid to make it active.

4 When active, the green texture grid turns yellow.
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Mote how the texture grid's pivot
point rests at the origin.

The horizontal yellow line
represents the highlighted texture
grid. The texture grid is not flush
with the bottom of the tea kettle.
The resulting animation would hawe
a hovering tea kettle.

5 In the Left view, select the Transform > Move tool and move the selected
texture grid from its current location to just under the kettle.
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The ground now rmeets the
tea kettle.

6 In the Multi-lister window, click the texture placement icon at the bottom
right corner of the SkyTexture#2 map to make the texture grid invisible.

Animating the environment shader

Setting keyframes does not only apply to animating objects. In AliasStudio,
you can set keyframes for shaders, textures, lights, and even the environment.
In the following procedures, you will animate the clouds by animating the
offset parameter in the fractal map. Shader attributes are animated by setting
keyframes for the appropriate parameters.

To prepare to set keyframes

1 Choose Pick > Nothing to deselect all items.

2 In the Multi-lister window, double-click the Fractal#2 icon to open the
fractal texture.
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[——

Enwvironment SkyTexture#2

Leather#?2 Fractal#? |@

Open the Fractal texture by double-
clicking the Fractal#2 icon.

3 Choose Animation > Show > View frame.

4 Type o0 at the prompt line and press Enter.
| ﬁ}!Enter Frame or list of Frames ko views0_ l

Since you want to set the first keyframe at this frame, you should set it
as the current frame.

5 Choose Animation > Editors > Param control to open the Parameter
Control window.

~loix

GLOBAL apely | [#]
LOGAL

Fractal#z

@ ‘indow, Persp

1
1

6 In the Parameter Control window, click the empty box beside Fractal#2
to turn on the fractal attributes for animation. If you click the down arrow
associated with Fractal#2, you can see that all of the attributes are now
turned on.
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:‘_ Parameter Control

NOTE The Parameter Control window lets you choose parameters to animate.
If you already knew which fractal parameters you wanted to animate, you
could have clicked them individually.

To set a keyframe for local parameters

1 Make sure that the Fractal#2 icon is selected in the Shaders window.
2 Choose Animation > Keyframe > Set keyframe r to modify the settings.

3 In the Set Keyframes Options box, set Parameters to Local.
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:'-Set Keyframe Dptions

=-
e

o

4 Click Go. Keyframes are set for frame 0.

NOTE When you restrict the Parameters Controls using the animatable
parameters, you must use Local to set keyframes. (This uses the local
parameter settings of Fractal#2 instead of all of them).

To set a second keyframe

1 Choose Animation > Show > View frame from the menu bar.
2 Type 100 at the prompt line and press Enter.

3 Inthe Fractal#2 editor, go to the Surface Placement section and set Voffset
to 0.1.
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M rractals2 = 0] x|

« [ Facarz | on ofF

[ oom
[ 1o |
[ o [
[ oom

voffset | 0.100

T

OFF

T

By moving the Fractal map that generates the clouds, the clouds appear
to move across the sky.

4 Choose Animation > Keyframe > Set keyframe A second keyframe is set
for frame 100.

To turn off the fractal attribute parameters
1 In the Parameter Control window, turn off the fractal attributes for

animation. This prevents you from unknowingly entering unwanted
keyframes. Begin by clicking the white box associated with Fractal#2.
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GLOBAL apply | ]
LOAL

“Windove,Persp

Fractaht2 =

active E l
amplitude E
threshold E

ratio E
lesvel_rnin E
level_max E
animated /7

time E

amult o7

aaffset E
blurmult /A7
bluroffset E
rotate E
urepeat E
vrepeat E
uaffset E
waffset E
mirrar E
stagoer E
chard_length E
Uroverans E
wCoverage E
utranslate E
wirandlate 7

uwrap E

wnrap o

i ert E

Click the Fractal#2 white box again to turn off all of the attributes.
Close the Multi-lister window.

Close the Texture editor.

w©n A W N

Close the Parameter Control window.

Rendering the animation

How to render and play back the animation.

Rendering an animation is very similar to rendering a still image, except that
you render a sequence of images. To create this sequence, you must tell
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AliasStudio that you want to render the animation, as opposed to a still image
of the currently viewed frame.

To set the rendering parameters

1 Choose Render > Globals to open its window.

2 In the Render Globals window, set the following:

Set... To...

Render Globals

Animation On (check mark)
Global Quality Level HIGH

Animation Output Filename Extensions

Frame padding 2

Image File Output

X Resolution 250

Y Resolution 250
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:‘. Render Globals

Animation | v

-
Animation Output Filename Extensions
-

NOTE For your final render, set the resolution in the Predefined Resolutions
section to NTSC or PAL, depending on which standard is used in your country.

3 Close the Render Globals window.

4 Maximize the Perspective view, and tumble and dolly to a view similar
to this:
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To raycast the animation

1 Choose Render > Render.
AliasStudio asks for a filename.

2 Type Teakettle as the filename.

3 Navigate to the pix sub-directory in the Lessons project, then click Save.

The resulting animation files will be named Teakettle.l, Teakettle.2,
and so on.

After the raycast starts, the rendering may take a few minutes.

You can monitor the rendering progress in the Render Monitor that
appears at the bottom left corner of your screen.

:Render Monitor I =] S

The current The percentage
frarme number. rendered for this
frame.
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About viewing the rendered animation

You can view your animations with FCheck if you are on a Windows platform,
which loads in the animation sequence and plays it back at a specified frame
rate.

To view the animation using FCheck (Windows)

1 After the render has completed, choose Animation > Show > FCheck from
the menu.

The FCheck window opens.

2 In the FCheck window, choose File > Open Animation.

=
File Yiew Help

Open Image. ..

Open Animation. ..

Rewvert

Save Image...
Save Animation. ..

Exit

3 From the Open box, navigate to the Lessons/pix directory, and
double-click the Teakettle.00 file. FCheck will automatically begin
playing the rendered animation.
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i FCheck: TeakettleStatic - 350x350 - 1:1 x|

File ‘iew Help

Conclusion

A review of the topics presented in this tutorial.
Congratulations! You have completed this tutorial.
You now know how to:
set an object’s pivot point for tighter rotation
review and edit animations for object collisions

use the SBD window
edit Environment shaders

use and edit environment texture grids

| |
|
| |
B use the Multi-lister to set Environment shaders
| |
| |
B animate the Environment shader

| |

use Animation > Show > View frame
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B use the Parameter Control window to set attributes
B render an animation

B use FCheck and/or FlipBook to view rendered animations.

Test your grasp of the material.

Now that you have rendered an intricate animation of the teakettle and the
environment, try this quick quiz to see how much material you have retained.

1 In the Set Keyframes Options box, it is best to have Frame set to...
B (a) Prompt

B (b) Current
B (c) Active
|

(d) All

2 True or false. The scrub bar must be set to the desired frame number
before you select and move an object for animation.

B (a) True
m (b) False
3 To produce an environment texture grid, click the...
B (a) Map... button
B (b) Association arrow
B (c) Texture placement icon
|

(d) Texture pivot point

4 True or false. The Parameter Control window lets you choose parameters
to animate.

B (a) True

m (b) False
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5 True or false. When you restrict the Parameter Controls using the
animatable parameters, you must use Local to set keyframes.

m (a) True

m (b) False

On your own

Now that you have experimented with intricate animations involving objects
and the environment they inhabit, try animating some of the other objects
you have created, or change some of the settings suggested in this tutorial.

For example, you can

B Assign a more traditional floor to the environment, such as Rock or Granite

B Create an exploded animation by breaking the teakettle into base
components and have them come together as a completed model

B Animate the environment of other tutorials, such as the shampoo bottle
or vacuum

B Try breaking apart the Dec_Balls group and assigning separate rotations
to the balls

Quiz Answers

Answers to the skill-testing questions found in the advanced animation tutorial.
1 (b). In the Set Keyframes Options box, it is best to have Frame set to Current.

2 (a) True. The scrub bar must be set to the desired frame number before you
select and move an object for animation.

3 (¢) To produce an environment texture grid, click the texture placement
icon.

4 (a) True. The Parameter Control window lets you choose parameters to
animate.

5 (a) True. When you restrict the Parameter Controls using the animatable
parameters, you must use Local to set keyframes.
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How did you do on this quiz? If you got all of the answers correct,
congratulations! If you missed any of the answers, you may want to review
this tutorial before moving on.
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Index

3-point arcs 476
3D model 58,78

changing view 58, 78

A

accurate dimensions in modeling 403
active 725
active window 26
adding 75
bookmarks 75
adding lights to a scene 670
AliasStudio  15-17, 19, 26
help menu 17
interface 17
loggingin 15
splash window 16
startingup 15
troubleshooting during start-up 16
using menus 19, 26
workspace window 16
align tool 526, 529
and continuity 526
and tangent continuity 529
angle 420
draft 420
application 15
startingup 15
arc tangent to curve 412
arcs 475-476
circular 475
three point 476
arranging windows 19, 26
arrow on tool icons 29
assigning objects to construction
layers 227

backgrounds 696
environment shader 696

image 696
birail surface 565
continuity 565
birail tool 539, 541
adjusting continuity after building a
surface 541
continuity and tangency 539
blend surfaces 557
bookmarks 75-77
adding 75,77
removing 77
renaming 76
using 76
bulge texture 720

bump mapping 718, 720, 723
bulge 720
bump textures 718, 723

C

camera move keys 63
camera move mode 59

cameras 58,78
dollying 58
moving 58, 78

tracking 58

tumbling 58
casing, equipment 416
chamfered surface 421
changing 172

surfaces through construction

history 172

changing view 63, 70

Look at tool 63

Viewing Panel 70
chordal surface fillet 319
circle primitive 179

changing options 179
circular arc tool 475
circular fillets 319

between surfaces 319
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click 5
definition 5
closing 21
windows 21
clouds 700, 703
cloud parameters 700
cloud texture 700
in sky texture 700
color channel 655
label mapping 655
components 81
concept design workflows 3
cone 32
constant radius fillet 319
construction history 172, 238, 330
and surface modification 172
deleting 238
construction layers 227
assigning objects 227
construction tolerances 517
continuity 516-517, 526, 529, 539
and birail tool 539
between curves 516
between surfaces 516
curvature 516
implied tangent 517
positional 516
tangent 516
tangent, with Align tool 529
using align 526
control panel 17, 207
increasing spans 207
location 17
control panels 641
visualize 641
coordinate positions 403
coordinates 403
absolute vs relative measure 403
copy objects 449
copying 368
geometry and scaling for
rhythm 368
corner fillet for lines 414
courseware 14
installing 14
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curve with CVs 164
fractal texture 701
new projects in Windows
environment 100
creating lights 661
creating mirrored surfaces 505
current project 88
in Windows environment 88
curvature continuity 516
curve section tool 485
curve snapping 353
curves 164, 167, 206, 375, 444, 466, 516
continuity 516
creating with CVs 164
edit points 206
keypoint 466
modifying by moving CVs 167
offsetting 444
projecting from within Trim surface
tool 375
curves-on-surface 455
customizing 43, 51, 54, 58
hot keys 58
marking menus 51, 54
shelves 43, 51
cutting 457
surfaces 457
CVs 167,175, 248, 257
displaying 175
manipulating to modify curves 167
moving to modify surfaces 248
rotating for surface
modification 257
cylinder 34

D

default draft direction 419
default lights (in tutorial) 661
deleting 238, 724-725
construction history 238
shaders 725
textures 724
design 3
concept design workflows 3



detach tool 535

using to modify surfaces 535
dimensions 407

specifying 407
dimensions, modeling to accurate 403
directional lights 667

adjusting 667
dollying 58
double-click 5

definition 5

draft 416
draft angle 420
drag 5

definition 5
duplicate objects 449

E

edge smoothing 567
with round surfaces 567
edges 435
rounding 435
edges, smoothing multiple 492
edit point curves 206
in tutorial 206
editing 688, 693-694, 704
render globals 688, 693-694
sun in sky texture 704
embossed logo 572
environment 675
setting in hardware shade 675
environments 696, 699, 706
control window 696
shader 696
sky 699, 706
equipment casing 416
extrusion surfaces 217, 341
creating in tutorial 217

F

file browser 100
creating new projects in Windows
environment 100

files 87, 100
opening in Windows
environment 87
saving in Windows
environments 100
fillet 310, 433
surface fillets 433
fillet a corner on two lines 414
fillet surfaces 319
chordal 319
circular 319
flange 416
flange surface 424
flat surfaces 462
floors 703
removing from sky texture 703
fog 701

G

geometry 505
mirroring 505
global quality level 693
granite texture 708, 713
graphics 4
in tutorials 4
grid snap 409
grid snapping 29-30
hot keys 29
grid spacing 408
setting 408
ground plane reflections 677
and hardware shade 677
ground plane shadows 665
and hardware shade 665
grouping 85, 119, 146
and organizing objects 85
controlling with object lister 119
hierarchical 146

H

hardware shade 268, 638, 664-665, 675,
677-678
and environment editor 675
and ground plane reflections 677
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and ground plane shadows 665
and lighting 664
enabling and disabling 268
saving images 678
viewing a model 638

help menu 17

hiding 175
CVs 175
hulls 175

hierarchy 146
grouping 146

history 330
construction history 330

hot keys 29, 43, 57-59, 63
camera move keys 63
camera move mode 59
customizing 58

hulls 175, 242, 531
changing display 175
understanding 242
using to modify shapes 531

icon size 51

interface options 51
image planes 163

enabling display of 163
images 678
implied tangent continuity 517
increasing 207, 728

reflectivity 728

spans, using control panel 207
information window 404, 477

and setting dimensions 477

use in modeling 404
installation 14

courseware 14
interface 17

control panel 17

main window 17

menu bar 17

overview 17

palette 17

shelves 17
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interface options 51, 66
iconsize 51
point of interest 66
intersecting 296, 343
and trimming surfaces 343
surfaces 296
intersecting surfaces 490
invisibility 117, 480, 489

controlling with object lister 117

obects 480

removing from objects 489
invisible 163

image planes 163
isographic camera view 75

K

keypoint curves 466
keypoints 413
moving 413

L

labels 651, 655
creating in visualize panel 651
mapping to color channel 655
layer symmetry 438
layer symmetry tools 593
layers 501
reference 501
layers, construction 227
assigning objects 227
lessons project 100
creating in Windows
environments 100
lighting 661, 664, 667, 670
(in tutorial) 661
adding lights 670
and hardware shade 664
placing directional lights 667
lights 667, 670
creating new 670
directional 667
Line tool 409
lines 414
fillet corner 414



lofted (skinned) surfaces 526
logging in to AliasStudio 15
logo, embossed 572

Lookat 63
tool 63

M

manipulating 19, 26, 65
point of interest 65
windows 19, 26

mapping 718,721, 723
bump 718, 723

surface placement tab 721
marking menus 43, 51-52, 54, 56
customizing 51, 54, 56
shelf window 54
shortcuts 43
using 52
mass properties tool 599
measure 407
setting units 407
measurement, volume 596, 599
and mass properties tool 599
measurements 403
absolute and relative 403
menu bar 17
location in AliasStudio software 17
menus 19, 26
using 19, 26
mesh tolerance 694
mirror tool 438
mirroring 282, 388, 505, 593
geometry 505
surfaces 282, 388, 593
modeling 407
specifying dimensions 407
modeling to accurate dimensions 403
modeling with primitives 91
models 6, 58, 78
changing view
definition 6
modifying 167
curves by moving CVs 167
mouse buttons 98, 113
use in non-proportional scaling 98

58,78

use in rotate tool 113
moving 23, 58, 78

camera 58,78

windows 23
moving keypoints 413
multi-lister 725

delete 725

deleting active swatches 725

N

nodes 79-80
node states 80
non-proportional scaling 98
mouse buttons 98

o

object lister 78, 80, 83, 117, 119
controlling visibility 117
grouping objects 119
window 80

objects 28, 35, 119, 227, 449, 480, 489
assigning to construction layers 227
controlling grouping with object

lister 119
duplicating 449
making visible 489
picking and unpicking 35
primitive tools 28
removing from display 480

offset 444
curves 444

opening 87
tutorial file in Windows

environments 87

opening files 87
in Windows environment 87

option boxes 33

overbuilding 282

overview 17
AliasStudio main window 17
control panel 17
interface 17
menu bar 17
palette 17
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shelves 17

P

packaged goods 546, 572
creating embossed logo 572
creating recessed label 546

palette 17, 26, 58
location in AliasStudio software 17
using 58

window 26
palette/shelf menus 31
password 15
patch precision 311

use in modeling 311
perspective view 74

versus isographic 74
perspective window 70

Viewing Panel 70
pick boxes 40
pick palette 36
Pick tools, using 37, 81

Component tool 81
picking 35-36, 41, 78, 83

all 36

by name 41
nothing 36
objects 35

using Object Lister 78, 83
pivot points 104, 430
setting 430
use in scaling and rotating 104
planar surfaces 199, 306, 462
creating in tutorial 199
planes 440
setting symmetry with 440
point of interest 65-66, 73-74
activating 66
locking 74
showing and hiding 73
using 65
positional continuity 516
primary surfaces 283
primitive NURBS objects
cone 32
creating 28

28, 32, 34
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cylinder 34
sphere 28
primitives 91, 179
circle, changing options 179
modeling with 91
projected curves 375
and trimmed surfaces 375
projects 88, 100
creating 100
creating lessons project
(Windows) 100
current (in Windows) 88
new (Windows) 100
renaming (in Windows) 100

R

radius, constant 319
on fillet 319
rail surfaces 291
raycasting 723
raytracing 723, 725, 729, 731
limiting reflections 729
reducing time 729
recessed label 546
reference layers 501
reflections 729
limiting 729
reflections, ground plane 677
in hardware shade 677
reflectivity 728
increasing 728
renaming 48, 76, 102
bookmarks 76
projects in Windows 102
tools 48
render 691
command 691
render globals 688, 693
command 693
global quality level 693
render menu 691, 693
globals 693
render 691



rendering 688, 691-694, 718, 723, 725,

729, 731
bump textures 718, 723
facetting (removing) 694
global quality level 693
limiting reflections 729
mesh tolerance 694
process 693
quality 693
quality variables 692
raycast 723
raytrace 723,725,731
reducing time 729
render globals 688, 693-694
tessellation 692, 694
variables 693
workflow 693
rendering options box 725
resizing windows 21
revealing hidden objects 489
revolved surfaces 465, 479
changing sweep angle 479
rhythm 368
scaling geometry copies 368
rotate tool 113
use of mouse buttons 113
rotating CVs for surface
modification 257
rotating surfaces 497
rotating using pivot points 104
round surfaces 567
round tool 435
rounding multiple edges 492

S

save as command 100

saving 44, 100
in Windows environments 100
shelves 44

saving files in Windows

environments 100

saving images 678
in hardware shade 678

saving with hardware shade 678

SBD 79
nodes 79

scaling geometry copies for rhythm 368

scaling using pivot points 104
scene 691
rendering 691
scenes 6
definition 6
Sections option 34
setting 407-408, 430
grid spacing 408
pivot points 430
units of measure 407
shaders 649, 654, 696, 725
creating labels (in tutorial) 654
deleting 725
environment 696

modifying with visualize panel 649

shaders, assigning 646
with visualize control panel 646
shaders, creating 643
with visualize panel 643
shading 268
hardware 268
shading models 640
Blinn 640
Lambert 640
light source 640
Phong 640
shadowed boxes 33
shadows 665
and hardware shade 665
shape modification 531
using hulls 531
shelf/palette menus 31
shelves 17, 42-46, 49, 51
adding tools  45-46
clearing 44
customizing 43, 51
location in AliasStudio software
removing tools 49
saving 44
shortcuts 42
shortcuts 42-43, 51, 57
hot keys 43, 57
marking menus 43, 51
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shelves 42,51

shelvesl 43

tools 42
showing CVs 175
showing hulls 175
simulating 701

cloud 701

fog 701

smoke 701
skin surface 326
skin surfaces 526
skinned surface 195

creation in tutorial 195
sky texture  699-700, 703-704

clouds 700

removing floor 703

sky button 699

sun 704

sunrise 704

sunset 704
smoke 701
smoothing between two surfaces 557
smoothing edges 435, 567

with round surfaces 567
smoothing multiple edges 492
snap buttons 30
snap mode 29

grid snapping 29
snapping 30

to grid 30
solid textures 706, 708, 713

granite 708
spacing 408

grid 408
spans 207

increasing using control panel 207
special effects tab 718
sphere primitive 28
splash window 16
split-line feature 416, 423
sponge surfaces 716
square surfaces 522
start-up screen 16
startingup 15-16

process 15

start-up screen 16

824 | Index

troubleshooting 16
workspace window 16
starting up AliasStudio 15
sub-palettes 29
sun 704
editing 704
sunrise 704
sunset 704
surface depth 420
with draft tool 420
surface fillet 319
chordal 319
circular 319
surface fillets 433
surface modification 172, 257, 535
and construction history 172
rotating CVs 257
using detach tool 535
surface orientation 596
and volume measurement 596
surface placement tab 721
surface textures 720
bulge 720
surfaces 195, 199, 217, 248, 291, 296,
302, 306, 310, 326, 341, 343,
388, 462, 465, 490, 497, 516,
522, 526, 557, 567, 593, 694,
716, 728-729
changing by moving CVs 248
continuity 516
extrusion 341
extrusion (in tutorial) 217
increasing reflectivity 728
intersecting 296, 343, 490
mirroring 593
mirroring (in tutorial) 388
of revolution 465
planar 306
planar (flat) 462
planar (in tutorial) 199
rail surface 291
reducing reflections 729
rotating 497
round 567
skin (in tutorial) 195
skin surface 326



skinned 526
smooth blending 557
sponge 716
square 522
tessellation 694
transitions 310
trimmed 302
trimming 343

sweep angle 479

changing in revolved surfaces 479

sweep option 34

switching between absolute and relative
measurements 403

symmetry 438, 440, 593

layer 438
layer tools 593
plane 440

T

tangency, implied 539
and birail tool 539
tangent continuity 516, 529
with align tool 529
terms S
in tutorials 5
tessellation 692, 694
definition 694
texture procedures window 697
opening 697
textures 697-701, 706, 713, 716, 718,
720-721, 723-724
bulge 720
bump 718,723
cloud texture 700
deleting 724
environments 697
fractal 701
sky 699, 706
solid 698, 706, 713
sponge 716
surface 697
surface placement tab 721
three point arcs 476
tolerances, construction 517

tools 33, 42, 45-46, 48-49, 51, 58, 81
adding to shelves 45-46
options 33
picking components 81
removing from shelves 49
renaming 48
shortcuts 42
small icons 51
using 58
tools palette 58
tracking 58
transition surfaces 310
trim 546
label area on packaged goods 546
trimmed surfaces 302, 375
using projected curves 375
trimming 282, 343, 457
intersected surfaces 343
surfaces 457
troubleshooting 16-17
during start-up 16
using help menu 17
tumbling 58, 63
in orthographic windows 63
turning hardware shade on and off 268
tutorial file 87
opening in Windows
environments 87
tutorials 4-5
graphic conventions 4
terms S

U

undo 174
units of measure 407
setting 407
unpicking 35
objects 35
user account 15
user name 15
using 17, 19, 26, 37, 40, 51, 57-38, 70,
91
AliasStudio 17
hot keys 57
marking menus 51
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menus 19, 26
pick boxes 40
Pick tools 37
primitives 91
tools 58
Viewing Panel 70

A\

view 58,78
changing 58, 78

viewing a model with hardware

shade 638

Viewing Panel 70-71, 73-75
bookmarks section 75
perspective option 74
point of interest section 73
using 70
view directions 71

visibility 117

controlling with object lister 117
visible image planes 163
visualize control panel 641, 643, 646,

649, 651
assigning shaders 646
creating labels 651
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creating new shaders 643

modifying shaders 649
volume measurement 596, 599

and mass properties tool 599

w

window 17
location in AliasStudio 17
windows 19, 21, 23, 26, 31
active 26
arranging
closing 21
moving 23
palette 26, 31
resizing 21
Windows environments
opening filesin 87
opening tutorial file 87
saving filesin 100
workflows 3
concept design 3

19, 26

87, 100

X

X Y Z coordinates 403
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